not a valid Win32 application...

hello,

I am using Nsight Visual Studio Edition 3.1 (VS ultimate, update 3) and receive the following error:

%1 is not a valid Win32 application (System.ComponentModel.Win32Exception)

I read through the User Guide, but did not find any reference to this error.

about my project, it uses XAML/C# and target platform is currently x86; however, I will also be targeting the Tegra 3 device on the Surface RT (ARM). But I want to first get familiar with nsight, simply using my desktop (currently using 326.41 drivers as provided by your links). This “windows store app” basically creates a frame for the XAML/C# portion, then sets up a SwapChainBackgroundPanel in which Unity (game engine) hooks DirectX.

I’ve tried compiling debug and release; however, i receive same error when attempting to start graphics debugging.

Nsight system info explorer provides great details and the nsight monitor is running fine.

Am I just attempting to do something that is not possible?

Bumping this since I am having the exact same problem with the latest version of Nsight (4.0) using Visual Studio 2013.

Hi,
We are debugging Cristina’s report now…

Hi,

any news here? This is blocking us as well…

My .exe is a C++/CLI .NET 4.5.1 x64/Debug application, the dlls to debug with NSight are x64 Plain-C++ dlls compiled with VS2010 (v100 Platform toolset).

NSight 4.0.0.14142 / VS Ultimate 2013 12.0.30501.00 Update 2

Regards,
Lars

Same issue for me:

  • NSight 4.1;
  • Visual Studio 2013 Ulitmate Update 3;
  • Application in C# .Net 4.5 using OpenTK.

Hi,

Nsight don’t support .Net App officially. But you can build your .Net app in x86, x64, AnyCPU, and take a try, that might be work, anyhow, managed app is not support officially.

Thanks
An