Nsight in Visual Studio does not display Cuda Source View in Profiler

Hi,

In the following video, title Profiling and Optimizing CUDA Kernel Code with NVIDIA Nsight Visual Studio Edition 3.0 the author shows a use case where he can get Source Code and SASS code at the same time in the tab Cuda Memory Transaction

I followed the instruction here
https://docs.nvidia.com/gameworks/content/developertools/desktop/analysis_source_code_correlation.htm

but there is no such choice a) Source and SASS) nor b)Source and PTX in my case.
Only c) PTX and SASS and d) SASS Only and e) PTX only are available.

How to display properly the Source code ?
I use

  • VISUAL STUDIO 2017
  • Nsight 5.5
  • Windows 10

Thanks for your help,

did you compile your project with the -lineinfo switch?

what GPU are you running on?

Yes I selected Yes (-lineinfo) and I use a GTX 1080 Ti
But now it works beacsue I restarted Visual. So the issue is more on VS I think …

Hi Robert,
I have the same issue, but I can see the correlated cuda-c and ptx code, the sass code isn’t available.
More specifically, in the sass pane, it shows line, address, instructions executed correctly, but the source column shows ???.

I’m running

  • CUDA 10 (no patch)
  • Nsight 6.0.0.18227
  • VS2015 14.0.23107.178

On a GTX780Ti card. And yes, I’ve enabled the -lineinfo in project settings, although nvcc always complains that

nvcc warning : '--device-debug (-G)' overrides '--generate-line-info (-lineinfo)'