Nsight nsys cannot collect cuda information

I flashed a drive os 5.2.6 on our pegasus board, everything looks fine both the host and target except the previous problem using nsight nsys, I still cannot get the cuda information.
I used nsight system 2021.4.1 CLI on the target and collect the report and transfer to the x86 host for displaying the information.

move this topic to DRIVE AGX General - NVIDIA Developer Forums.

Please take a look at Nsight Systems User Guide :: Nsight Systems Documentation of DRIVE OS 5.2.6.

@VickNV Actually I used CLI when I first tried my profiling on drive os 5.1.6 so I think I am familiar with the process. But anything special to pay attention to?

I still get the same error saying that cuda collection stopped and no cuda profiling is done (only the CPU stuff, context et al, which are not of interest to me now).

Any clue on this? I have 5.1.6/5.2.6 not working, but 5.2.0 OK.

Please share the detailed steps. Thanks.

@VickNV Here is the screen dump:

nvidia@pegasus3b:~$ cd baseline-cipher/
nvidia@pegasus3b:~/baseline-cipher$ nsys start
start executed. use the ‘launch’ command to start the collection
nvidia@pegasus3b:~/baseline-cipher$ nsys launch ./baseline
WARNING: CPU sampling requires root privileges, disabling.
WARNING: ‘timer’ backtrace collection trigger will not be used because sampling is disabled.
WARNING: ‘sched’ backtrace collection trigger will not be used because sampling is disabled.
application launched
TIMING: 553.184 ms (allocate memory)
TIMING: 80468.1 ms (encrypt data on CPU)
TIMING: 30.2844 ms (copy data from CPU to GPU)
TIMING: 124.34 ms (decrypt data on GPU)
TIMING: 30.3676 ms (copy data from GPU to CPU)
TIMING: 185.403 ms (total time on GPU)
STATUS: test passed
TIMING: 13.7855 ms (checking result on CPU)
TIMING: 487.828 ms (free memory)
Processing events…
Saving temporary “/tmp/nsys-report-3fd5-8fac-516e-f56d.qdstrm” file to disk…

Creating final output files…
Processing [===============================================================100%]
Saved report file to “/tmp/nsys-report-3fd5-8fac-516e-f56d.nsys-rep”
Report file moved to “/home/nvidia/baseline-cipher/report2.nsys-rep”

How you set up nsys on the target system? Which version are yous using?

@VickNV I use Nsight Systems 2021.4 (Arm Server CLI only .deb Installer) and then install it using sudo apt-get install. version 2021.4.1

Please try with the one installed by SDK Manager (in /opt/nvidia/nsight-systems/2021.2.2/).

@VickNV I have to reflash the system, someone messed up the system. I will get back to you when it is ready. Thanks

@VickNV I reinstalled drive os 5.2.6 but did not find nsys 2021.2.2. Can I install nsys 2021.2.1?

Was nsight system in host components installed successfully in sdkmanager?

@VickNV sdkmanager for drive os5.26 installation on host has no problem at all

@VickNV I have tried nsight system 2021.2.1 and it works!!! Thanks for your support and finally solved the profiling problem!!

Good to hear it works on your side.