Nsight VSCode debug not running on remote server

I am attempting to debug cuda programs on a remote server. I have set up the Remote-SSH extension for VSCode and that seems to be working perfectly. However, I can not get any file to actually run with or without debugging using the NSight extension. The indicator bar appears, but nothing happens and there is no output in the debug console.

nsight_broken

I believe I followed all of the steps for setting up the extensions correctly. My cuda file builds correctly and I am even able to run cuda-gdb on the file through a terminal, but cannot get it to run using VSCode.

This is what my launch.json file looks like:

{
    "version": "0.2.0",
    "configurations": [
        
        {
            "name": "CUDA C++: Launch",
            "type": "cuda-gdb",
            "request": "launch",
            "program": "${workspaceFolder}/test1"
        }
    ]
}

I also have cuda correctly added to the PATH variable on the remote server, so that should not be the issue.

2 Likes

Is cuda-gdb in the path on the remote machine? Also try setting debuggerPath in your launch.json to the absolute path to cuda-gdb.

cuda-gdb is in the path on the remote machine. I added this line to the launch.json file:

"debuggerPath": "/usr/local/cuda-11.2/bin/cuda-gdb"

That path works for running cuda-gdb directly from the terminal.
Now the debug console simply outputs this:
Failed to find cuda-gdb or a dependent library.

I had the same issue and libncursesw version was the problem. This command fixed my issue:

ln -s /usr/lib/x86_64-linux-gnu/libncursesw.so.6 /usr/lib/x86_64-linux-gnu/libncursesw.so.5

Hi mvosseteig, I have exactly the same issue. How did you solve this problem?
the above solution with symbolic link doesn’t work for me :(

3886100