NVCC Not Found

I recently updated my system to Ubuntu 16.04 and I am receiving a new error when trying to compile my code.

/usr/local/cuda-6.5/bin/nvcc: not found
subdir.mk:18: recipe for target 'demo.o' failed
make: *** [demo.o] Error 127

When I go to “/usr/local/cuda-6.5/bin/” I only see links to “gcc” and “g++”
I have not touched the cuda toolkit in a long time and have not seen this error before

I checked some other forums to figure out what was going on and I guess my cuda toolkit somehow vanished?

whereis nvcc



I can’t install the DEB cuda toolkit 6.5 because I get the following error (I am running Ubuntu 16.04):

http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1404/armhf/Release.gpg: Signature by key 889BEE522DA690103C4B085ED88C3D385C37D3BE uses weak digest algorithm (SHA1)
E: Failed to fetch http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1404/armhf/Release  No Hash entry in Release file /var/lib/apt/lists/partial/developer.download.nvidia.com_compute_cuda_repos_ubuntu1404_armhf_Release which is considered strong enough for security purposes
E: Some index files failed to download. They have been ignored, or old ones used instead.

I tried installing with a RUN installation and that worked well but my system is an ARMv7 32 bit and the RUN installations are only for 64 bit so that also did not work.

What do I do? I need the nvcc compiler on my system so I can work on my code

No sure if below topic can help you.


There is mention that CUDA 6.5 can be installed on Ubuntu 16.04 but no instructions on how to do so. I have tried installing the DEB and following the official documentation but I keep getting the “No hash entry which is considered strong enough” error


Do you setup the TK1 with JetPack?