[NVidia 319.12] Brightness controls not working on laptop (Ubuntu 13.03)

Hi all,

I am using Ubuntu 13.03, with the latest xorg-edgers ppa installed.
And just installed the latest NVidia binary driver trough the repository.
After a reboot, I found out that my brightness controls are suddenly not working anymore.
With the 304.x and 310.x drivers the controls were working fine.

My HW:
HP EliteBook 8560w
NVidia Quadro 2000M
Intel Core i7-2670QM

My SW:
root@priyantha-HP-EliteBook-8560w:~# cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=13.04
DISTRIB_CODENAME=raring
DISTRIB_DESCRIPTION=“Ubuntu Raring Ringtail (development branch)”

Linux priyantha-HP-EliteBook-8560w 3.8.0-17-generic #27-Ubuntu SMP Sun Apr 7 19:39:35 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

PS. I am going back to a previous version now, because I can’t work without having those controls working, but I am perfectly able to test some things out if asked, a reboot and a reinstall of the driver is done in a minute.

Thanks in advance!

[edit]
Just installed this version 313.30-0ubuntu1~xedgers~raring1, with that version the brightness controls are working like it should. So it looks like a regression for the 319.12 version specific.
[/edit]

More than 147 views, but nobody sees the urge to drop a reply ? :(

I can only confirm this problem. After installing this driver kernel do not recognize some scancodes of keys(lol, where is correlation?); udev does, but loading of custom keymap do not help, xbacklight do not work too.

This problem has also affected KDE, up to version 4.10.1.
With the release of KDE 4.10.2, the brightness control works again.

My only idea is booting the kernel with the:

acpi_backlight=vendor

boot option and seeing if there is any difference.

any difference with controls.
before:

$ ls /sys/class/backlight/
acpi_video0  acpi_video1  intel_backlight

after

$ ls /sys/class/backlight/
intel_backlight  samsung

I can always change backlight by

echo 50 > /sys/class/backlight/acpi_video0/brightness

but on my laptop probles is with keys scancodes - after installing 319.12 driver kernel do not recognize some fn-keys.

Problems are still here on my laptop.
Is there an updated version comming ?

Nothing ???
This problem makes the driver just unusable…

Well just installed a new version of the driver, the 319.17, but it did not help :(

Is there anybody who may help me with this ? This way the laptop is not really good usable with this driver installed :(

A new topic kick…
Would be nice to have this solved :(

Oops, I notice I just created a duplicate bugreport via eMail as this has been posted here already.

However, I can suggest a temporary solution: Use the older driver version 295.33 . Going back to that driver will make the brightness control work again.

@vacaloca: While I was troubleshooting, I had tested acpi_backlight=vendor but even then the brightness control wouldn’t work.

edit: My report via eMail copes with the current version 319.17, so updating won’t help you yet.

Internally filed Bug 1351054 : [NVidia 319.12] HP EliteBook 8560w Brightness controls not working on laptop (Ubuntu 13.03)

I have a ASUS K55VM Ivybeidge i7 laptop with Nvidia GT630M GPU. I installed latest Ubuntu 12.04.3 which automatically installs nvidia drivers 319, nvidai-prime and raring 3.80 kernel for full optimus support out of the box including modified light DM etc. I noticed that even with the older kernel, my brightness key didn’t function and I couldn’t control brightness with any software either. The solution to this was to add kernel parameters

GRUB_CMDLINE_LINUX_DEFAULT="splash quiet acpi_osi='!Windows 2012'"

in GRUB and now everything works, I can control brightness with indicator-brightness or gnome setting panel.

Any updates on this?
It’s still not working here.
Now running Ubuntu Saucy and the latest Nvidia 331 version.

https://devtalk.nvidia.com/default/topic/639374/recent-nvidia-drivers-are-not-able-to-control-screen-brightness-on-hp-elitebook-mobile-workstation/#4016177

Do you have exactly the same problem as I described in my post? If so, then mine is a duplicate. However, I hope that if Nvidia sees more users “complaining”, the more chance we will have for a fix being released.

Priyantha, We are still investigating this issue …

Let me chime in with what appears to be the same problem.

I’m using a Lenovo T61p with a Quadro FX 570M. I’m running Gentoo with xorg-server-1.14.3. I updated the nvidia-drivers package to 331.20 and then 325.15. In both cases my brightness control did not work. After finding this thread I tried again with 313.30, and the brightness controls work again.

It’s worth mentioning that even though the brightness controls did not work while in X, they nevertheless did work after changing to a text TTY.

While researching, I found some info from http://www.gentoo-wiki.info/Lenovo_Thinkpad_T61#hotkeys_.28Fn-Fx_combinations.29 that seems relevant:

"Brightness controls (Alt F10,F11) are hard wired, but only have effect while in text-mode, or using xorg-vesa- or xorg-nv-driver. x11-drivers/nvidia-drivers-169.07 supports xorg brightness control, too. "

It’s obviously a bit old, but you get the picture. Can anyone else confirm whether the problem only exists for them while trying to change brightness from inside X?

guys,
i have the same issue with ubuntu 13.10 on my lenovo ideapad y510p (GeForce GT 750M/PCIe/SSE2).
brightness control movements on ubuntu/ fn+arrow pressing key registered by ubuntu but no effect on monitor brightness.
i managed to reduce brightness using nvidia x server setting on DFP / color correction, new settings does not survive long on running system (have to adjust manually again) nor survive restart.
this is very annoying… i remember to adjust brightness when my eyes start burning (and then it’s too late)… :)
hope to see solution soon!

Hi,

May I request a status update on this bug?
Also, has anyone found a hack/workaround?

Hey!

I have Thinkpad W530 with Quattro K1000M card and have the same problem. I currently use the 331.38 driver.

I found a custom kernel module at github.com/guillaumezin/nvidiabl, it’s in the repositories of my Gentoo package manager, maybe you have it available too.

For now I can set the brightness by doing echo 100 > /sys/class/backlight/nvidia_backlight/brightness.

But I had to first tweak the modprobe to “modprobe nvidiabl min=400 max=12000”, before the 127 steps corresponded to a good dim to full brightness. Don’t make min too low. You won’t be able to read the screen when setting brightness to 0 ;)

When loading the driver, it is on max brightness, cat actual_brightness shows the value, tweak it until the value corresponds to max_brightness.

Cheers,

leipie