Nvidia 340.24 problems with hibernation and suspend

This is a bug related to both hibernation and suspend on linux Mint 17 x64, X server version 1.15.1 (11501000), NV-CONTROL Version 1.29 with a GeForce GTS 360M video card.
When trying to hibernate my computer the hibernation never completes. A green screen is shown for a fraction of a second and the CPU spikes and the computer never turns off.
When suspending the computer things work partially: the computers suspends and resumes fine but the powermizer performance level is forever stuck at level 1 (my card has level 0, level 1 and level 2).
The interesting thing is that after suspending and resuming, forcing the powermizer level to be stuck at level 1, hibernation and thaw work with no problem.
This problem is reproducible 100% of the time so far.
Is there any additional log information that should I submit?
nvidia-bug-report.log.gz (77 KB)

Also, 2 topics I created in Ubuntu Forums and Linux Mint forums follow:

http://forums.linuxmint.com/viewtopic.php?f=49&t=173531

http://ubuntuforums.org/showthread.php?t=2234591

and because the website says that it is scanning the log file and never finishes, this is the pastebinit link for the nvidia-bug-report.log.gz file:

http://pastebin.com/tSc9u6dr

I am willing to help the developers to find a solution to this annoying problem.
Thanks!

Suspend doesn’t work for me at all, so consider yourself lucky.

NVIDIA refuses to fix my problem and they refuse to decode the errors that my GPU is spewing on resume. A funny company. I guess, I won’t buy any discrete GPUs any more.

Yeah… I guess they don’t care much about linux users…

Heyyo,

nVidia does care… but just like AMD? Their Linux Dev team is only a small group compared to the Windows driver team. They have been putting in efforts though like 4k resolution support and preliminary G-Sync support as well, but many issues still remain. My main issue is the lack of proper SLI support needs to be upgraded to support more than the old and tired ID Tech 4 Engine-based games… I doubt many people play those on Linux these days. I did inform the Linux driver team about the issue and they are looking into it… not sure how far they’ve gotten.

I run EVGA GTX 680’s and so far I haven’t had problems with suspend and Hibernation running Xubuntu 14.04 with kernel 3.13 and 340.24 drivers… same with Antergos with 3.15 kernel and 340.24 drivers & Manjaro on 3.15 with 340.24 drivers… I also used to have GTX 480’s and didn’t have problems with suspend or hibernation on those as well.

I saw in the other thread you’re running CentOS which is Red Hat based… have you tried a different Linux Distro to see if for some reason it works fine on others such as Arch? I’m not saying “oh you have to switch” I’m just saying if you have some free space on your HDD or SDD to partition a spot and see if for some reason it’s just CentOS that’s giving you grief or maybe something that CentOS installs might be causing you problems. Same goes for you Marcelo, might as well try a different distro to confirm if it’s drivers or maybe just certain kernels or software incompatibility.

Suspend and hibernate are carried out by one and one only component which is called the Linux kernel. I run vanilla kernel which is free from questionable patches most distros emply.

Which unfortunately means switching distros is futile.

Switching kernels or NVIDIA drivers could have helped but when your PC is completely dead on resume, there isn’t much you can do.

Heyyo,

It’s just I find between distros I have hardware issues myself. I can’t even use Manjaro at home because in there my mouse jumps like mad around the screen… Logitech G500… same goes for sound on my Soundblaster CA0132 Recon3D. I can get it to work fine in Xubuntu and Antergos but my work-arounds don’t work for Manjaro… so sometimes distros can act oddly. You can’t say you’ve tried everything if you’re not even willing to try a different distro and try different kernels is what I’m saying. Might surprise yourself. Besides, even with the Vanilla Kernel, most distros do their own builds of it… maybe some add in their own patches? I know SteamOS makes their own customized versions of the vanilla kernel.

Do you have enough space in the swap partition? In order for hibernation to work, you need at least the size of you RAM or more in the swap.

UPDATE: I just saw that it works at times for you, so that must be not swap related then.