nvidia-340 fails to work with 8600GTS.

Brief explanation:
As far as nvidia-173 is unavailable for Ubuntu 14.04 I installed nvidia-340 via apt-get. (known as the legacy driver for 8XXX-9XXX)
After reboot all I’ve had was a black screen (w/o mouse pointer) after some usual boot messages. I switched to console using Ctrl+Alt+F1 and did a bug report.

Story:
That problem was with me since 2012 when I tried to update NVidia driver on MS Windows and the symptoms were the same: black screen (w/o mouse pointer) after bootscreen. So I deleted new driver and installed the old one.
Couple of years later I changed my system to Ubuntu 12.04 and latest drivers didn’t work in the same way: black screen after boot. So I used nvidia-173 which worked just fine.
And today I’ve installed Ubuntu 14.04. After first unsuccessful try of nvidia-340 I installed nvidia-304 and manually tweaked xorg.conf, all I got were black screen but now w/ pointer and ability to push it behind the right edge of the monitor which didn’t help me at all.

I need to use this PC as soon as possible so I would like any help concerning my problem.

Thanks in advance.

https://www.dropbox.com/s/13wu1hkbxmv9rx6/nvidia-bug-report.log.gz?dl=1