Ubuntu 14.04 boots to black screen after installing drivers on Geforce GTX 960m

I tried again by running

sudo apt-add-repository ppa:graphics-drivers/ppa
sudo apt-get update

and then selected 367.35 from the list of additional drivers. The issue is still black screen after reboot. Attached is the nvidia-bug-report.

Thanks!

nvidia-bug-report.log.gz (143 KB)

duplicate of https://devtalk.nvidia.com/default/topic/950647/linux/black-screen-with-367-35/ ?

Hi Licaon, thanks a lot! But this is not exactly a duplicate. We tried 364.19, 367.27 and 367.35. None of them ever worked. A switch to VT1 and back didn’t work either.

According to the Ubuntu “Graphics Drivers Team”, maybe the issue is the drivers’ lack of support for Optimus as we are testing a laptop GPU, and we will need to wait for Nvidia to fix the problem. Do you agree with this?

From the thread you provided, I also found this.

Maybe we should try this.

tpruzina’s suggestion worked.

I followed Nvidia’s Readme http://us.download.nvidia.com/XFree86/Linux-x86/319.12/README/randr14.html with the exception of using ~/.xsessionrc instead of ./xinitrc for adding the x session startup scripts.