Nvidia A2000 + Gnome = low fps-rate for desktop animations

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

Thanks for reopening @mods! On standby for further details or instructions.

Any ideas or anything that you guys want me to try out? I would try to the open kernel module drivers but I’m not sure how well these are currently supported for normal desktop work and gaming plus video recording via nvenc etc. Also not sure how well these work on OpenSUSE, but at least they’re in Beta now.

Cheers

Hi @Sturmlocke
I have retried repro again recently with fresh OpenSuse 15.3 setup with 3 displays connected but still no luck in repro.
Gigabyte Z170X-GamingG1 + Intel(R) Core™ i7-6700K CPU @ 4.00GHz + OpenSuse 15.3 + kernel 5.3.18-150300.59.106-default + NVIDIA RTX A2000 12GB + Driver 550.54.14 + Asus PG38UQ with 4k resolution & 60 Hz refresh rate + Asus 27AQDM with 2k resolution & 60 Hz refresh rate + Asus VG279QM with 2k resolution & 60 Hz refresh rate

VBLANK and Allow Flipping is enabled and Force Composition Pipeline is disabled. Powermizer is at max performance.

Could you please confirm if issue is reproducible with only single display connected.
Is it possible for you to check on fresh OS to rule out any configuration issue.

Hey there amrits, I can confirm the issue also happens with a single display connected, but only if it’s the 4k display at 4k resolution. If I switch to 2k or 1080p on the 4k display instead, it runs buttery smooth again. The same effect can be seen when switching monitors to a single 1080p display = everything runs super smooth again. So right now it seems like the 4k resolution is causing Gnome to underperform because it runs very smooth at lower resolutions. I can also confirm the rest of the system config: VBLANK and Allow Flipping is enabled and Force Composition Pipeline is disabled. Powermizer is at max performance. A few differences though: A) All of this goes for OpenSUSE Leap 15.5 with its more recent default 5.14+ kernel (you’re using 15.3 with an older kernel it seems) B) I have an RTX A2000 with 6GB of vram.

Yes, I have taken this entire week off and I am using some of that time to test these things further. I uninstalled OpenSUSE 15.5 Leap and reinstalled Tumbleweed yesterday, but I also gave Ubuntu 22.04 LTS and Ubuntu 23.10 another go on this machine for comparisons sake. In addition, I also gave the 550 and 545 open kernel module drivers (beta) a shot too while at it. This time no Powermizer modifications at all (default settings), VBLANK and Allow Flipping is enabled and Force Composition Pipeline is disabled.

Tumbleweed: Tested both proprietary 550 and open kernel module 550 drivers (beta). Tumbleweed now ships with Gnome 46.

Tumbleweed Xorg/X11: Same behaviour as before with Leap. Strong fps drops when using the Gnome overview and its animations.

Tumbleweed Wayland: Performs much smoother and manages to hit and maintain 60 fps faster even at 4k resolution and even with a triple monitor setup. There are a few additional fps drops here and there when switching between multiple workspaces with Steam and Firefox open in the background, but overall it’s a big improvement over Leap and X11. The main problem here is that there is still some flickering and glitching to be seen in certain situations (Steam+gaming), seemingly due to explicit gpu sync still being work in progress on Wayland:

https://www.phoronix.com/news/Explicit-GPU-Sync-XWayland-Go
https://www.phoronix.com/news/KDE-Wayland-Explicit-Sync-Goal

Ubuntu 22.04.4 LTS: Tested both proprietary 550 and open kernel module 545 drivers (alpha/beta?).

Xorg/X11: Pretty much suffers from the same issue that OpenSuse Leap has = fps drops with Gnome animations.

Wayland: Super smooth similar to Tumbleweed with Wayland.

Ubuntu 23.10: Tested both proprietary 550 and open kernel module 545 drivers (alpha/beta?).

Xorg/X11 and Wayland: Lo and behold, both are performing very smooth now at 60fps even at 4k resolution with the same triple monitor setup. X11 is already much smoother, albeit a tiny bit slower sometimes, but Wayland is the best. I wasn’t able to try the open kernel module drivers V550 on Ubuntu because the “additional drivers” app only offers 545 for the desktop. There is a V550 open kernel SERVER edition, but I didn’t test that one during this run. On Ubuntu 23.10 it feels like Canonical’s triple buffering solution is finally kicking in correctly because I know that “feeling” very well from other computers using Ubuntu’s triple buffering vsync solution on Gnome as it makes everything feel super fluid and pristine. Maybe Ubuntu fixed something for this release that has not been backported to earlier Ubuntu releases yet? Whatever the case, 23.10 is performing really well and most Gnome animations are super smooth too. I say “almost” and “most” because similar to Tumbleweed+Wayland, you can see a slight fps drop when Firefox and Steam are open and when you switch between workspaces, but overall it’s performing the best out the whole bunch - even better than Tumbleweed+Wayland.

Verdict: So for now it seems like Ubuntu 23.10 is performing the best and is giving me the most fluid Gnome experience thus far. Side note: I also tried both OpenSUSE and Ubuntu with KDE and KDE didn’t have any of these performance issues. That said, I am sticking to Gnome because I prefer it over everything else. I really wanted to continue to use OpenSuse on this machine, but I might consider doing Ubuntu 23.10 if all else fails.

Update: I continue testing for as long as I can (will have to stop by the end of this week / this weekend). So far Ubuntu 23.10 remains the only option where both X11 AND Wayland are performing really well under Gnome with beautifully triple synced vsync. Ubuntu 22.04.4, 23.04, OpenSUSE 15.5 Leap and even Tumbleweed all have major performance issues with Gnome’s animations using X11. If I switch to Wayland, performance / fps increases nicely even at 4k60 resolution for all of the distros that I mentioned - excluding OpenSUSE Leap 15.5 where Wayland can still be seen stuttering and lagging.

Thus far the only thing that manages to actually help with X11 Gnome performance is launching nvidia-settings once for the current session until reboot. In addition, I also found this repo for Tumbleweed: Show home:tjyrinki_suse:branches:openSUSE:Factory / mutter - openSUSE Build Service

More info here: GNOME Dynamic Triple Buffering patch on openSUSE | Timo's openSUSE Posts

Which enables Ubuntu’s triple buffering solution for Tumbleweed users. It works really well under Wayland, which makes animations even smoother than before, but for X11 I still have to manually launch nvidia-settings once in order to bring desktop animations under Gnome up to 4k60fps most of the time. Not sure if Timo is using the latest and greatest triple buffering / Mutter development from Ubuntu 23.10, or if he’s using the Gnome 42 Ubuntu 22.04 triple buffering patch-set, haven’t had the time to check yet, but at least this remains a usable option until vanilla Gnome gets official triple buffering support one day. IIRC Ubuntu continues to tweak, optimize and enhance their triple buffering feature with every interim release and its corresponding version of Gnome coming after 22.04 LTS.

In addition, as mentioned previously, if I don’t launch nvidia-settings under X11 at least once during the session, I have also seen windows behave the same way that the person is showcasing in this video under KDE: So when will desktop performance issues be addressed by nvidia?

Window resizing = low fps, sometimes even tearing and stuttery behaviour before launching nvidia-settings. This issue does not occure under Wayland and can only be seen under X11.

Now… I understand that explicit sync is almost ready to launch for Nvidia + Gnome 46 + Wayland etc. and that we’re most likely going to be seeing an Nvidia driver update supporting these features next month, which would mean that Proton gaming and normal desktop usage gets fixed for Nvidia users under Wayland. I might just wait until that happens and transition over to Wayland the moment that our drivers get updated in openSUSE, but it would still be nice to understand why X11 is behaving this way on my A2000. Again, only Ubuntu 23.10 manages to render Gnome both on X11 and Wayland buttery smooth. What’s the difference between Ubuntu 23.10 and everything else on the list? Is it Ubuntu’s newer and more mature triple buffering patch in 23.10?

PS: I’ve been testing the open kernel module drivers V550 (beta) on both Ubuntu 23.10 and openSUSE Tumbleweed and so far gaming and normal desktop usage has been a really good experience on my A2000. Will test some more games and also do some screen recording to check how the new drivers perform on a daily basis.

Cheers

Update, Tumbleweed + 550 open kernel module drivers enabled: So, I decided to disconnect the two other monitors and use only the 4k Samsung monitor with Timo’s triple buffering repo enabled on my Tumbleweed box, see previous message. Previously I had tested this single monitor setup with TW but without Ubuntu’s triple buffering vsync patches. To my complete surprise, the desktop is now rendering its overview and desktop switching animations at buttery smooth 4k60fps again - even on X11. The only thing still losing fps is resizing windows, which looks similar to what you can see in the KDE video mentioned in my last post further above. On Ubuntu 23.10 all of this works well under X11 even with all three monitors connected, that’s not the case on TW as of this writing, but that’s ok for now. This just goes to show how important Ubuntu’s additional tweaks and contributions are at fixing severe performance issues and at addressing missing features compared to vanilla Gnome.

In addition, I also noticed that a lot of games were experiencing severe tearing and weird fps hiccups under load on X11, even with vsync enabled in-game, which is being discussed in different thread here in the forums, so I enabled Gsync on my Freesync compatible 4k monitor and left the other two monitors disabled. Lo and behold, no tearing in games anymore and framerates are super smooth too (Steam+Proton). Everything is super smooth now from normal gameplay to normal desktop usage under load.

To that end, since I’m running out of testing time, I’m going to ride with this setup until you guys drop the V555 drivers with explicit sync support next month, which should fix all / most (?) of the show stopping issues under Wayland for us Nvidia users. It’s only a few weeks of waiting until then, and since time goes by so fast, I can live with the workaround above for the time being.

Thanks @everyone!

Thank you @Sturmlocke for multiple isolations at your end.

To my complete surprise, the desktop is now rendering its overview and desktop switching animations at buttery smooth 4k60fps again - even on X11.
If I have understood correctly, you no longer seeing issue for desktop animations on on X11, please confirm as I am still not able to recreate issue after testing on multiple setups with different OS.

Hi @Sturmlocke
Please confirm if you are still seeing issue with latest driver 550.78

Hello Amrits,

sorry for the late reply, didn’t realize you posted until now.

On Ubuntu 23.10 and 24.04 it’s no issue even with driver V535. On Ubuntu Gnome is super smooth. I have a separate drive with openSUSE Leap 15.5 here and will retest with 550.78 and report back. In fact, I can try tonight.

Update: On openSUSE 15.5 Leap with 550.78 the issue remains and I still have to start nvidia-settings once for the Gnome animations to become smooth at 60 fps. What I noticed is how Ubuntu actually has nvidia-settings in their start-up programs (Ubuntu has a preinstalled app to configure start-up programs). Could this have something to do with it? Would starting nvidia-settings during boot help on openSUSE? How would I make nvidia-settings launch at start-up on openSUSE?

You can create a systemd service or use your desktop environment’s start-up applications settings to make nvidia-settings launch at start-up on openSUSE.

Meanwhile, I will update my OpenSuse linux to match your config and will retry for local repro.

Thanks @amrits.

Question, I added nvidia-settings via start-up script in Leap, but it always launches the entire app shortly after a boot, and it also sometimes causes the desktop to freeze or not show up properly. Can you compare to Ubuntu and tell me how Ubuntu is doing this? Because on Ubuntu nvidia-settings doesn’t launch as app during start-up and whatever Ubuntu is doing happens in the background. You can check on Ubuntu by using the preinstalled start-up manager. Search Gnome for “start program” or something to that effect and it’ll show up. In there you can see what I mean.

Could this be of any help? → [SOLVED] How to startup Nvidia at the boot time? / Newbie Corner / Arch Linux Forums

“nvidia-settings -l”
“nvidia-settings --load-config-only”

Cheers