Nvidia black screen bug in Firefox(hardware accelerated) and in kwin(lockscreen) after suspend

When firefox has layout.acceleration.force-enabled set to true and kwin uses compositing both will end up glitching and going full black after I wake my PC from suspend. This only happens on nvidia GPUs.

Please check if it also happens when you set this up:

Now suspend simply just doesn’t work…

Which driver version, what kind of hardware are you using (vmem size)?

I’m using an RTX 2080, 440.64.

Ok, so you have at least 8GB VMEM, I suppose. This will need to set the tmp location. Which steps did you take to enable vmem saving?

I only enabled the systemd service and the mentioned kernel parameter.

The files
There are three systemd units to be enabled.

I only enabled the suspend service, I don’t use hibernation(sleep). The suspend command doesn’t work through systemctl, probably the nvidia-sleep script can’t handle it.

nvidia-resume has also be enabled.
So do those files exit at all?

They don’t work with nvidia-resume either. Even if I remove the parameter they still don’t work.