Nvidia driver 510.68 does not run on fedora 36 after update to kernel 5.17.9


I updated my kernel to 5.17.9 today and nvidia driver for my gpu gtx3080 stopped working, and i found out the issue by trying to run nvidia-smi and got the error message NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

I have tried to downgrade my kernel, reinstall the driver, so far no luck. Please find the bug report attached.
nvidia-bug-report.log.gz (109.9 KB)

Thanks in advance!

Have you tried in install the latest driver 510.73.05?

hello, i have not tried as it is not yet available on rpmfusion. i can give it a try, thanks.

You set your system compiler to gcc 8.2 but you need gcc 12 to build the modules for your kernel. Please switch to the correct gcc, then try reinstalling the driver.

1 Like

Hello, this was indeed the issue. I changed the default gcc into 8.2 to allow matlab cuda running. Now i changed the system default back to gcc 12 it is working perfectly. Thanks very much for you help!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.