Nvidia Drivers 319.12 / Xorg 1.14 / Optimus and Dual-Screen

Hi,

i have tried the new Optimus Support with the current Beta drivers. First: Thx! It works. On a single Monitor, i don’t have any problems.

But i’m unable to set up a Dual-Screen. The second screen is always a clone of the first one.

I have the default configuration from the example in the README.

Is there any limitation on Multi-Screen setup?

How are the screens placed in nvidia-settings? If you drag them atop each other, you get overlay. Placing them next to each other (up/down/left/right -whatever) should arrange the display real estate that way.

nvidia-settings can’t see the screens connected to the sink device because it doesn’t (yet) use RandR 1.2 to find additional displays. You’ll need to use an RandR client such as the xrandr command-line tool to change the configuration.

Does using the --right-of option work?

Hello, I have similar problem on my DELL laptop with nVidia Optimus - I have connected two external displays (via DVI on port replicator), but nVidia driver see only one display, and both displays are showing the same picture.

I am already asked about help on DELL forum, but without success (for more details see here).

My configuration:

  • DELL Latitude E5440
  • Kubuntu 14.04 64bit (KDE v4.13.3)
  • X server: 11.0 (vendor version: 1.15.1, NV-CONTROL v1.29)
  • Xrandr v1.4.1
  • VGA: GeForce GT 720M
  • nVidia driver: 340.32

Xrandr result:

Screen 0: minimum 8 x 8, current 1680 x 1050, maximum 16384 x 16384
eDP-1-0 connected
   1600x900       60.0 +   40.0  
   1440x900       59.9  
   1360x768       59.8     60.0  
   1152x864       60.0  
   1024x768       60.0     60.0  
   960x720        60.0  
   928x696        60.1  
   896x672        60.0  
   960x600        60.0  
   960x540        60.0  
   800x600        60.0     60.3     56.2  
   840x525        60.0     59.9  
   800x512        60.2  
   700x525        60.0  
   640x512        60.0  
   720x450        59.9  
   640x480        60.0     59.9  
   680x384        59.8     60.0  
   576x432        60.1  
   512x384        60.0  
   400x300        60.3     56.3  
   320x240        60.1  
DisplayPort-1-0 connected 1680x1050+0+0 473mm x 296mm
   1680x1050      60.0*+
   3360x1050      60.0  
   2560x1024      60.0  
   1280x1024      75.0     60.0  
   1152x864       75.0  
   1024x768       75.1     60.0  
   800x600        75.0     60.3  
   640x480        75.0     60.0  
   720x400        70.1  
HDMI-1-0 disconnected
HDMI-1-1 disconnected

Do you have any idea what I can do to get it working properly? Thx.


Hey guys, don’t tell me that there is not any easy solution for this, with Windows driver it is working as it should :-/

Heyyo,

Please check this thread and see if this solution works for you. This user was using Optimus via HDMI and Displayport.

https://devtalk.nvidia.com/default/topic/544761/319-17-optimus-multimonitor-setup/

[EDIT]
Another one you could check out if Prime isn’t working out for you?
https://github.com/Bumblebee-Project/Bumblebee/wiki/Multi-monitor-setup

Hello and thank you for response. Unfortunately my problem is little bit different from these mentioned on your links (and beyond I want to avoid Bumblebee if I am using nVidia driver with Optimus support).

The main issue is that Xrandr on my computer doesn’t see two external displays, but only one as DisplayPort-1-0.

It seems to me, that port replicator where my displays are connected via DVI ports is connected to the laptop via one DisplayPort, so probably there is some problem with displays identification.

Because this is working well on Windows 7 I suppose that this can be some missing feature in nVidia driver, but I can get confirmation about this.

OK, it looks that I am found reason - DisplayPort MST (Multi-Stream Transport) is needed, but it is not supported in Linux yet.

Somebody is working on patch, but it will be available not before Linux 3.16.

Heyyo,

Interesting research! Glad to see there’s something in the works. You could always install 3.16 kernel on your system, but of course there’s the risk of stability loss… albeit, I’ve never experienced it myself since the Linux Kernel is pretty solid. :)

So, I am upgraded to Ubuntu 14.04.2 with kernel 3.16-30 and unfortunately no change yet regarding DisplayPort MST :-/

I am upgraded to Ubuntu 14.04.3 and Kernel 3.19.0-25 today (sudo apt-get install linux-generic-lts-vivid), and DP MST starts working like a charm. Problem solved.