319.17 Optimus - MultiMonitor Setup

Hello all,
on two machines the current nvdia optimus solution working for me.
Except the MultiMonitor setup.

Wenn I start the XServer without ‘Option “UseDisplayDevice” “none”’ the Virtual Screen Size of the XServer set to the size of the Monitor which connected directly to the Nvidia GPU.

Start of the Laptop Screen output with
‘xrandr --setprovideroutputsource Intel NVIDIA-0
xrandr --auto’
working but I’m not able to move the Mouse cursor to the Laptop screen because of the wrong virtual screen size.

xrandr self recognize the Laptop screen correct.

So, at the moment I don’t now if its a failure or the XServer, Nvidia 319.17 driver or Compiz.
Perhaps someone know where could be the problem or know a solution.

Thank you for any help you can provide.
BlueCase

You should be able to resize the framebuffer with xrandr’s --fb option. It should also do that for you if you reconfigure the screen using xrandr instead of nvidia-settings.

Thanks for your answer.
I tried it with --fb now.


xrandr --setprovideroutputsource Intel NVIDIA-0
xrandr --auto
xrandr --fb 4960x1050 #3 Displays


It seems that the increase work but only for the Nvidia GPU conneted displays.
When I configure my Laptop screen on the left I have the same situation as in my first post.
Wenn I put it to right then it seems the desktop is in panning mode.

The whole setup work only if I configure it with nvidia-settings by increase the offset of my second external display (+3280+0) and put my Laptop Screen with xrandr between the free space.

I have the exactly the same symptoms using 319.23 driver.

Alienware M11XR3 with Intel i810 and Nvidia GT540M

Up-to-date Kubuntu.
xrandr 1.4.0 program compiled from source.
X.Org X Server 1.13.4 from xorg-edgers PPA.
Nvidia Driver 319.23 installed vi sgfxi script.
Kernel 3.9.0 from Ubunto repository.
KDE 4.10.3

External display on DisplayPort to right of laptop display.

I could only get offloading to work using the intel driver rather than the modesettings driver suggested in the release notes. Everything works fine except the mouse being unable to pass the left side of the external display onto the builtin display. However, when moving a window the window moves to the builtin display until the mouse cursor hits the left side of the external monitor.

Setting framebuffer using --fb to the width of both screens does not work.

I have full output of nvidia-bug-report.sh but can’t see how to attach it here.

Excited by how close this is to working now!

UPDATE:

I reinstalled some packages and I can now get offloading working with the modesettings driver and my xorg.conf is now exactly as per the release notes.

I’ve also tested this using E17 Window manager and got the same symptoms as KDE.

I’m wondering if it’s related to this xrandr CRTC bound checking bug? https://bugs.freedesktop.org/show_bug.cgi?id=39949
nvidia-bug-report.log.gz (70.1 KB)

Anyone have any clues where to start looking for a fix?

BlueCase, Please attach nvidia bug report. We are tracking this issue Bug 1310752 .

FYI. Issue persists in x86_64 325.08 beta.

If you need more info or testing please feel free to ask, I’m not a c developer but know my way around a Linux system on the command-line pretty well.

Does the problem go away if you add

Option "ConstrainCursor" "no"

To the Screen or Device section of /etc/X11/xorg.conf?

Yes, that seems to work fine now when placed in the device section.

Now have two monitors (one hdmi, one display-port) either side of the laptop screen and a seamless 3d-accelerated KDE desktop across all three.

Awesome! Thanks for this, finally got this laptop working the way I want!

If you need any follow-up info please feel free to ask.

System: Alienware M11x r3
GPU: GT540M
Kernel: 3.10.0-6-generic (Ubuntu Saucy)
Nvidia driver: x86_64 325.08 beta with 3.10 kernel patch from this forum
Xorg: 11,4002,000 (from xorg-edgers)
Xrandr: 1.4.0 from xrandr source repository.

@wraith0x29a

would you share your xorg.conf wigh us?

Section “ServerLayout”
Identifier “layout”
Screen 0 “nvidia”
Inactive “intel”
EndSection

Section “Device”
Option “ConstrainCursor” “no”
Identifier “nvidia”
Driver “nvidia”
BusID “PCI:1:0:0”
EndSection

Section “Screen”
Identifier “nvidia”
Device “nvidia”
EndSection

Section “Device”
Identifier “intel”
Driver “modesetting”
EndSection

Section “Screen”
Identifier “intel”
Device “intel”
EndSection

Hi,

I would like to confirm this^^ solved my issue “cursor out of screen” with KDE Plasma 5:
https://youtu.be/J3IazDOzhKc

Many thanks for advise!