Nvidia error while install 396.26 on Centos 7.2 VM with Tesla P6

The VM is running in VMWare (6.5), with a passthrough connection to the P6. It appears in “lspci” output.
But when I run the Nvidia installer (most recently 396.26, but have tried others) I get the following message:

“The NVIDIA GPU 0000:02:01.0 (PCI ID: 10de:1bb4) installed in this system is not supported by the NVIDIA 396.26 driver release. Please see ‘Appendis A - Supported NVIDIA GPU Products’ in this release’s README”

So I look in the REAME file, where it says the P6 is supported. What’s actually going on here? Is the OS too old, or the kernel (3.10.0-327.el7.x86_64)? Is there some special incantation needed for the passthrough?

The normal use-case for P6 would be in a GRID setting.

https://docs.nvidia.com/grid/latest/grid-vgpu-user-guide/index.html#using-gpu-pass-through