NVRM: installed in this system is not supported by the NVRM: NVIDIA 410.78 driver release.

Hi Team,

When I am trying to install the GPU driver for K260Q on a Centos 7.3 VM - hosted on Citrix HyperVisor , I get the following error. Can I get some assistance ?

[i]
-> Kernel module compilation complete.
-> Unable to determine if Secure Boot is enabled: No such file or directory
ERROR: Unable to load the kernel module ‘nvidia.ko’. This happens most frequently when this kernel module was built against the wrong or improperly configured kernel sources, with a version of gcc that differs from the one used to build
the target kernel, or if another driver, such as nouveau, is present and prevents the NVIDIA kernel module from obtaining ownership of the NVIDIA GPU(s), or no NVIDIA GPU installed in this system is supported by this NVIDIA Linux graphi
cs driver release.

Please see the log entries ‘Kernel module load error’ and ‘Kernel messages’ at the end of the file ‘/var/log/nvidia-installer.log’ for more information.
-> Kernel module load error: No such device
-> Kernel messages:
[ 349.197415] vgaarb: device changed decodes: PCI:0000:00:0b.0,olddecodes=io+mem,decodes=none:owns=io+mem
[ 349.197664] NVRM: The NVIDIA GPU 0000:00:0b.0 (PCI ID: 10de:11b0)
NVRM: installed in this system is not supported by the
NVRM: NVIDIA 410.78 driver release.
NVRM: Please see ‘Appendix A - Supported NVIDIA GPU Products’
NVRM: in this release’s README, available on the operating system
NVRM: specific graphics driver download page at www.nvidia.com.
[ 349.198191] nvidia: probe of 0000:00:0b.0 failed with error -1
[ 349.198211] NVRM: The NVIDIA probe routine failed for 1 device(s).
[ 349.198212] NVRM: None of the NVIDIA graphics adapters were initialized!
[ 349.198313] nvidia-nvlink: Unregistered the Nvlink Core, major device number 248
[ 2350.140671] [drm] Initialized drm 1.1.0 20060810
[ 2350.168905] ipmi message handler version 39.2
[ 2350.197492] nvidia-nvlink: Nvlink Core is being initialized, major device number 248
[ 2350.199053] vgaarb: device changed decodes: PCI:0000:00:0b.0,olddecodes=none,decodes=none:owns=io+mem
[ 2350.199363] NVRM: The NVIDIA GPU 0000:00:0b.0 (PCI ID: 10de:11b0)
NVRM: installed in this system is not supported by the
NVRM: NVIDIA 390.87 driver release.
NVRM: Please see ‘Appendix A - Supported NVIDIA GPU Products’
NVRM: in this release’s README, available on the operating system
NVRM: specific graphics driver download page at www.nvidia.com.
[ 2350.199948] nvidia: probe of 0000:00:0b.0 failed with error -1
[ 2350.199979] NVRM: The NVIDIA probe routine failed for 1 device(s).
[ 2350.199980] NVRM: None of the NVIDIA graphics adapters were initialized!
[ 2350.200083] nvidia-nvlink: Unregistered the Nvlink Core, major device number 248
ERROR: Installation has failed.

[/i]

Is this because of the system unable to find out if the Secure boot is enabled or not ?
I tried on Centos 7.5 as well and fails with the same.

The Grid K2 series is only supported up to driver v367: https://download.nvidia.com/XFree86/Linux-x86_64/415.18/README/supportedchips.html
Please try with a v340 legacy driver.

Thank you , That worked !!