NVIDIA graphics card not being used on Ubuntu 22.10


I have upgraded to Ubuntu 22.10 and I am unable to use Nvidia Graphics card.

Gnome 43.1 and Wayland is being used.

I have tried to follow all the steps in the solution of this Cannot get nvidia driver (520, 515, 515-open, or 510) working in Ubuntu 22.10 but could not get it to work.

I have tried reinstalling or even using different version of the Graphics card but it is the same.

1 Like

Screenshot from 2022-12-19 16-01-47

This is what it says in the About section of Settings (NVIDIA is not mentioned in the graphics card field)

As can be seen from above Nvidia is detected but no utilization is there.

This is Nvidia Graphics settings, it stays at 0 %

This is the Profile that is being used.

Output of modinfo nvidia

modinfo nvidia
filename:       /lib/modules/6.0.9-060009-generic/updates/dkms/nvidia.ko
firmware:       nvidia/525.60.11/gsp_tu10x.bin
firmware:       nvidia/525.60.11/gsp_ad10x.bin
alias:          char-major-195-*
version:        525.60.11
supported:      external
license:        NVIDIA
srcversion:     E6E92E3273CC30C56A44147
alias:          pci:v000010DEd*sv*sd*bc06sc80i00*
alias:          pci:v000010DEd*sv*sd*bc03sc02i00*
alias:          pci:v000010DEd*sv*sd*bc03sc00i00*
depends:        drm
retpoline:      Y
name:           nvidia
vermagic:       6.0.9-060009-generic SMP preempt mod_unload modversions 
sig_id:         PKCS#7

parm:           NvSwitchRegDwords:NvSwitch regkey (charp)
parm:           NvSwitchBlacklist:NvSwitchBlacklist=uuid[,uuid...] (charp)
parm:           NVreg_ResmanDebugLevel:int
parm:           NVreg_RmLogonRC:int
parm:           NVreg_ModifyDeviceFiles:int
parm:           NVreg_DeviceFileUID:int
parm:           NVreg_DeviceFileGID:int
parm:           NVreg_DeviceFileMode:int
parm:           NVreg_InitializeSystemMemoryAllocations:int
parm:           NVreg_UsePageAttributeTable:int
parm:           NVreg_EnablePCIeGen3:int
parm:           NVreg_EnableMSI:int
parm:           NVreg_TCEBypassMode:int
parm:           NVreg_EnableStreamMemOPs:int
parm:           NVreg_RestrictProfilingToAdminUsers:int
parm:           NVreg_PreserveVideoMemoryAllocations:int
parm:           NVreg_EnableS0ixPowerManagement:int
parm:           NVreg_S0ixPowerManagementVideoMemoryThreshold:int
parm:           NVreg_DynamicPowerManagement:int
parm:           NVreg_DynamicPowerManagementVideoMemoryThreshold:int
parm:           NVreg_EnableGpuFirmware:int
parm:           NVreg_EnableGpuFirmwareLogs:int
parm:           NVreg_OpenRmEnableUnsupportedGpus:int
parm:           NVreg_EnableUserNUMAManagement:int
parm:           NVreg_MemoryPoolSize:int
parm:           NVreg_KMallocHeapMaxSize:int
parm:           NVreg_VMallocHeapMaxSize:int
parm:           NVreg_IgnoreMMIOCheck:int
parm:           NVreg_NvLinkDisable:int
parm:           NVreg_EnablePCIERelaxedOrderingMode:int
parm:           NVreg_RegisterPCIDriver:int
parm:           NVreg_EnableDbgBreakpoint:int
parm:           NVreg_RegistryDwords:charp
parm:           NVreg_RegistryDwordsPerDevice:charp
parm:           NVreg_RmMsg:charp
parm:           NVreg_GpuBlacklist:charp
parm:           NVreg_TemporaryFilePath:charp
parm:           NVreg_ExcludedGpus:charp
parm:           NVreg_DmaRemapPeerMmio:int
parm:           rm_firmware_active:charp

Excluded the signature part above.

I have secure boot disabled.

Screenshot from 2022-12-19 16-09-29

Screenshot from 2022-12-19 16-13-12

nvidia-bug-report.log.gz (290.0 KB)

Also bug report attached.

Kindly let me know how to resolve.


You can only make use of the nvidia gpu using offloading with Xwayland.

I have even tried opening apps using “Open with discrete grahics card”, even that does not work.

So how can I get it to work with Wayland?

What kind of “apps”?

Browsers such as Brave, Firefox.
Also with Plex Player.

Those are not really the type of applications to make use of offloading/Xwayland due to no media decoding support.

Is there anything else that can be tried such as

To enable hardware decoding on Wayland, you may need to set the VDPAU_DRIVER environment variable to nvidia. You can do this by adding the following line to your ~/.bashrc file:

export VDPAU_DRIVER=nvidia


grep nvidia /etc/modprobe.d/* /lib/modprobe.d/*
to find a file containing

blacklist nvidia
and remove it,
then run

sudo update-initramfs -u

Just wondering

I don’t really know but I think neither va-api nor vdpau will ever work in an offloading setup, neither on Wayland nor on Xorg. Only direct nvdec/nvenc might be working in the nvidia case.

Yep i have the same issue, i guess it caused by your GPU (MX150) and mine (MX350) doesn’t support NVENC and NVDEC.