Ubuntu 19.04 - Can't enable or select Nvidia card as default

I’ve been trying for weeks now to use my Laptop with an MX150 card to run some games in Ubuntu.
But for some reason linux doesn’t want to let me use it!

Things I’ve tried:

  • I’ve installed the latest drivers (430)
  • done prime-select nvidia, query shows nvidia as selected too.
  • I’ve also disabled secure boot from the BIOS.
  • I’ve added nomodeset to the grub config, but this boots to a blinking cursos and black screen until i remove that.
  • I just tried installing bumblebee to run stuff, i get this message:
    [ERROR]Cannot access secondary GPU - error: [XORG] (EE) Failed to load module "nvidia" (module does not exist, 0)
  • I also tried modifying this 10-nvidia.conf file to add “Primary GPU” “true”

WHen i can see the login screen, for some reason I’m forced to login selecting Wayland from the user select screen otherwise it bounces back to the user list.

And I still see in Settings > Details that the system is still using the intel Card. Even thought the nvidia drivers are suggested in the Software app and i have installed the 430 ones.

Also if i run tools like glxgears or glmark2 it uses the intel card instead of the Nvidia card to do the tests :/

I don’t know what else to try to use my graphics card… it seems at this point i will have to go back to Winbugs :(

Any other ideas what to do?

Thanks and regards.
nvidia-bug-report.log.gz (103 KB)
report2.log.gz (692 KB)

You’re running into

Aug 24 13:22:56 yorutamashi-X510UNR kernel: [    7.763837] NVRM: GPU 0000:01:00.0: RmInitAdapter failed! (0x31:0xffff:883)
Aug 24 13:22:56 yorutamashi-X510UNR kernel: [    7.763865] NVRM: GPU 0000:01:00.0: rm_init_adapter failed, device minor number 0

which might be a hardware failure. Can you confirm the nvidia gpu properly works in Windows?

Hi there, thanks for the answer!

I was using windows right before installing Ubuntu and it was working just fine :/

I just booted into the BIOS to check if i see anything weird, but i have simply default options and the nvidia card is listed next to the intel one :(

Is a bios update available for your machine?

apparently there is, i will try this and get back to you :)
Do you think that this could help me with bouncing back to login when i try to start non-wayland?

@generix i have updated bios, restarted and things still the same, i can’t login without Wayland, and even after purging all nvidia and installing the latest driver from the software manager everything is still the same for me, i’ve attached a new report to the original post.

Thanks for the help!!!

I’m tired of this, i’ll try out Manjaron cuz i heard i has newer kernels, but if it doesn’t work i’ll go back to windows :(

TBH, outlook is bad. The MX150 is connected to the system by a “Intel Corporation Sunrise Point-LP PCI Express Root Port” which is a buggy piece of hardware. IDK if the last bug-fixes for it are in the kernel yet and you might even hit a new bug with it. Worth a try to use the latest kernel, nevertheless.