Ubuntu 19.04 Drivers 440.26 Multiple Issues

So I have a Dell Precision 7530 laptop with a Quadro P3200 running Ubuntu 19.04 with secure boot and UEFI along with drivers 440.26. Currently I am having issues with waking up from sleep along with it doesn’t appear like my drivers are running the Nvidia card as the default card. When I look under Settings -> About I see “Graphics: llvmpipe (LLVM 8.0, 256 bits)”. Below is the output from the standard tools along with a bug-report.sh

{EDIT} UPDATED the nvidia-bug-report.sh

lxinfo|grep render
direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
    GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer, GLX_MESA_query_renderer,
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: llvmpipe (LLVM 8.0, 256 bits)
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth,
    GL_MESA_ycbcr_texture, GL_NV_conditional_render, GL_NV_depth_clamp,
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth,
    GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_fog_distance,
    GL_OES_element_index_uint, GL_OES_fbo_render_mipmap,

nvidia-smi
    Mon Jan 27 10:54:45 2020
    +-----------------------------------------------------------------------------+
    | NVIDIA-SMI 440.26       Driver Version: 440.26       CUDA Version: 10.2     |
    |-------------------------------+----------------------+----------------------+
    | GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
    | Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
    |===============================+======================+======================|
    |   0  Quadro P3200        Off  | 00000000:01:00.0  On |                  N/A |
    | N/A   58C    P3    24W /  N/A |    806MiB /  6044MiB |      3%      Default |
    +-------------------------------+----------------------+----------------------+

    +-----------------------------------------------------------------------------+
    | Processes:                                                       GPU Memory |
    |  GPU       PID   Type   Process name                             Usage      |
    |=============================================================================|
    |    0      2938      G   /usr/bin/gnome-shell                         772MiB |
    +-----------------------------------------------------------------------------+

sudo lshw -c video
      *-display
           description: VGA compatible controller
           product: GP104GLM [Quadro P3200 Mobile]
           vendor: NVIDIA Corporation
           physical id: 0
           bus info: pci@0000:01:00.0
           version: a1
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
           configuration: driver=nvidia latency=0
           resources: irq:145 memory:a3000000-a3ffffff memory:60000000-6fffffff memory:70000000-71ffffff ioport:3000(size=128) memory:c0000-dffff

nvidia-bug-report.log.gz (1.11 MB)

I did look into this post https://devtalk.nvidia.com/default/topic/1070352/linux/solution-for-nvidia-sleep-wake-issue/post/5422587/#5422587 and updated my GRUB config with the ACPI info in the post but that did not resolve the problem either.

This looks like you’re running Gnome in a Wayland session, Xwayland on Nvidia only supports software rendering so far. Se this how to run a normal X session:
https://askubuntu.com/questions/975094/how-to-disable-wayland-in-17-10-in-gdm3-login-screen
About resume freezes:
Please post the output of
cat /sys/power/mem_sleep

So I tried switching off of Wayland and I am unable to login when I do that. After entering my password the screen goes black then goes back to me entering my password.

AS for the the Sleep issue

cat /sys/power/mem_sleep
s2idle [deep]

From attempting to run without Wayland

cat /home/<username>/.local/share/xorg/Xorg.0.log
[   120.950] (--) Log file renamed from "/home/<username>/.local/share/xorg/Xorg.pid-3890.log" to "/home/<username>/.local/share/xorg/Xorg.0.log"
[   120.950] 
X.Org X Server 1.20.7
X Protocol Version 11, Revision 0
[   120.950] Build Operating System: Linux 4.4.0-171-generic x86_64 Ubuntu
[   120.950] Current Operating System: Linux TequilaShots 5.0.0-40-generic #44-Ubuntu SMP Wed Jan 15 02:03:45 UTC 2020 x86_64
[   120.950] Kernel command line: BOOT_IMAGE=/vmlinuz-5.0.0-40-generic root=/dev/mapper/root--vg-root ro dis_ucode_ldr acpi_rev_override=1 acpi_osi=Linux nouveau.modeset=0 pcie_aspm=force drm.vblankoffdelay=1 scsi_mod.use_blk_mq=1 nouveau.runpm=0 mem_sleep_default=deep nvidia-drm.modeset=1
[   120.951] Build Date: 15 January 2020  09:26:10PM
[   120.951] xorg-server 2:1.20.7-0ppa1 (For technical support please see http://www.ubuntu.com/support) 
[   120.951] Current version of pixman: 0.36.0
[   120.951] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[   120.951] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   120.951] (==) Log file: "/home/<username>/.local/share/xorg/Xorg.0.log", Time: Tue Jan 28 08:19:56 2020
[   120.951] (==) Using config file: "/etc/X11/xorg.conf"
[   120.951] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   120.951] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   120.951] (==) ServerLayout "Layout0"
[   120.951] (**) |-->Screen "iGPU" (0)
[   120.951] (**) |   |-->Monitor "<default monitor>"
[   120.951] (**) |   |-->Device "iGPU"
[   120.951] (**) |   |-->GPUDevice "dGPU"
[   120.952] (**) |   |-->GPUDevice "Device0"
[   120.952] (==) No monitor specified for screen "iGPU".
	Using a default monitor configuration.
[   120.952] (**) Option "IgnoreABI" "1"
[   120.952] (**) Ignoring ABI Version
[   120.952] (==) Automatically adding devices
[   120.952] (==) Automatically enabling devices
[   120.952] (==) Automatically adding GPU devices
[   120.952] (==) Automatically binding GPU devices
[   120.952] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   120.952] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   120.952] 	Entry deleted from font path.
[   120.952] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[   120.952] 	Entry deleted from font path.
[   120.952] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[   120.952] 	Entry deleted from font path.
[   120.952] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[   120.952] 	Entry deleted from font path.
[   120.952] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[   120.952] 	Entry deleted from font path.
[   120.952] (==) FontPath set to:
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/Type1,
	built-ins
[   120.952] (==) ModulePath set to "/usr/lib/xorg/modules"
[   120.952] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[   120.952] (II) Loader magic: 0x559241f35020
[   120.952] (II) Module ABI versions:
[   120.952] 	X.Org ANSI C Emulation: 0.4
[   120.952] 	X.Org Video Driver: 24.1
[   120.952] 	X.Org XInput driver : 24.1
[   120.952] 	X.Org Server Extension : 10.0
[   120.952] (++) using VT number 2

[   120.953] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_34
[   120.954] (II) xfree86: Adding drm device (/dev/dri/card0)
[   121.277] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 12 paused 0
[   121.279] (**) OutputClass "nvidia" ModulePath extended to "/usr/lib/x86_64-linux-gnu/nvidia/xorg,/usr/lib/xorg/modules"
[   121.279] (**) OutputClass "Nvidia Prime" ModulePath extended to "/x86_64-linux-gnu/nvidia/xorg,/usr/lib/x86_64-linux-gnu/nvidia/xorg,/usr/lib/xorg/modules"
[   121.279] (**) OutputClass "dGPU" ModulePath extended to "/usr/lib/nvidia/xorg,/usr/lib/xorg/modules,/x86_64-linux-gnu/nvidia/xorg,/usr/lib/x86_64-linux-gnu/nvidia/xorg,/usr/lib/xorg/modules"
[   121.279] (**) OutputClass "Nvidia Prime" setting /dev/dri/card0 as PrimaryGPU
[   121.280] (--) PCI:*(1@0:0:0) 10de:1bbb:1028:1831 rev 161, Mem @ 0xa3000000/16777216, 0x60000000/268435456, 0x70000000/33554432, I/O @ 0x00003000/128, BIOS @ 0x????????/131072
[   121.280] (II) LoadModule: "glx"
[   121.280] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   121.281] (II) Module glx: vendor="X.Org Foundation"
[   121.281] 	compiled for 1.20.7, module version = 1.0.0
[   121.281] 	ABI class: X.Org Server Extension, version 10.0
[   121.281] (II) LoadModule: "modesetting"
[   121.281] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[   121.281] (II) Module modesetting: vendor="X.Org Foundation"
[   121.281] 	compiled for 1.20.7, module version = 1.20.7
[   121.281] 	Module class: X.Org Video Driver
[   121.281] 	ABI class: X.Org Video Driver, version 24.1
[   121.281] (II) LoadModule: "nvidia"
[   121.281] (II) Loading /usr/lib/x86_64-linux-gnu/nvidia/xorg/nvidia_drv.so
[   121.281] (II) Module nvidia: vendor="NVIDIA Corporation"
[   121.281] 	compiled for 1.6.99.901, module version = 1.0.0
[   121.281] 	Module class: X.Org Video Driver
[   121.281] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[   121.281] (II) NVIDIA dlloader X Driver  440.26  Sun Oct 13 17:46:52 UTC 2019
[   121.281] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[   121.281] xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
[   121.281] (WW) Falling back to old probe method for modesetting
[   121.281] (II) modeset(0): using default device
[   121.282] (II) systemd-logind: releasing fd for 226:0
[   122.629] (II) Loading sub module "fb"
[   122.629] (II) LoadModule: "fb"
[   122.629] (II) Loading /usr/lib/xorg/modules/libfb.so
[   122.630] (II) Module fb: vendor="X.Org Foundation"
[   122.630] 	compiled for 1.20.7, module version = 1.0.0
[   122.630] 	ABI class: X.Org ANSI C Emulation, version 0.4
[   122.630] (II) Loading sub module "wfb"
[   122.630] (II) LoadModule: "wfb"
[   122.630] (II) Loading /usr/lib/xorg/modules/libwfb.so
[   122.630] (II) Module wfb: vendor="X.Org Foundation"
[   122.630] 	compiled for 1.20.7, module version = 1.0.0
[   122.630] 	ABI class: X.Org ANSI C Emulation, version 0.4
[   122.630] (II) Loading sub module "ramdac"
[   122.630] (II) LoadModule: "ramdac"
[   122.630] (II) Module "ramdac" already built-in
[   122.631] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[   122.631] (EE) 
Fatal server error:
[   122.631] (EE) Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices
[   122.631] (EE) 
[   122.631] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[   122.631] (EE) Please also check the log file at "/home/<username>/.local/share/xorg/Xorg.0.log" for additional information.
[   122.631] (EE) 
[   122.642] (EE) Server terminated with error (1). Closing log file.
[   120.951] (**) |-->Screen "iGPU" (0)
[   120.951] (**) |   |-->Monitor "<default monitor>"
[   120.951] (**) |   |-->Device "iGPU"
[   120.951] (**) |   |-->GPUDevice "dGPU"
[   120.952] (**) |   |-->GPUDevice "Device0"

This looks like you’re having some additional stray config files meant for render offload. Please create and attach a new nvidia-bug-report.log.

The one above should be the same as today I just generated it. Here is another though.
nvidia-bug-report.log.gz (1.07 MB)

Please post the output of
ls -l /etc/X11 /etc/X11/xorg.conf.d /usr/share/X11/xorg.conf.d

ls -l /etc/X11 /etc/X11/xorg.conf.d /usr/share/X11/xorg.conf.d 
/etc/X11:
total 92
drwxr-xr-x 2 root root  4096 Jan 27 19:06 app-defaults
drwxr-xr-x 2 root root  4096 Apr 16  2019 cursors
-rw-r--r-- 1 root root    15 Apr 16  2019 default-display-manager
drwxr-xr-x 4 root root  4096 Apr 16  2019 fonts
-rw-r--r-- 1 root root 17394 Jan 20  2017 rgb.txt
drwxr-xr-x 2 root root  4096 Apr 16  2019 xinit
drwxr-xr-x 2 root root  4096 Oct 25  2018 xkb
-rw-r--r-- 1 root root  1259 Dec  6 13:41 xorg.conf
-rw-r--r-- 1 root root  1252 Dec  6 13:41 xorg.conf.backup
drwxr-xr-x 2 root root  4096 Jan 27 11:16 xorg.conf.d
-rw-r--r-- 1 root root     0 Dec  6 13:39 xorg.conf.nvidia-xconfig-original
-rwxr-xr-x 1 root root   709 Jan 20  2017 Xreset
drwxr-xr-x 2 root root  4096 Apr 16  2019 Xreset.d
drwxr-xr-x 2 root root  4096 Apr 16  2019 Xresources
-rwxr-xr-x 1 root root  3730 Dec 14  2018 Xsession
drwxr-xr-x 2 root root  4096 Nov  6 07:29 Xsession.d
-rw-r--r-- 1 root root   265 Jan 20  2017 Xsession.options
drwxr-xr-x 2 root root  4096 Apr 16  2019 xsm
-rw-r--r-- 1 root root    13 Dec  5  2016 XvMCConfig
-rw-r--r-- 1 root root   630 Apr 16  2019 Xwrapper.config

/etc/X11/xorg.conf.d:
total 4
-rw-r--r-- 1 root root 1397 Jan 27 11:16 10-prime-offload.conf

/usr/share/X11/xorg.conf.d:
total 28
-rw-r--r-- 1 root root   92 Apr  6  2019 10-amdgpu.conf
-rw-r--r-- 1 root root  206 Oct 19 06:00 10-nvidia.conf
-rw-r--r-- 1 root root 1350 Jan 15 16:26 10-quirks.conf
-rw-r--r-- 1 root root   92 Mar 28  2019 10-radeon.conf
-rw-r--r-- 1 root root  329 Jan 25 09:27 11-nvidia-prime.conf
-rw-r--r-- 1 root root 1429 Mar 30  2019 40-libinput.conf
-rw-r--r-- 1 root root 3039 Apr 12  2019 70-wacom.conf

Please remove
/etc/X11/xorg.conf.backup
/etc/X11/xorg.conf.nvidia-xconfig-original
/etc/X11/xorg.conf.d/10-prime-offload.conf
Bug or feature, the xserver will use anything that begins with “xorg.conf”.
Afterwards, create a new nvidia-bug-report.log.

So after removing those files. I rebooted. When I try to boot without Wayland everything goes blank and I guess just loops over and over but stays on black. I can change TTY sessions and get back to the login prompt. I had to reboot again and log into Wayland to get everything back running.
nvidia-bug-report.log.gz (1.12 MB)

The config is clean now and the Xserver came up properly but you were running into a known bug where the nvidia driver thinks the gpu has no outputs. To work around, please follow this:
https://devtalk.nvidia.com/default/topic/1066683/linux/ubuntu-18-04-3-blank-screen-at-startup-with-430-drivers-and-gtx-960/post/5402308/#5402308

So I set the parameter like you said nvidia-drm.modeset=0 but when I booted up the computer I could not get the login prompt to load. It just loaded to a black screen. Attached is another bug-report.
nvidia-bug-report.log.gz (1.12 MB)

So this morning I rolled the drivers back to 390 and tested with those with no luck but now I am back to 440.26 drivers.