How do I make the Nvidia graphics card the default in my laptop?


I have a SONY VAIO FIt-15 (Core i7 + Intel HD 4000/Nvidia GT 735M)

I want have the Nvidia graphics for default (No matter if I have to disable the driver Intel or the battery life).

I was using the bumblebee software, but it is insufficient, for example, the “Color Config” in Nvidia is much better than Intel, but doesn’t works with Bumblebee. So, How do I make the Nvidia graphics card the default in my laptop?

S.O: OpenSUSE 12.3 (x86_64)
Kernel: 3.10
D.E: KDE 4.10.4

  1. First, make sure you’ve totally removed Bumblebee.

  2. You need to modify your xorg.conf
    I use the following /etc/X11/xorg.conf file to make it work on openSUSE:
    (similar to the official one

  3. You need to modify your ~/.xinitrc
    Find where it says “Add your own lines here…” at the end of the file, and add:
    xrandr --setprovideroutputsource modesetting NVIDIA-0
    xrandr --auto

As you installed the nvidia driver manually (it’s the only solution with kernel 3.10, I guess), it’s possible that the symbolic link created by the nvidia installer often gets overwritten by a from openSUSE xorg updates. You’ll have to fix that link or applications will crash:
sudo ln -s /usr/lib64/xorg/modules/extensions/ /usr/lib64/xorg/modules/extensions/
(replace 319.32 by your driver version)

Thanks but don’t works.

  • I removed Bumblebee

  • I copied the file /etc/X11/xorg.conf (with the line “EndSection” in the Section “Files”) ;)

  • I copied the file ~/.xinitrc.template to ~/.xinitrc and add the lines in “Add your own lines here…”

  • Also, moved /usr/lib64/xorg/modules/extensions/ to
    /usr/lib64/xorg/modules/extensions/ (for backup)

  • Later
    ln -s /usr/lib64/xorg/modules/extensions/ /usr/lib64/xorg/modules/extensions/

  • Finally reboot and… Black Screen.

My xorg.0.log:
Also, my xorg.8.log:

You need to add:xrandr --output LVDS-0 --off
before xrandr --auto in your .xinitrc. 1.13.2 has a bug that was fixed in later versions. Also, you need to be running the xrandr program version 1.4.0:
$ xrandr --version
xrandr program version 1.4.0

Thanks, but I have Black Screen again … :(

Well… I installed the version from the “Factory Repository” (7.6_1-8.2), but the X server is also 1.13.2. Supposedly this is the Stable Version.

My “xrandr” version is 1.4.0


I tried without /etc/X11/xorg.conf and I can start KDE, so, maybe the problem is with this file.

Did you uncomment the UseDisplayDevice = “none” line in the nvidia Screen section in xorg.conf? You need to do that if you’re only using the laptop screen and no others.

I uncommented the line UseDisplayDevice = “none” but I had black screen again. :(
The black screen always appears before of the “Login Screen”(KDM),

My Xorg.0.log is:

And my Xorg.8.log is:

Oh, you’re using KDM. The commands in the .xinitrc won’t get called when KDM starts. It’ll read .xsessionrc, but only after login. To make sure the Nvidia card and Intel card are working properly, log in in text mode and call startx. That should work. If it works, you’ll need to put xrandr commands into something KDM reads at start.

Here is how to add them to the KDM startup scripts:

Your xrandr version might be too old.
Try adding the X11 repository, it might help:

First: THANKS!

Sorry for the delay, I was sick.

  1. I updated my packages from
  2. I disabled the “DisplayManager”.
  3. Now my Nvidia chip works for Default. ^_^


Now, I have only a problem… the “nvidia-config” doesn’t have “Color Config”. :(
So, I can’t adjust gamma/brightness/contrast. Neither works “System Preferences > Screen > Gamma” nor “xcalib”.

Temporarily I’m using:
xrandr --output LVDS-0 --gamma 0.68:0.68:0.68 --brightness 0.96

Someone has managed to run the nvidia-config with “color-config”?

I have a similar issue disabling my Intel HD Graphics 3000 for an NVIDIA GT540M installed in a Novatech nSpire Pro 2640m i7 2nd Generation Intel HM65 Chipset. I tried disabling it but comes back as a default can anyone assist here ??

Dear zchronos,

Could you please describe your solution that worked in a bit more detail? Did you add the xrandr lines to a config file (which one exactly)? How did you disable DisplayManager?

Thanks a lot…

Hi szpari,

My solution(thanks to “AnAkkk” and “conky_vs_julian”) was:

  1. I updated my packages from
  2. I disabled the “DisplayManager”. (Yast > Users Management > Advanced > Session > Automatic Login)
  3. Close session and init 3.
  4. Install Nvidia Driver ( in my case with patch by my kernel version)
  5. Copy xorg.conf to /etc/X11/ ( )
  6. Check symbolic link, if is different then:

mv /usr/lib64/xorg/modules/extensions/ /usr/lib64/xorg/modules/extensions/libglx.bak
(only for backup)
ln -s /usr/lib64/xorg/modules/extensions/ /usr/lib64/xorg/modules/extensions/
(create the symbolic link)

  1. Copy the ~/.xinitrc.template to ~/.xinitrc

  2. Edit the .xinitrc ( )

  3. Reboot

The Nvidia chip works, but I can’t configure the colors with nvidia-config. Uguu~

Are you making this in linux OS? I’ve the same problem in windows 7! How to change with that?