Nvidia not able to turn off or swith to intell.[ubuntu 18]

I have Nvidia 5200m. and using the additional driver from Nvidia. I want to only use Intel GPU and turn-off Nvidia. I try to do this with " prime-select intel " all is okay. but when system reboot KDE not working and Only Show Me a black screen with mouse cursor.

NOTE 1 : I have no option to select From BIOS

NOTE 2 : all i have is to turn off/on or on Nvidia optimus from BIOS

NOTE 3 : Nvidia optimus should Be Off to get working with additional driver from Nvidia in luinx.[ it's Off now ] IN Bios.

NOTE 4 : My laptop Dell-Latitude e6430

Screenshot_20180804_060739.png
Screenshot_20180804_060852.png

Please attach your /var/log/Xorg.0.log

https://kopy.io/oELzO

That’s from a boot where you disabled hybrid graphics, so only the nvidia gpu is existant. So this should be working?
Please switch to hybrid, intel only and attach your Xorg log and the dmesg output.

Nvidia optimus from BIOS : On
KDE run ? : No,Only Black Screen.
Selected Card : Nvidia.

https://kopy.io/N3bvz

You have a /etc/X11/xorg.conf which is disabling the intel gpu, so it doesn’t work in hybrid mode. Please remove, try again, post resulting xorg log.

Nvidia Optimus from BIOS: On
Selected Card: Intel.
KDE run? : No, Only Black Screen but with a mouse cursor

https://kopy.io/PJrfQ

see the log below and tell me if i still should delete xorg.conf

Yes please remove. Now the modesetting driver loads due to the nvidia being turned off but glx is not working.

I remove it , but nothing is change
rm /etc/X11/xorg.conf

Nvidia Optimus from BIOS: On
Selected Card: Intel.
KDE run? : No, Only Black Screen but with a mouse cursor

last log

https://kopy.io/25vDA

Ok, now the real issue surfaces:

[    37.411] (EE) modeset(0): eglGetDisplay() failed
[    37.502] (EE) modeset(0): glamor initialization failed

So something is broken either with your GL/eGL or glvnd install.
Since your nvidia gpu is a Fermi, it is supported by the 390 driver, please upgrade to that, or the 384 driver. Use the graphics ppa if necessary.
Also reinstall libegl-mesa0 and see if that helps

How to Delete the Current Driver or update it in safe way ?

It depends on how you installed the nvidia driver in the first place, using the ‘Additional drivers’ pane in ‘Software & Updates’?

yes i use it to instalal the current driver.

Then use that again, it should give you the option to install nvidia-390. If not, run
sudo apt-get install nvidia-390

…but make sure it doesn’t install the -396 driver, that one doesn’t support your gpu anymore.

see the last reply here … I think its related to my problem.

https://bbs.archlinux.org/viewtopic.php?id=222737

No, that’s unrelated. The mentioned xrandr commands are only needed when both gpus are used, after prime-select nvidia. You’re trying to get the intel-only case to work.

Okey … I upgrade to 390 without problems.

https://kopy.io/V3Vue

How To make sure Nvidia is full OFF??

You have created an xorg.conf again, remove that. Otherwise, seems like it’s working now.
To have the nvidia shut down either replace the kernel parameter in gub
nouveau.runpm=0
with
nouveau.runpm=1
and run sudo update-grub

or replace the prime-select infrastructure with this:
https://github.com/timrichardson/Prime-Ubuntu-18.04
which uses bbswitch to turn off the nvidia gpu.