How do I run Wayland on NVIDIA GeForce RTX 2070?

How do I run Ubuntu Wayland on NVIDIA GeForce RTX 2070?

Specifics Below:

Hardware

  • The graphics card (not counting the Intel one) is NVIDIA® GeForce RTX™ 2070 8GB GDDR6
    • Intel UHD 560
    • Nvidia GeForce RTX 2070 Mobile

Background

  • When I first tried to install Ubuntu I had this graphics issue I was able to resolve it by rebooting into graphics safe mode from the Grub menu, and changing the default display driver to: driver: nvidia-driver-450 - distro non-free recommended

  • I’ve run sudo ubuntu-drivers autoinstall as well as all the regular ubuntu updates on 20.04 and the available graphics drivers are vendor: NVIDIA Corporation model: TU106BM [GeForce RTX 2070 Mobile] with these choices:

    • driver: nvidia-driver-418-server - distro non-free
    • driver: nvidia-driver-440-server - distro non-free (this can prevent running of OS unless in graphics safe mode)
    • driver: nvidia-driver-435 - distro non-free
    • driver: nvidia-driver-450-server - distro non-free
    • driver: nvidia-driver-450 - distro non-free recommended (this is the one I currently use)
    • driver: xserver-xorg-video-nouveau - distro free builtin (this is the default that prevents the OS from displaying at all)

Solutions I’ve Tried:

  • I’ve tried switching between all the above drivers, with no apparent effect on Wayland.

  • If you use the terminal to run prime-select query , you can see an Intel and an Nvidia graphics driver, and you can switch in-between them with sudo prime-select intel or sudo prime-select nvidia but if you select intel, everything just becomes unacceptable, I think it’s just a part of the processor, but not sure.

  • I’ve run sudoedit /etc/gdm3/custom.conf to uncomment WaylandEnable=false and change the value to true, as seen here.

  • I’ve also run: sudoedit /etc/default/grub to change GRUB_CMDLINE_LINUX_DEFAULT to GRUB_CMDLINE_LINUX_DEFAULT=“quiet nvidia-drm.modeset=1” and then sudo update-grub, but not sure I’m doing it right.

  • I’ve seen this old bug report from Ubuntu regarding Wayland and Nvidia, but I don’t think it explains why the cog to switch to wayland isn’t appearing or working, not sure.

  • Ive seen the below errors in terminal, but not sure that they are related since the Wayland issue exists on the other drivers

    • WARNING:root:_pkg_get_support nvidia-driver-455: package has invalid Support Betaheader, cannot determine support level. Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
    • The following packages have unmet dependencies:
      nvidia-driver-455 : Depends: libnvidia-extra-455 (= 455.23.04-0ubuntu0~0.20.04.1) but it is not going to be installed
      Depends: nvidia-compute-utils-455 (= 455.23.04-0ubuntu0~0.20.04.1) but it is not going to be installed
      Depends: nvidia-utils-455 (= 455.23.04-0ubuntu0~0.20.04.1) but it is not going to be installed
      Depends: xserver-xorg-video-nvidia-455 (= 455.23.04-0ubuntu0~0.20.04.1) but it is not going to be installed
      Depends: libnvidia-ifr1-455 (= 455.23.04-0ubuntu0~0.20.04.1) but it is not going to be installed
      Recommends: libnvidia-compute-455:i386 (= 455.23.04-0ubuntu0~0.20.04.1)
      Recommends: libnvidia-decode-455:i386 (= 455.23.04-0ubuntu0~0.20.04.1)
      Recommends: libnvidia-encode-455:i386 (= 455.23.04-0ubuntu0~0.20.04.1)
      Recommends: libnvidia-ifr1-455:i386 (= 455.23.04-0ubuntu0~0.20.04.1)
      Recommends: libnvidia-fbc1-455:i386 (= 455.23.04-0ubuntu0~0.20.04.1)
      E: Unable to correct problems, you have held broken packages.
      user@user:~$

Current and Desired Setup

  • The current state of the laptop is a fresh install of 20.10 with all the above actions and regular updates.
  • I also have LVM encryption, and a MOK enrolled, which I’d like to have setup on the final state of the machine, and be able to change the passwords. I think I can change the passwords with the “Disks” application for LVM and sudo mokutil for the MOK. but not sure if those have to be setup on the initial install or not, so may be something to consider if we decide to reinstall the OS.

As far as I know GNOME’s initial support for EGLstreams isn’t really being actively maintained and they’ve even setup an udev rule to automatically revert/enforce Xorg when the nvidia driver is detected.

And render offload doesn’t have a workable implementation regardless as far as I know so that’s a non starter by definition for a laptop setup.

UPDATE:
I was able to get both wayland to run as well as resolve this different issue: https://askubuntu.com/questions/1261190/cant-change-screen-brightness-on-ubuntu-20-04-always-display-maximum-brightnes

By installing Ubuntu in “safe graphics mode” and then NOT UPDATING THE NVIDIA DRIVERS

Once the NVIDIA drivers are updated, it recreates both the issue in this post, and the issue in the link above.

Can someone from the NVIDIA team please fix the driver updates so it does not cause these problems?