NVIDIA Persistence Daemon Failed to Start

Hi, I suddenly noticed that I started getting this error “[FAILED] Failed to start NVIDIA persistence Daemon” at start up. I tried following the solution discussed in [Solved] Issue with nvidia driver in Linux Ubuntu 18.04 and CUDA 11.4 . After following all the steps without much luck, I still get that error and this error “NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.” when I ran nvidia-smi.

I have the bug report attached here as well-
nvidia-bug-report.log.gz (176.0 KB)

I am clueless as to how to resolve these problems. I would appreciate any help I can get. Thanks

Hi @senpaibayo005, thank you for your response. This did not work. it says the ppa is not supported by NVIDIA so has to be updated manually. Thank you all the same.

There are no kernel modules installed. Please install the kernel headers
sudo apt install linux-headers-$(uname -r)
and post the output of
dkms status

Hi @generix, thank you for your reply. I installed the kernel using the command above, but the dkms status shows nothing.

This is the bug report after taking the steps
nvidia-bug-report.log.gz (176.3 KB)

How did you initially install the driver? Please post the output of
dpkg -l |grep nvidia

hi @generix

Here is the output of dpkg -l |grep nvidia

I installed using

sudo apt-get install nvidia-driver-510

sudo apt-get install nvidia-driver-470

There were precompiled, signed modules for the 5.4 kernel installed but you’re using the liquorix kernel. Please uninstall the 470 driver and use the graphics driver ppa like @senpaibayo005 mentioned to install the 515 driver.

Hi @generix this worked. Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.