NVIDIA QUADRO P2000 installing problems with Ubuntu 18.04

Hi we are trying to install nvidia quadro p2000 on ubuntu 18.04.3 without success.
We are following these steps:

sudo apt-get install -y build-essential gcc-multilib dkms
sudo bash -c ‘echo “blacklist nouveau” >> /etc/modprobe.d/blacklist-nouveau.conf’
sudo bash -c ‘echo “options nouveau modeset=0” >> /etc/modprobe.d/blacklist-nouveau.conf’
sudo update-initramfs -u
sudo apt install -y nvidia-driver-390

Then we reboot the server and we can see that the NVIDIA is not working (we have tried different NVIDIA drivers like 440, 390, 420…)
We also tried different installation methods (by commands, in the ubuntu environment…).

When we try to access to the user interface, we can not, we can only access by ssh.
When we access to the server by ssh, we can see the following:

sudo nvidia-smi
Fri May 15 14:10:17 2020
| NVIDIA-SMI 390.132 Driver Version: 390.132 |
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| 0 Quadro P2000 Off | 00000000:01:00.0 Off | N/A |
| 0% 39C P0 16W / 75W | 0MiB / 5059MiB | 0% Default |

| Processes: GPU Memory |
| GPU PID Type Process name Usage |
| No running processes found |

We attache the logs we download by: sudo nvidia-bug-report.sh
nvidia-bug-report.log (1.3 MB)

You have connected the monitor to the on-board Matrox graphics. Please connect the monitor to an output on the nvidia graphics card, then create /etc/X11/xorg.conf with contents:

Section "Device"
    Identifier     "nvidia"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BusID          "PCI:1:0:0"
    Option         "AllowEmptyInitialConfiguration"

Furthermore, you can use the current 440 driver.
sudo apt install nvidia-driver-440

We tried what you told us and everything is now working correctly. Thank you for for your support!