(Ubuntu 18.04) NVIDIA-SMI has failed, but the Software and Updates app indicates that I am using nvidia-driver-430

When I enter “nvidia-smi” into my terminal on my Ubuntu 18.04 machine, I get the following message:

“NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.”

However, when I check the Software and Updates app, I see that I am using the NVIDIA driver metapackage from nvidia-driver-430, the latest driver. I have an Nvidia Quadro RTX5000 graphics card, so the driver should be compatible.

My eventually want to download the Nvidia SDK manager and flash a Jetson TX2 with JetPack 4.2. How can I solve this problem?

Please check if you have secure boot enabled in bios and disable it.
Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

I had this same issue installing NVIDIA 430 on Ubuntu 18.04 and tried a number of things suggested on the devtalk forums to no avail. I checked my BIOS settings and it showed that Secure Boot was disabled, but then observed that Ubuntu thought it was enabled. I put this down to a recent BIOS update. I cleared my CMOS settings and set the BIOS settings fresh including secure boot. It worked perfectly after that.

I have an issue after installing NVIDIA 430 on Ubuntu 18.04.2 LTS
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

(base) volk@check-ubuntu-versionvolk-precision-5530:~/Downloads$ grep nvidia /etc/modprobe.d/* /lib/modprobe.d/*
/etc/modprobe.d/blacklist-framebuffer.conf:blacklist nvidiafb
/etc/modprobe.d/nvidia-installer-disable-nouveau.conf:# generated by nvidia-installer
/lib/modprobe.d/blacklist-nvidia.conf:# This file was generated by nvidia-prime
/lib/modprobe.d/blacklist-nvidia.conf:blacklist nvidia
/lib/modprobe.d/blacklist-nvidia.conf:blacklist nvidia-drm
/lib/modprobe.d/blacklist-nvidia.conf:blacklist nvidia-modeset
/lib/modprobe.d/blacklist-nvidia.conf:alias nvidia off
/lib/modprobe.d/blacklist-nvidia.conf:alias nvidia-drm off
/lib/modprobe.d/blacklist-nvidia.conf:alias nvidia-modeset off
/lib/modprobe.d/nvidia-kms.conf:# This file was generated by nvidia-prime
/lib/modprobe.d/nvidia-kms.conf:options nvidia-drm modeset=1

nvidia-bug-report.log.gz (119 KB)

vchernat, it’s an Optimus notebook, please follow this:

  • install nvidia-prime (sudo apt install nvidia-prime)
  • switch to nvidia (sudo prime-select nvidia)
  • remove stray blacklist files (sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf)
  • update the initrd (sudo update-initramfs -u)
  • reboot

Thank you very much @generix!

I have Dell Precision 5530 laptop with Quadro P2000 Nvidia Card. Would the same instruction apply?
Should i back up Linux configuration before this update?

vchernat, those instructions were explicitly for your hardware. Doing a backup is never a bad idea.