Nvidia-smi "NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running."

I have done “sudo apt-get install nvidia-driver-430”

Which seems to work fine.

prime-select query=> nvidia

nvidia-bug-report.log (635 KB)
nvidia-bug-report.log (734 KB)

I ran nvidia-smi after reboot ofc

You have secure boot enabled so the nvidia driver doesn’t load since it isn’t signed. Please disable secure boot in bios.

I disabled it, still having same issue, I ran the script again, see the attached file(second one).

NVM ty it worked