Nvidia-smi not working

the command nvidia-smi does not work, it gives the following error:
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

I tried several fixes on this forum but none seem to work. Could someone help me out?
nvidia-bug-report.log.gz (116.0 KB)
here is the nvidia-bug-report

nvidia-smi is working. It is just telling you, that it cannot find a loaded driver. Which is what actually is happening.
How did you install the driver? By driver manager or PPA?

[ 0.000000] secureboot: Secure boot enabled

Try disabling Secure Boot.

If that is not helping, then show the output of: dmks status
And also create a new bug report.

Besides that it might be worth checking for a bios update:

[ 0.163196] ACPI: [Firmware Bug]: BIOS OSI(Linux) query ignored
[ 0.228587] ACPI: Dynamic OEM Table Load:
[ 0.228601] ACPI: SSDT 0xFFFF8F82FDB1C800 0005DC (v02 PmRef Cpu0Ist 00003000 INTL 20121018)
[ 0.230382] ACPI: _PR
.CPU0: _OSC native thermal LVT Acked
[ 0.231064] ACPI BIOS Error (bug): AE_AML_BUFFER_LIMIT, Field [CAP1] at bit offset/length 64/32 exceeds size of target Buffer (64 bits) (20190816/dsopcode-203)

NVIDIA Corporation GM107GLM [Quadro M1000M]

I just checked the legacy driver list and I think your GPU is only supported by the version 390 driver:
https://www.nvidia.com/en-us/drivers/unix/legacy-gpu/