Issue with installing nvidia drivers on fresh Ubuntu 18.04.3

So the situation is that I have a laptop with a GTX 880M, and a fresh install of Ubuntu 18.04.3. I tried installing nvidia-driver-415, and after finishing and then trying ‘nvidia-smi’, I get,

“NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.”

Even when I try ‘lspci -vvv’ I see the GTX 880M there. And I’m pretty sure I have SecureBoot disabled, although I didn’t see an exact option for it in the BIOS. I did see a UEFI setting and have it disabled.

Anyway, I also attached the nvidia-bug-report:

https://drive.google.com/file/d/1r8St3qZ374eCgayzI4ZC89syzt0vveHC/view?usp=sharing

Thank you in advance.

The logs tell:

  • you installed Ubuntu 18.04, kernel 4.15
  • installed the nvidia driver 415, compiled fine for kernel 4.15
  • upgraded Ubuntu, got kernel 5.0, driver got lost
    Kernel 5.0 needs driver 430, please try to reinstall it using
sudo apt install --reinstall nvidia-driver-430

Yeah I tried installing nvidia-driver-430, but then get stuck at boot with starting Gnome Display Manager. I tried switching to lightdm but then I just get to a screen with a blinking cursor.

Thanks for the help.

I’m unsure about the current state and which driver is installed.
Please install the 430 driver, then create a new nvidia-bug-report.log after reboot.
You might have to switch to VT (e.g. ctrl+alt+f4)
If you have internet connection, you can use pastebinit to upload it from console.

  • install pastebinit (sudo apt install pastebinit)
  • unzip logfile (gunzip nvidia-bug-report.log.gz)
  • upload logfile (pastebinit -i nvidia-bug-report.log)
  • note down and post the url you’re given

Oh yeah I just installed nvidia-driver-430, then ctrl+alt+f4’ed, and then logged in and ran nvidia-bug-report.sh. Then I uninstalled nvidia-driver-430 via recovery mode. And here is the google drive link:

The weird thing is that everything worked fine in Ubuntu 18.04 with kernel 4.15.0-54 (I’m unsure of the nvidia driver version, maybe 410?), but when I updated to 4.15.0-55 it stopped working. Then I tried a fresh install with kernel 5 and can no longer get it to work. I also tried to installing the nvidia drivers in 4.15.0-54 again, but it no longer works.

It seems something changed with the ppa.

You’re getting

Aug 27 14:41:23 maxwell kernel: NVRM: GPU 0000:01:00.0: RmInitAdapter failed! (0x26:0xffff:1155)
Aug 27 14:41:23 maxwell kernel: NVRM: GPU 0000:01:00.0: rm_init_adapter failed, device minor number 0

which might be a sign for your gpu simply being broken.

  • Try running it using Windows
  • Do a fresh Ubuntu install, don’t upgrade the HWE and use nvidia-driver-390
    to check.

Nvidia Drivers doesn’t support kernel 5.0. I am using unsigned ubuntu kernel 4.18 and nvidia drivers and prime works fine.