Problems installing NVIDIA 430.26 drivers on Ubuntu 18.04

Hey guys,

I’ve really tried hard to try everything I could think of before coming here. nvidia-bug-report will be attached after I create the topic. Things I’ve done so far:

  • Secure boot is disabled
  • I installed via apt, and it was successful, but nvidia-smi says it cannot communicate with the driver.
  • Purged the apt driver and tried installing it from .run file. Same issue.
  • Ran the .run file with --uninstall and went back to the apt install. No change.
  • Tried installing nvidia prime and prime-select nvidia. No change.
  • Tried blacklisting with blacklist-nvidia-nouveau.conf. No change.

It’s a dual-boot Ubuntu/Win 10 machine. Very few customizations on the Ubuntu side – though I am using the Unity Desktop as my display manager (not sure if that matters).

The log shows some kernel compilation errors, but before I start poking around in the kernel I figured I’d come here.
nvidia-bug-report.log.gz (115 KB)

Please don’t use the .run installer, it’s an Optimus system.
Currently, there’s no kernel driver installed, please reinstall the driver from repo
sudo apt install --reinstall nvidia-driver-430

  • make sure nvidia-prime is installed (sudo apt install nvidia-prime)
  • switch to nvidia (sudo prime-select nvidia)
  • remove stray blacklist files (sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf)
  • update the initrd (sudo update-initramfs -u)
  • reboot
    If this doesn’t resolve the issue, please create a new nvidia-bug-report.log.

No luck. Attached are the commands I ran and the new nvidia-bug-report.
terminal.txt (3.96 KB)
nvidia-bug-report.log.gz (113 KB)

Something seems to be wrong with your dkms setup, still no kernel driver installed.
Please post the output of
dkms status

Slight version difference (64 vs 65). Could that be the problem?

miketwo@miketwo-acer:~$ dkms status
nvidia, 430.26, 4.15.0-64-generic, x86_64: installed
nvidia, 430.26, 4.15.0-65-generic, x86_64: built

Please run
sudo dkms install nvidia/430.26 --all
and check dkms status afterwards that the status changed from built to installed for the currently running kernel.

Halfway there!

Both show installed now, and nvidia-smi worked. However, when I rebooted, it froze after entering my password. I opened up a terminal with Ctrl+Alt+F3 and prime-selected intel just to unfreeze it. I then tried re-running the reinstall commands from earlier: no change in behaviour.

This is more progress than I’ve made in many days though! Thanks already for helping!

miketwo@miketwo-acer:~$ dkms status
nvidia, 430.26, 4.15.0-64-generic, x86_64: installed
nvidia, 430.26, 4.15.0-65-generic, x86_64: installed

miketwo@miketwo-acer:~$ nvidia-smi
Mon Oct 14 19:08:09 2019
| NVIDIA-SMI 430.26       Driver Version: 430.26       CUDA Version: 10.2     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|   0  GeForce GTX 1060    Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   53C    P0    27W /  N/A |      0MiB /  6078MiB |      2%      Default |

| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|  No running processes found                                                 |

miketwo@miketwo-acer:~$ nvidia-settings

ERROR: Error querying enabled displays on GPU 0 (Missing Extension).

ERROR: Error querying connected displays on GPU 0 (Missing Extension).

** Message: 19:08:14.974: PRIME: Requires offloading
** Message: 19:08:14.974: PRIME: is it supported? yes

ERROR: nvidia-settings could not find the registry key file. This file should have been
       installed along with this driver at
       /usr/share/nvidia/nvidia-application-profiles-key-documentation. The application
       profiles will continue to work, but values cannot be prepopulated or validated, and
       will not be listed in the help text. Please see the README for possible values and

Please switch to nvidia, reboot and create a new nvidia-bug-report.log after trying to log in.

Switched, rebooted and created a new one.

nvidia-bug-report.log.gz (1.04 MB)

It’s an Optimus notebook, please delete your xorg.conf.

Outstanding success! That was the final brick in the wall.

I still get a strange error on login (something about xrandr not find eDP-1), but it logs me in properly and nvidia-setting and -smi both work! The glmark2 benchmark is also showing numbers that indicate it’s using the right card.

Thanks so much!!!

Now I just need to install nvidia-docker, but I can probably handle that part on my own.

Thanks again!

Nvidia Drivers doesn’t support kernel 5.0. I am using unsigned ubuntu kernel 4.18 and nvidia drivers and prime works fine. For further assistance go through this site