Problem installing driver 435 on Ubuntu 18.04

The Additional Drivers tab in Ubuntu settings confirms that I’m using nvidia-driver-435.

$ prime-select query

but Ubuntu’s About tab has Graphics as llvmpipe (LLVM 8.0, 256 bits)

$ nvidia-smi
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

$ nvidia-settings

ERROR: NVIDIA driver is not loaded

ERROR: Unable to load info from any available system

(nvidia-settings:6246): GLib-GObject-CRITICAL **: 14:02:22.960: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed
** Message: 14:02:22.961: PRIME: No offloading required. Abort
** Message: 14:02:22.961: PRIME: is it supported? no

My /etc/modules lists only:

I currently have /etc/modprobe.d/blacklist-nouveau.conf with:
blacklist nouveau
options nouveau modeset=0

and no /etc/X11/xorg.conf

Any help would be greatly appreciated!
nvidia-bug-report.log.gz (114 KB)

Please try this:

  • remove stray blacklist files (sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf)
  • update the initrd (sudo update-initramfs -u)
  • reboot

Thanks, that worked!

Hi, guys!

I am having the same problem on Mint, and I tried this with no luck:

rm: cannot remove ‘/lib/modprobe.d/blacklist-nvidia.conf’: No such file or directory
rm: cannot remove ‘/etc/modprobe.d/blacklist-nvidia.conf’: No such file or directory

This is the inxi -F:
Host: yandiro-G3-3590 Kernel: 5.0.0-32-generic x86_64 bits: 64
Desktop: Cinnamon 4.4.8 Distro: Linux Mint 19.3 Tricia
Type: Laptop System: Dell product: G3 3590 v: N/A serial:
Mobo: Dell model: 0GDFK2 v: A00 serial: UEFI: Dell
v: 1.7.1 date: 08/28/2019
ID-1: BAT0 charge: 45.4 Wh condition: 45.4/51.0 Wh (89%)
Topology: Quad Core model: Intel Core i5-9300H bits: 64 type: MT MCP
L2 cache: 8192 KiB
Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 800
3: 800 4: 800 5: 800 6: 800 7: 800 8: 800
Device-1: Intel driver: i915 v: kernel
Device-2: NVIDIA driver: N/A
Display: x11 server: X.Org 1.20.5 driver: modesetting unloaded: fbdev,vesa
resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2)
v: 4.5 Mesa 19.2.8
Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel
Device-2: NVIDIA driver: snd_hda_intel
Sound Server: ALSA v: k5.0.0-32-generic
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: r8169
IF: enp2s0 state: down mac: e4:54:e8:18:4c:ee
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
driver: ath10k_pci
IF: wlp3s0 state: up mac: b0:68:e6:f5:0e:75
Device-3: Atheros type: USB driver: btusb
Local Storage: total: 465.76 GiB used: 71.68 GiB (15.4%)
ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
ID-1: / size: 456.01 GiB used: 71.68 GiB (15.7%) fs: ext4 dev: /dev/dm-0
ID-2: swap-1 size: 980.0 MiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1
System Temperatures: cpu: 53.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 259 Uptime: 5m Memory: 7.64 GiB used: 2.54 GiB (33.2%)
Shell: zsh inxi: 3.0.32

/usr/bin/nvidia-debugdump -D

Error: nvmlInit(): Driver Not Loaded

I tried the solution suggested, however I receive this message:

sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf
rm: cannot remove ‘/lib/modprosudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf
rm: cannot remove ‘/lib/modprobe.d/blacklist-nvidia.conf’: No such file or directory
rm: cannot remove ‘/etc/modprobe.d/blacklist-nvidia.conf’: No such file or directory
be.d/blacklist-nvidia.conf’: No such file or directory
rm: cannot remove ‘/etc/modprobe.d/blacklist-nvidia.conf’: No such file or directory

To be honest I am not sure if I have provided enough information. Please advise.

Thank you.