Mint 19.2, Kernel 5.2: 430.40 driver won't load (RTX 2070 Optimus)

Hello, NVIDIA team! I upgraded to the latest Linux kernel to deal with heat issues on my brand-new laptop. Now the 430.40 driver won’t load (it was okay on kernel 4.15).

I uninstalled it with sudo apt remove --purge nvidia* and sudo apt autoremove, then rebooted, reinstalled it and after another reboot, nvidia-settings says this:

nvidia-settings

ERROR: NVIDIA driver is not loaded


ERROR: Unable to load info from any available system


(nvidia-settings:3131): GLib-GObject-CRITICAL **: 12:20:24.662: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
** Message: 12:20:24.667: PRIME: Requires offloading
** Message: 12:20:24.667: PRIME: is it supported? yes

It then launches its GUI and allows me to select the PRIME card, but there’s nothing else. Screenshot: https://pasteboard.co/IrJa9WO.png

modprobe nvidia says this:

thebrightside@SCHNITZELBOI:~$ sudo modprobe nvidia
modprobe: ERROR: could not insert 'nvidia': No such device

However, lspci says:

thebrightside@SCHNITZELBOI:~$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Device 3e98 (rev 02)
01:00.0 VGA compatible controller: NVIDIA Corporation Device 1f10 (rev a1)

My specs are:

thebrightside@SCHNITZELBOI:~$ inxi -Fz
System:
  Host: SCHNITZELBOI Kernel: 5.2.0-10-generic x86_64 bits: 64 
  Desktop: Cinnamon 4.2.3 Distro: Linux Mint 19.2 Tina 
Machine:
  Type: Laptop System: Notebook product: N9x0TD_TF v: N/A serial: <filter> 
  Mobo: Notebook model: N9x0TD_TF serial: <filter> UEFI: INSYDE v: 1.07.06 
  date: 04/23/2019 
Battery:
  ID-1: BAT0 charge: 58.8 Wh condition: 58.8/62.1 Wh (95%) 
CPU:
  Topology: 8-Core model: Intel Core i7-9700 bits: 64 type: MCP 
  L2 cache: 12.0 MiB 
  Speed: 1314 MHz min/max: 800/4700 MHz Core speeds (MHz): 1: 3488 2: 3713 
  3: 3587 4: 4153 5: 1295 6: 1866 7: 1980 8: 3756 
Graphics:
  Device-1: Intel driver: i915 v: kernel 
  Device-2: NVIDIA driver: nouveau v: kernel 
  Display: x11 server: X.Org 1.19.6 driver: modesetting,nouveau 
  unloaded: fbdev,vesa tty: N/A 
  OpenGL: renderer: Mesa DRI Intel HD Graphics (Coffeelake 3x8 GT2) 
  v: 4.5 Mesa 19.0.2 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel 
  Device-2: NVIDIA driver: snd_hda_intel 
  Sound Server: ALSA v: k5.2.0-10-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 
  IF: enp6s0f1 state: down mac: <filter> 
  Device-2: Intel driver: iwlwifi 
  IF: wlp7s0 state: up mac: <filter> 
  IF-ID-1: enp0s20f0u5 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:
  Local Storage: total: 2.75 TiB used: 3.03 TiB (110.2%) 
  ID-1: /dev/mmcblk0 model: TP02G size: 1.88 GiB 
  ID-2: /dev/nvme0n1 vendor: Samsung model: SSD 970 PRO 1TB size: 953.87 GiB 
  ID-3: /dev/sda vendor: Samsung model: SSD 860 QVO 2TB size: 1.82 TiB 
Partition:
  ID-1: / size: 29.67 GiB used: 13.77 GiB (46.4%) fs: ext4 
  dev: /dev/nvme0n1p5 
  ID-2: /home size: 1.79 TiB used: 1.33 TiB (74.5%) fs: ext4 dev: /dev/sda2 
  ID-3: swap-1 size: 1.40 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-0 
Sensors:
  System Temperatures: cpu: 50.0 C mobo: N/A gpu: nouveau temp: 41 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 329 Uptime: 9m Memory: 31.13 GiB used: 2.30 GiB (7.4%) 
  Shell: bash inxi: 3.0.32

Driver Manager shows the 430 driver as selected, but also says “No proprietary drivers are in use”. Screenshot: https://pasteboard.co/IrIpjac.png

Bug report log attached.

Any help will be greatly appreciated! I really hope we can find a solution to this.
nvidia-bug-report.log.gz (2.01 MB)

modprobe: ERROR: could not insert 'nvidia': No such device

most likely blacklisted, aliased to “off”. Try running

  • remove stray blacklist files (sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf)
  • update the initrd (sudo update-initramfs -u)
  • reboot
    otherwise, grep those directories for “nvidia” to find the correct files to remove.

Hey generix, thanks for your quick reply. Forgot to mention that I already looked for those files, there are none to be found anywhere on my system.

I did move any other files containing the term “nvidia” from those directories to somewhere in my home directory, then updated initrd. Rebooting now.

thebrightside@SCHNITZELBOI:/etc/modprobe.d$ sudo update-initramfs -u
update-initramfs: Generating /boot/initrd.img-5.2.0-10-generic
cryptsetup: WARNING: Invalid source device /swapfile
cryptsetup: WARNING: target cryptswap1 has a random key, skipped

No dice. Same as before.

Kernel driver in use: nouveau
	Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia

The nouveau blacklist file is missing.

I wrote a file called, blacklist-nouveau.conf and placed it in /lib/modprobe.d/ and /etc/modprobe.d/:

# Blacklisting nouveau
blacklist nouveau

After sudo update-iniramfs -u and a reboot, I landed on a black screen with a non-blinking command prompt cursor in the top left corner.

I removed the blacklisting for nouveau again and now I’m back on my desktop, but nothing has changed.

I tinkered with this some more, blacklisted nouveau again, then uninstalled and re-installed the 430 driver both from the PPA and from the .run file, every time it booted into a black screen and non-blinking command prompt cursor.

After more struggling, I managed to revive nouveau and I’m back again at square one.

Please re-enable the nvidia driver, boot to black screen, then reboot to safe mode and run
sudo journalctl -b-1 --no-pager _COMM=gdm-x-session >journal.log
and attch the output file afterwards.

Hi Generix! I went back to kernel 4.15 yesterday and discovered that my attempts at installing, re-installing and tinkering had borked my system so far that the driver was completely broken, even on the older kernel where it previously worked.

I re-installed Mint 19.2 from scratch and it’s now running stable (albeit a bit on the warm side) on kernel 4.15. For the time being, I’d prefer not to mess with it anymore, since this is currently my main PC and I need to get back to my daily life :-)

Thanks for all your help. I’m hoping that when the next versions of Mint with new default kernels roll around, this will have become a non-issue.

In the meantime, if I come across some free time to try the new kernel again, I’ll post back here.