Problem: 430 driver not recognised on Linux Mint 19.2?

Hello,

I am brand new to Linux and been trying to get a couple of my old games to work on it for the past 2 weeks with little success.
I have followed the guides provided by Lutris (https://github.com/lutris/lutris/wiki/Installing-drivers specific to the issue I’m writing about), but when it kept complaining about Vulkan I tried running inxi -Gx as seen on a forum, which revealed the following issue:

Graphics:
Device-1: Intel Haswell-ULT Integrated Graphics vendor: ASUSTeK
driver: i915 v: kernel bus ID: 00:02.0
Device-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT
620M/625M/630M/720M]
vendor: ASUSTeK driver: N/A bus ID: 04:00.0
Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa
resolution: 1366x768~60Hz, 1366x768~60Hz
OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 19.0.8
direct render: Yes

I have triple checked by now, I installed the 430.40 driver (which according to the download drivers site, should be good for my GeForce 820M card if I understand it correctly), but it seems like it isn’t recognised?
When I open Driver manager it says I’m using a manually installed driver and that no proprietary drivers are in use (instead of the 340 nvidia one that is “recommended” but when I switched to that and restarted all I got was a black screen, but I doubt it has much to do with my current issue - or a nouveau one).

I’ll attach the bug report log.gz file the moment I realise how to. - New log file after installing 390 is attached later in the thread.
nvidia-bug-report.log.gz (101 KB)

Screenshot from 2019-12-01 12-29-05.png

Please try this:

  • make sure nvidia-prime is installed (sudo apt install nvidia-prime)
  • switch to nvidia (sudo prime-select nvidia)
  • remove stray blacklist files (sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf)
  • update the initrd (sudo update-initramfs -u)
  • reboot
    If this doesn’t resolve the issue, please create a new nvidia-bug-report.log.

Forget what I said, I only now recognized you have an old Fermi gpu. This is only supported by the legacy 390 driver. Use the Software&Updates application to switch from nvidia-430 to nvidia-390.

I tried this and now I have the same black screen issue after booting like I used to have after I switched to 340 driver. I can’t even get to the login screen.

With ctrl+alt+F1 i can get a termi al up but that’s about all I’m afraid.

Ok, please create a new nvidia-bug-report.log
If you have internet connection, you can use pastebinit to upload it from console.

  • install pastebinit (sudo apt install pastebinit)
  • unzip logfile (gunzip nvidia-bug-report.log.gz)
  • upload logfile (pastebinit -i nvidia-bug-report.log)
  • note down and post the url you’re given

…and you should rather use the 390 instead of the 340 driver.

I am using the 390 driver, I just mentioned the 340 because the issue looked similar to what I experienced with that one, I’m sorry for the confusion.

After the pastebinit command it returned: “Bad API request, maximum paste file size exceeded”.

I tried a startx command and alone it didn’t seem to do much, however if after I’ve heard the start up tune, press fn+f8 (switches between screen modes if multiple screens are connected) the screen comes back live again. Startx alone or fn+f8 alone doesn’t seem to work (although I have not waited more than a minute in either case)

At least I can post the bug report file generated after the reboot.
nvidia-bug-report.log.gz (559 KB)

According to the logs, everything comes up fine. Probably the DM is not calling the xrandr commands to enable the internal screen. Which Mint flavour are you using, i.e which DE?

I’m using the 64-bit Cinnamon.

Please upgrade the HWE stack to the latest:
https://wiki.ubuntu.com/Kernel/LTSEnablementStack
and check if that resolves the issue.

Sadly it didn’t resolve the problem.

Please check if the file /sbin/prime-offload exists, rename it to /sbin/prime-offload.old
Re-create it /sbin/prime-offload with contents

#!/bin/sh
xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

make it executable (sudo chmod ogu+x /sbin/prime-offload)
and reboot.

Sorry for the slow advancement, weekdays can get a bit hectic.

I haven’t found a “prime-offload” file. I have created one (assuming I should) as you described but it wasn’t the solution.

If it didn’t exist, please delete the one you created. This would point to the package nvidia-prime not being correctly installed. Please reinstall it
sudo apt install --reinstall nvidia-prime
and check if the file /sbin/prime-offload exists afterwards.

That did the trick, thank you for your help!

Should I change the topic title (in case anyone has a similar or same issue) or just leave it as is?

Title should be sufficient, the initial problem was the wrong driver being used for your gpu.