Linux driver 390xx not working

hello guys, i have a lenovo g50 30 with debian installed on it.
after i was installing nvidia 470, it said install 390 driver instead of 470.
so i installed it and no error,
but the problem is xorg server
i used nvidia-xconfig but it boots into blank screen, and i have to remove xorg config to fix it. after i remove it, my laptop will use intel instead of nvidia.

my graphic driver: 390xx
distro: debian
laptop model; lenovo g50-30
graphic model: geforce 820m

Hello @rezaebr3234s4,

the most current driver version for the 820M on Linux is actually 430.40, you can check that on the driver download pages.

Can you use prime-select nvidiato enable usage of nvidia instead of intel?

Please try those things first.


Thanks for responding.
As you said, i’ve installed nvidia 430 driver for linux
And still getting message that 390.xx is supported for me

And also there is no prime-select command.

Can you copy the exact message about the 390 driver here please? I am surprised that would come up.

What are the rest of the specs of the laptop?

And please share the resulting file of here. Maybe then we can check what might be going wrong.


Since i use systemctl stop lightdm, and i install without x server ( because driver will stop progress due to xserver) so i cant copy message, but if u want i can take a picture of it. And also, i uninstalled nvidia 390 to prevent my laptop from any problem because im installing another driver. There is no nvidia bug report.

If its helpful, i can install 390xx again and send a bug report

If you have any NVIDIA driver installed, the bug report can be created.

If you have no NVIDIA driver installed, then there will be the Open Source nouveau driver running and I can’t help you with that. Or the system will only use the integrated graphics.

At this point I am not completely certain I understand what you want to achieve?

At first, I installed the 390XX driver from the Debian terminal, and then when I installed it, when I used the nvidia-settings command, it said that the driver is not in use, then use the nvidia-config command, when I used it, the screen was black. goes up So I deleted xconfig. After this, everything was ok, but I got the same error again, I told you here and you said to install 430, I did it, and it says your card is not supported and you have to install 390 and it wont install, there is no nvidia bug report because before installing 430 I deleted all the drivers so that no problem would happen to the laptop

Thank you for the clarification.

It seems there are some constraints with respect to Debian and older Hardware. Surprisingly the 820M only supports up to the 390.144 driver on newer distributions, or max 418.197.02 on Debian 10.

There is a note on the Debian Driver installation pages that worries me:

Some designs incorporating supported GPUs may not be compatible with the NVIDIA Linux driver:
in particular, notebook and all-in-one desktop designs with switchable (hybrid) or Optimus graphics will not work if means to disable the integrated graphics in hardware are not available.
Hardware designs will vary from manufacturer to manufacturer, so please consult with a system’s manufacturer to determine whether that particular system is compatible.

Still, this does not explain why X does not work after installing the 390.144 driver.

Did the Laptop initially not use the NVIDIA GPU? or why did you want to install the 470 driver?

In any case, if you want to continue debugging, please install an NVIDIA driver and share the debug log as described above.

And please share the spec details of your Lenovo laptop.

I dont want to install 470 driver. As i said before, i tried to install 470 which is recommended by a friend and after installing it, at the startup log, it said install 390 instead of 470. So i did it. After installing 390, my laptop doesnt used it as nvidia-settings app said:

You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.

After that, i installed nvidia-xconfig simply and i ran:
After that, i rebooted to make sure if my laptop is using our driver. And well. Black screen goes up. So, i simply removed xorg.conf file to fix blank screen.
But still getting this error:

You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.

I have no idea to fix it
Os: linux
Distro: debian ( normal debian, not debian based)
Intel® Celeron® Processor N2830 (2.16 GHz 1600MHz 1MB)

Memory: 4gb
Graphics: intel integrated + nvidia geforce 820m

What Debian version?

Please run


and attach the resulting nvidia-bug-report.log.gz file to this thread.

The default xorg.conf might not be correct for your system. That relates to the sentenced I highlighted before. Debian and these older systems and GPU drivers require some manual setup work to get the Optimus feature and XOrg to work correctly. There are a lot of resources on this topic both here in the Linux forum category and if you search in Debian specific forums.

using latest debian, 11, bullseye

installing 390x as you said

as you can see, there is no xconfig. so nvidia-xconfig just created a new one.
this is command output:

realsuperuser@debian:~$ sudo nvidia-xconfig

WARNING: Unable to locate/open X configuration file.

New X configuration file written to '/etc/X11/xorg.conf'

and this is our new xconfig:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 470.103.01

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "Files"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24

Also let me create a nvidia bug report

nvidia-bug-report.log.gz (67.0 KB)

According to your log, the nvidia installer version was 430:

*** /var/log/nvidia-installer.log
*** ls: -rw-r--r-- 1 root root 954 2023-05-30 04:40:05.023699628 -0400 /var/log/nvidia-installer.log
nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Tue May 30 04:09:48 2023
installer version: 430.40

But the main log messages say that the 390 driver is installed. How did you install the 390 without properly removing the 430 driver?

Then there is the fact that the xconfig is created based on the 470 driver

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 470.103.01

You need to remove previous driver files before installing a different driver. Especially if you are downgrading.
Right now the easiest might be to start from scratch and re-install a clean Debian and then install the 390 driver following the Debian specific instructions very closely.