GLib-GObject-CRITICAL after driver update (Geforce MX250)

Hello, after updating the drivers for the video card on my ThinkPad T490, ubuntu does not see it in the settings.

nvidia-bug-report.log.gz (262.5 KB)

piletskiy@piletskiyPC:~$ sudo ubuntu-drivers autoinstall
[sudo] password for piletskiy:
WARNING:root:_pkg_get_support nvidia-driver-510-server: package has invalid Support PBheader, cannot determine support level
WARNING:root:_pkg_get_support nvidia-driver-510: package has invalid Support PBheader, cannot determine support level
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
0 upgraded, 0 newly installed, 0 to remove and 60 not upgraded.

The driver is installed and loading fine.
You are in on-demand Prime profile. Your X screen is driven by the intel iGPU.

Switch to “Performance Mode” for your nvidia GPU to render the graphics and pass it to the iGPU for display.

Before the update, I saw both video cards in the settings, and now the Intel video card is listed there twice (even in Performance Mode), and before the update, I saw information in PRIME, but now it is empty

You’re not in offload mode but Xorg is crashing and the DE is falling back to Wayland

 /usr/libexec/gdm-x-session[930]: Xorg: ../../../../dix/privates.c:384: dixRegisterPrivateKey: Assertion `!global_keys[type].created' failed.
/usr/libexec/gdm-x-session[930]: (EE)
 /usr/libexec/gdm-x-session[930]: (EE) Backtrace:
 /usr/libexec/gdm-x-session[930]: (EE) 0: /usr/lib/xorg/Xorg (OsLookupColor+0x139) [0x55e036a47cf9]
/usr/libexec/gdm-x-session[930]: (EE) 1: /lib/x86_64-linux-gnu/ (__sigaction+0x50) [0x7f0f797d5520]
 /usr/libexec/gdm-x-session[930]: (EE) 2: /lib/x86_64-linux-gnu/ (pthread_kill+0xf8) [0x7f0f79829828]
 /usr/libexec/gdm-x-session[930]: (EE) 3: /lib/x86_64-linux-gnu/ (raise+0x16) [0x7f0f797d5476]
 /usr/libexec/gdm-x-session[930]: (EE) 4: /lib/x86_64-linux-gnu/ (abort+0xd7) [0x7f0f797bb7b7]
 /usr/libexec/gdm-x-session[930]: (EE) unw_get_proc_name failed: no unwind info found [-10]
 /usr/libexec/gdm-x-session[930]: (EE) 5: /lib/x86_64-linux-gnu/ (?+0x0) [0x7f0f797bb6db]
 /usr/libexec/gdm-x-session[930]: (EE) 6: /lib/x86_64-linux-gnu/ (__assert_fail+0x46) [0x7f0f797cce26]
 /usr/libexec/gdm-x-session[930]: (EE) 7: /usr/lib/xorg/Xorg (dixRegisterPrivateKey+0x249) [0x55e0368ffe09]
 /usr/libexec/gdm-x-session[930]: (EE) 8: /usr/lib/xorg/modules/ (glamor_init+0xcd) [0x7f0973f3d3ed]
/usr/libexec/gdm-x-session[930]: (EE) unw_get_proc_name failed: no unwind info found [-10]
 /usr/libexec/gdm-x-session[930]: (EE) 9: /usr/lib/xorg/modules/drivers/ (?+0x0) [0x7f0973f7c2cd]

There’s also a log from an ealier, working boot captured and neither
nvidia driver
have been updated. What exactly has been installed on update?
Overall, the issue seems to be with the intel igpu, it also takes ages to initialize after firmware load so it’s not even available sometimes.

After installing ubuntu, I had open source drivers installed (bottom in the picture), I installed proprietary 470 (because they are signed tested)

After that, ubuntu started up as it should and displayed both video cards in the settings and all parameters were displayed in nvidia-settings. In nvidia-settings, I enabled perfomance-mode and rebooted, after that the video card disappeared from the settings and nvidia-settings is now empty. Tried reinstalling the opensource/proprietary drivers several times - didn’t help

It’s some bug with the Xserver/modesetting driver.
Please check if adding the drivers to the initrd helps, add the lines
and run
sudo update-initramfs -u

You can switch back to offload mode using
sudo prime-select on-demand

Added. After reboot, there are NVIDIA Corporation GP108M [GeForce MX250] / NVIDIA GeForce MX250/PCIe/SSE2 in Ubuntu Settings and a lot of information in nvidia-settings

You also switched back to offload mode. Does performance mode also work?

Performance mode remained selected in the nvidia-settings after the reboot. How can I check this for sure?

The terminal window is blocking the view on the interesting info.
To check for the nvidia gpu to be primary, run
glxinfo |grep vendor
should output “Nvidia” for performance mode, “Intel” for offload mode.

piletskiy@piletskiyPC:~$ glxinfo |grep vendor
server glx vendor string: NVIDIA Corporation
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation

Seems fine.

Perfect :) And now I see GPU Utilization > 0, was zero before…
Now I have to do the same for windows 10…

Thank you very much for your help!

which post should i mark as solution?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.