Nvidia On-Demand offloading not works correctly after software update

Hi, I am using Kubuntu 20.04.2 and I have problem with ‘On-Demand’ profile from nvidia-settings. It worked fine just two days ago.

Yesterday I updated few packages through Plasma Discover including the package for configuring external drivers (I’m not sure what is the exact name of this package). After that I’ve noticed my Nvidia card not switch properly. When I run command ‘__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia glxgears -info’ I got output:
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 152 (GLX)
Minor opcode of failed request: 3 (X_GLXCreateContext)
Value in failed request: 0x0
Serial number of failed request: 25
Current serial number in output stream: 26

When starting without any additional parameters the Mesa Intel graphics driver is loading.

Furthermore, in the nvidia-settings app only “PRIME Profiles” section is presented now. Earlier I saw more options. This is weird because nvidia drivers were not updated recently.

I am not sure if updating software for handling external driver could do such mess…

How to make offloading works again?
nvidia-bug-report.log.gz (272.8 KB)

Please see this:
Also, please remove ‘nogpumanager’ from kernel command line.

Thanks @generix, that was quick, it works now.