Trouble installing nvidia driver 440 on Linux Mint

Hello,

As written in the title, I have trouble running the nvidia-driver-440 driver.

When I run inxi -G, I get this result :

Graphics:  Device-1: Intel driver: i915 v: kernel 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: N/A 
           Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
           resolution: 1920x1080~60Hz, 1360x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) v: 4.5 Mesa 19.2.8 

And when I run nvidia-settings, i get :


ERROR: NVIDIA driver is not loaded


ERROR: Unable to load info from any available system


(nvidia-settings:22282): GLib-GObject-CRITICAL **: 22:10:18.453: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
** Message: 22:10:18.457: PRIME: No offloading required. Abort
** Message: 22:10:18.457: PRIME: is it supported? no

I tryed :

  • Removing all nvidia packages with the command sudo apt purge nvidia*

  • Removing the /lib/modprobe.d/blacklist-nvidia.conf file then run sudo update-initramfs -u

With no success…

Can someone please help me ? I attached to this message the nvidia bug report.
Thanks in advance.

nvidia-bug-report.log (923.5 KB)

Please switch to nvidia mode:
sudo prime-select nvidia
You’re currently in intel only mode and the nvidia gpu is turned off.

1 Like

Hello,

I typed sudo prime-select nvidia again and it returned Info: the nvidia profile is already set

I attached the bug report again

nvidia-bug-report.log (1.1 MB)

Please make sure gpu-manager is enabled
sudo systemctl enable gpu-manager
reboot, then attach /var/log/gpu-manager.log

1 Like

I enabled the gpu-manager, /var/log/gpu-manager.log : gpu-manager.log (1.4 KB)

Do you have bumblebee installed in parallel to nvidia-prime?

1 Like

Yes, bunblebee was installed, so I removed it and it works now !
Thank you very much !

Hello! I’d like to follow this thread as I’m having the same issue - I don’t have bumblebee installed.
My results have been the same as mc.yohann’s.

I purged and reinstalled my nvidia 440 driver, on my linux Mint 19.3, using kernal 5.4.X.

Disable Secure Boot from bios.

My issue was resolved as my gcc compiler was mismatching. This may not be the same cause for most, but this thread will help others know what information to give regarding Nvidia driver issues: https://forums.linuxmint.com/viewtopic.php?p=1844611#p1844611