Installed Nvidia driver but doesn't seemed to be used

Hi! I have a Ubuntu 18.04 on an an alienware laptop, which has an GTX 1070 (mobile?).

I installed the driver through:
sudo add-apt-repository ppa:graphics-drivers/ppa
sudo ubuntu-drivers autoinstall
sudo apt-get install nvidia-driver-460 (instead of nvidia-driver-460-server, which was the recommed one when running ubuntu-drivers devices)

I think these were all the steps I took to install the driver. However, there are multiple issues that really make me think that I did not install it correctly.

  1. nvidia-smi
    NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

  2. nvidia-settings
    ERROR: NVIDIA driver is not loaded
    ERROR: Unable to load info from any available system

(nvidia-settings:11901): GLib-GObject-CRITICAL **: 19:41:27.343: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed
** Message: 19:41:27.346: PRIME: No offloading required. Abort
** Message: 19:41:27.346: PRIME: is it supported? no

  1. inxi -G
    Graphics: Card-1: Intel HD Graphics 530
    Card-2: NVIDIA GP104M [GeForce GTX 1070 Mobile]
    Display Server: x11 (X.Org 1.20.8 ) driver: i915 Resolution: 3840x2160@60.00hz
    OpenGL: renderer: Mesa DRI Intel HD Graphics 530 (SKL GT2) version: 4.6 Mesa 20.0.8

As you can see the OpenGL has intel instead of Nvidia.

However, I am able to use prime-select to switch between intel and nvidia.
Besides, if I run
dkms status
nvidia, 460.56, 5.4.0-42-generic, x86_64: installed
nvidia, 460.56, 5.4.0-66-generic, x86_64: installed

I followed a link and tried
sudo apt install nvidia-cuda-toolkit
which did not solve the issue, and even kind of made it worse because nvidia-settings now opens up a blank window, while before it opens up a window that can switch between nvidia and intel.

Can someone help please? Thank you!
nvidia-bug-report.log.gz (119.1 KB)

Please run as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Hi! I just edited my post and attached the file. Thank you!

You have secure boot enabled, please disable it in bios.

1 Like

Thank you so much it worked!