Black screen after installing Nvidia drivers in Linux Mint


First of all, thanks in advance. I know this must not be easy to do.

So, I just installed a fresh Linux Mint distribution on my new HP laptop (GeForce RTX 4060), it was using the nouveau drivers by default, but the games’ performance was really lacking, even for those that should really perform pretty well with these specs. I then checked and saw that there were actually no drivers in use.

Running “inxi -G” returns:

Device-1: Intel driver: N/A
Device-2: NVIDIA driver: N/A
Device-3: Quanta HP True Vision FHD Camera type: USB driver: uvcvideo
Display: x11 server: X.Org v: driver: X: loaded: vesa
unloaded: fbdev,modesetting gpu: N/A resolution: 1920x1080~77Hz
OpenGL: renderer: llvmpipe (LLVM 15.0.7 256 bits)
v: 4.5 Mesa 22.2.5-0ubuntu0.1~22.04.3

When launching nvidia-settings, the message “ERROR: NVIDIA driver is not loaded” appears. I then switched through the Driver Manager to the NVidia drivers, especifically the 535.54.03, the optimal for my machine. However, rebooting leads to a black screen. After some back and forth and a lot of research, I’ve now got that NVidia driver selected in the Driver Manager, but running the Intel ones to access the Desktop GUI. However, running the previous commands returns the same outcome, and the struggle to run games persists. What should I do? Help is really appreciated.

I was going to attach the bug report but the page doesn’t let me since I’m a new user…


did you try:
prime-select nvidia

Yup, and that’s when I return to that black screen after the Mint logo appears

Ok, so I just discovered that when the screen turns black, connecting an external monitor works, and it runs the drivers, but it doesn’t detect my laptop’s display. Weird…

Maybe you have a laptop, which internal display is not connected to the nvidia gpu.

Any settings gpu wise in the UEFI BIOS available?

The only one I see is “Graphics switch”, described as “Select which of SG/PEG Graphics device should be Primary Display”, letting me choose between Hybrid and Discrete

Discrete should be only the nvidia gpu is turned on.
Hybrid both are active (and should behave in an “Optimus” way).

Switching to Discrete solved the problem! Maybe it was something related to the Intel drivers… Either way, I cannot thank you enough!