Drivers not loaded on Linux mint - Lenovo Ideapad Gaming 3 GTX1650

I have a Lenovo Ideapad Gaming 3 Notebook with an AMD Ryzen 7 4800 and a GTX 1650 GPU. I cannot get an external monitor to work on the HDMI port. I have tried a lot of posted solutions online without luck. Nvidia drivers v470 are installed through the driver manager, but the inxi -G command shows no drivers installed for Nvidia, it doesn’t even show the GPU series:

Graphics:
Device-1: NVIDIA driver: N/A
Device-2: AMD Renoir driver: amdgpu v: kernel
Display: x11 server: X.Org 1.20.11 driver: amdgpu,ati
unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz
OpenGL:
renderer: AMD RENOIR (DRM 3.42.0 5.14.10-051410-generic LLVM 12.0.0)
v: 4.6 Mesa 21.0.3

My OS is Linux Mint 20.2 uma. Attached the bug report.
My monitor works using nouvou drivers, but no driver is recognized when I select Nvidia Drivers on mint driver manager.

nvidia-bug-report.log.gz (89.6 KB)

You might want to try this and disabling secure boot from BIOS if you haven’t already.

Judging from the things I cannot see, I would guess you don’t have the kernel headers for your kernel installed. The package you’d need would be something like: linux-headers-$(uname -r).
So if that’s the case, install that. check with dkms status, the status of the kernel module build - if it says “added”, you can either install it through dkms, or re-install the driver using apt.

Hi guys,

I tried both solutions, dkms status showed the driver as added, trying to install them correctly I realized that linux-headers where not installed. It turns out that I was using a kernel (5.14) that is not fully supported by mint 20.2, I downgraded to kernel 5.8.0 and I was able to build the drivers correctly, dkms status shows now:
nvidia, 470.74, 5.8.0-050800-generic, x86_64: installed
After rebooting, my external monitor works perfect and the drivers load:

Graphics:
Device-1: NVIDIA driver: nvidia v: 470.74
Device-2: AMD Renoir driver: amdgpu v: kernel
Display: x11 server: X.Org 1.20.11 driver: amdgpu,ati,nvidia
unloaded: fbdev,modesetting,nouveau,vesa
resolution: 1920x1080~60Hz, 1920x1080~60Hz
OpenGL: renderer: NVIDIA GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA 470.74

Thank you very much for your help

Interesting. 5.14 works just fine on my end. Mint 20.

System:
  Host: asus-FX553VD Kernel: 5.14.11-xanmod1 x86_64 bits: 64 compiler: N/A 
  Desktop: Cinnamon 5.0.5 wm: muffin dm: GDM3, LightDM 
  Distro: Linux Mint 20.2 Uma base: Ubuntu 20.04 focal 
Machine:
  Type: Laptop System: ASUSTeK product: GL553VD v: 1.0 
  serial: <superuser/root required> 
  Mobo: ASUSTeK model: GL553VD v: 1.0 serial: <superuser/root required> 
  UEFI: American Megatrends v: GL553VD.308 date: 04/29/2019 
Graphics:
  Device-1: Intel HD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:591b 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: ASUSTeK 
  driver: nvidia v: 470.74 bus ID: 01:00.0 chip ID: 10de:1c8d 
  Display: x11 server: X.Org 1.20.11 driver: modesetting,nvidia 
  unloaded: fbdev,nouveau,vesa resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) 
  v: 4.6 Mesa 21.2.3 - kisak-mesa PPA direct render: Yes