ubuntu 19.10 with driver 440 - NVIDIA driver is not loaded - rtx 2060 mobile

And I greet everyone.
I have a laptop DELL G5 5590, IPS, Intel Core i7 9750H 2.6 GGZ, 16Gb RAM, 512Гб SSD, nVidia GeForce RTX 2060 - 6144 Мб, Ubuntu 19.10.

And I have a similar problem - the computer does not use my RTX 2060 graphics card, but instead uses the integrated Intel UHD Graphics 630 (Coffeelake 3x8 GT2).
Although I tried to follow these steps in order, the problem did not resolve.
In any case, I always get one result:

$ nvidia-settings

ERROR: NVIDIA driver is not loaded

ERROR: Unable to load info from any available system

(nvidia-settings: 15939): GLib-GObject-CRITICAL **: 11: 09: 05.472: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed
** Message: 11: 09: 05.474: PRIME: Requires offloading
** Message: 11: 09: 05.474: PRIME: is it supported? yes

Please tell me what I’m missing? If I’m not mistaken, following the advice, but not correctly executing it, perhaps deleted the directory / lib / … fixable?)
I just switched to the operating system and until I figured it out)))

4 hours ago I turned to the forum with a problem, but so far I have not received an answer. Could any of you help figure out the reason? Here is a link to a parsing in the forum about this problem, but either I’m doing something wrong or the solution does not suit me. I try to understand not the first day in breaks from work))

https://devtalk.nvidia.com/default/topic/1066356/linux/ubuntu-19-10-with-driver-440-31-no-nvidia-graphics-adapter-found-on-rtx2060-mobile/?offset = 9 #

Please, help me))

I have the same problem with the same machine. Any news?

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post. You will have to rename the file ending to something else since the forum software doesn’t accept .gz files (nifty!).

nvidia-bug-report.log (1.2 MB)
I could not upload the fie in compressed way, although I changed the name.
I hope you can help me

Looks like the driver is now blacklisted but in previous boot were getting

[    5.999096] NVRM: GPU 0000:01:00.0: RmInitAdapter failed! (0x26:0xffff:1227)

meaning the gpu couldn’t be initialized. This can be a general hardware failure or an incompatibility. Does the nvidia gpu work on Windows?

Thank you.
I bought pre-installed by dell with 18.04. When I tried to use after several months it stopped booting with files xxx/xxx blocks xxx/xxx. Thus I purged nvidia, it booted, I upgraded to 19.10 and that’s all.
Dell guys were not able to help me. But now with your suggestion, I’ll phone to then again.

You might try this:
Shut down notebook, then press and hold the power button for 30 seconds (>25s,<40s). Then boot normally and try getting the nvidia gpu working again:

  • sudo prime-select nvidia
  • sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf
  • sudo update-initramfs -u
  • reboot
    if that doesn’t work, please create a new nvidia-bug-report.log from Ubuntu recovery mode

The screen remained black, and I could not access it. I tried from recovery mode but it did not work.

You could try editing the kernel commandline in grub menu, adding