ubuntu 19.10 with driver 440.31 No NVIDIA graphics adapter found on rtx2060 mobile

Hi, i hava a ‘No NVIDIA graphics adapter found’ problem on my ASUS ZenBook UX581GV laptop with a integrated nvidia RTX-2060 graphic card on it.

I did try:

  • Nvidia drivers from ubuntu 19.04
  • drivers 430.x
  • daily build 19.10 mainline kernel

CPU: 2.4GHz Intel Core i9-9980HK (octa-core, 16MB cache, up to 5GHz)
Graphics: Nvidia GeForce RTX 2060.
RAM: 32GB DDR4 (2,666MHz)
Screen: 15.6-inch, OLED Ultra HD (3,840 x 2,160), 14-inch Ultra HD (3,840 x 1,110) touch display.
Storage: 2TB PCIe SSD.

Thankx for the help.
nvidia-bug-report.log.gz (97.6 KB)

The kernel doesn’t see any nvidia device. If there really is one in your system, it’s either disabled in bios or broken.

Ok, I have to correct myself, taking a deeper look at the log the nvidia gpu is detected by the kernel but then removed by it for unknown reasons. Please try this:
Create /etc/modprobe.d/blacklist-i2c-nvidia-gpu.conf with contents

blacklist i2c_nvidia_gpu

then run
sudo update-initramfs -u
and reboot.
Please also post the output of
grep 10de /lib/udev/rules.d/*

/lib/udev/rules.d/71-nvidia.rules:SUBSYSTEM==“pci”, ATTRS{vendor}==“0x10de”, DRIVERS==“nvidia”, TAG+=“seat”, TAG+=“master-of-seat”
/lib/udev/rules.d/80-pm-nvidia.rules:ACTION==“add”, SUBSYSTEM==“pci”, ATTR{vendor}==“0x10de”, ATTR{class}==“0x0c0330”, ATTR{remove}=“1”
/lib/udev/rules.d/80-pm-nvidia.rules:ACTION==“add”, SUBSYSTEM==“pci”, ATTR{vendor}==“0x10de”, ATTR{class}==“0x0c8000”, ATTR{remove}=“1”
/lib/udev/rules.d/80-pm-nvidia.rules:ACTION==“add”, SUBSYSTEM==“pci”, ATTR{vendor}==“0x10de”, ATTR{class}==“0x040300”, ATTR{remove}=“1”
/lib/udev/rules.d/80-pm-nvidia.rules:ACTION==“add”, SUBSYSTEM==“pci”, ATTR{vendor}==“0x10de”, ATTR{class}==“0x030000”, ATTR{remove}=“1”
/lib/udev/rules.d/80-pm-nvidia.rules:ACTION==“bind”, SUBSYSTEM==“pci”, ATTR{vendor}==“0x10de”, ATTR{class}==“0x030000”, TEST==“power/control”, ATTR{power/control}=“auto”
/lib/udev/rules.d/80-pm-nvidia.rules:ACTION==“bind”, SUBSYSTEM==“pci”, ATTR{vendor}==“0x10de”, ATTR{class}==“0x030200”, TEST==“power/control”, ATTR{power/control}=“auto”
/lib/udev/rules.d/80-pm-nvidia.rules:ACTION==“unbind”, SUBSYSTEM==“pci”, ATTR{vendor}==“0x10de”, ATTR{class}==“0x030000”, TEST==“power/control”, ATTR{power/control}=“on”
/lib/udev/rules.d/80-pm-nvidia.rules:ACTION==“unbind”, SUBSYSTEM==“pci”, ATTR{vendor}==“0x10de”, ATTR{class}==“0x030200”, TEST==“power/control”, ATTR{power/control}=“on”

Ok, it’s this:

/lib/udev/rules.d/80-pm-nvidia.rules:ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x030000", ATTR{remove}="1"

it’s removing the nvidia gpu from the bus. The rest of the file are rules to prepare for render offload.
This looks like something changed in Ubuntu’s prime-select/nvidia-prime again, don’t really know what’s the point of doing this… Please post the output of
sudo prime-select query

sudo prime-select query

only 1 line

Ok, must be an Ubuntu bug then. Please delete /lib/udev/rules.d/80-pm-nvidia.rules
and run
sudo update-initramfs -u
then reboot and check if the file got re-created or the nvidia gpu is available.
How did you currently install the driver?

Thank you, the problem is solved.

I use the following instructions to install the driver.

sudo apt-get purge nvidia*
sudo apt autoremove
sudo add-apt-repository ppa:graphics-drivers
sudo apt-get update
sudo apt-get install nvidia-driver-440

And I greet everyone.
I have a laptop DELL G5 5590, IPS, Intel Core i7 9750H 2.6 GGZ, 16Gb RAM, 512Гб SSD, nVidia GeForce RTX 2060 - 6144 Мб, Ubuntu 19.10.

And I have a similar problem - the computer does not use my RTX 2060 graphics card, but instead uses the integrated Intel UHD Graphics 630 (Coffeelake 3x8 GT2).
Although I tried to follow these steps in order, the problem did not resolve.
In any case, I always get one result:

$ nvidia-settings

ERROR: NVIDIA driver is not loaded

ERROR: Unable to load info from any available system

(nvidia-settings: 15939): GLib-GObject-CRITICAL **: 11: 09: 05.472: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed
** Message: 11: 09: 05.474: PRIME: Requires offloading
** Message: 11: 09: 05.474: PRIME: is it supported? yes

Please tell me what I’m missing? If I’m not mistaken, following the advice, but not correctly executing it, perhaps deleted the directory / lib / … fixable?)
I just switched to the operating system and until I figured it out)))

Please, help me))

Please open a new thread, run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.