NVIDIA driver suddenly missing

Hi all,

I have a dell G15 laptop with ubuntu 20.04, and a NVIDIA RTX 3060.
I managed to install the drivers and get a working setup. However, this morning I was suddenly unable to do anything related to my GPU.

When I am running the command “nvidia-settings”, I get this error :

ERROR: NVIDIA driver is not loaded
ERROR: Unable to load info from any available system
(nvidia-settings:5303): GLib-GObject-CRITICAL **: 13:08:02.722: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed
** Message: 13:08:02.725: PRIME: No offloading required. Abort
** Message: 13:08:02.725: PRIME: is it supported? no

When I run nvidia-smi, I get this error:

NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

Do you have any idea where this problem could come from, and what to do to solve it?
Maybe I should that I already disabled the secure boot.

I attach the bug report to this post.

Thanks a lot!
nvidia-bug-report.log.gz (80.6 KB)

Looks like you had a kernel update and either headers were not installed or the driver isn’t using dkms. How did you previously install the driver?
Please post the output of
dkms status

Thanks for you answer!

I installed the driver following the procedure given on https://linuxconfig.org/how-to-install-the-nvidia-drivers-on-ubuntu-20-04-focal-fossa-linux; i.e. using
$ sudo ubuntu-drivers autoinstall

dkms was not installed on my laptop. Once installed, the command
dkms status
doesn’t return anything…

That’s most odd, looks like everything went awol while the tools are still there. Please reinstall the nvidia driver using Software&Updates and check dkms status again.

I reinstalled the nvidia-driver using Software & Updates.

dkms status now returns:
nvidia, 470.86, 5.11.0-41-generic, x86_64: installed

but nvidia-smi still returns the same error.

Please create a new nvidia-bug-report.log after reboot.

After reboot, everything seems to be working again… thanks a lot!

Just in case you would still be interested in it, I still attach the new bug report now that nvidia-smi and nvidia-settings are working well.
nvidia-bug-report.log.gz (306.2 KB)