Nvidia RIVA not working on jetson nano

I am using an nvidia jetson nano 2GB model, with a 64GB microSD card using the image jetson-nano-2gb-sd-card-image_JP4.6.1_b110
I followed the steps related in Riva Skills Quick Start | NVIDIA NGC

After downloading the image using:
ngc registry resource download-version nvidia/riva/riva_quickstart:1.10.0-beta
i edited the lines of config.sh:

  • riva_target_arch=“arm64”
  • language_code(“es-US”)

Saving it and launching
sudo bash riva_start.sh and getting the following results:

Logging into NGC docker registry if necessary…
Pulling required docker images if necessary…
Note: This may take some time, depending on the speed of your Internet connection.

Pulling Riva Speech Server images.
Image nvcr.io/nvidia/riva/riva-speech:1.10.0-beta-server exists. Skipping.

Downloading models (RMIRs) from NGC…
Note: this may take some time, depending on the speed of your Internet connection.
To skip this process and use existing RMIRs set the location and corresponding flag in config.sh.
Error response from daemon: Container 1921d21a950dc73a13ff21c20839da78cfd16bb1eb1dd0a394d0f8407b8eea51 is not running
Error in downloading models.
and it finishes.

Even if i try running sudo bash riva_start.sh

WARNING: The requested image’s platform (linux/amd64) does not match the detected host platform (linux/arm64/v8) and no specific platform was requested
Starting Riva Speech Services. This may take several minutes depending on the number of models deployed.
WARNING: The requested image’s platform (linux/amd64) does not match the detected host platform (linux/arm64/v8) and no specific platform was requested
8e8948a56f8b7f1f2dce54b7d35ec9005488f1004308cc2ea7bb3ff15485952b
Error response from daemon: Container 8e8948a56f8b7f1f2dce54b7d35ec9005488f1004308cc2ea7bb3ff15485952b is not running

Is there anything i am missing:

Please provide the following information when requesting support.

Hardware - GPU (A100/A30/T4/V100)
Hardware - CPU
Operating System
Riva Version
TLT Version (if relevant)
How to reproduce the issue ? (This is for errors. Please share the command and the detailed log here)

NAME=“Ubuntu”
VERSION=“18.04.6 LTS (Bionic Beaver)”
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME=“Ubuntu 18.04.6 LTS”
VERSION_ID=“18.04”
HOME_URL=“https://www.ubuntu.com/
SUPPORT_URL=“https://help.ubuntu.com/
BUG_REPORT_URL=“https://bugs.launchpad.net/ubuntu/
PRIVACY_POLICY_URL=“Data privacy | Ubuntu
VERSION_CODENAME=bionic
UBUNTU_CODENAME=bionic

Hi @alejandro.serna

Thanks for your interest in Riva,

Currently we do not support Jetson Nano

Apologies, Currently at the moment, we support the following below embedded devices only for Riva

Reference: Support Matrix — NVIDIA Riva Skills