Riva not starting up

Hi to everyone,
I am trying to use riva on my jetson orin nano ( the 4gb module ), I have followed the quick start guide. However once i try to start via the “riva_start.sh” script, the associated riva_speech container stops as i cannot connect to a server on
So the scripts just waits until it stops.

I also attached riva_speech container logs and config.sh.

Thank you in advance for your help!
riva_speech.txt (96 Bytes)
config.sh (13.3 KB)

HI @mattsays

Thanks for your interest in Riva

Apologies you are facing issue

Request to kindly share details on

  1. Jetpack version used and verify Jetpack is installed correct, The Version needed for Riva 2.11.0 is
  • JetPack 5.1.1
  • JetPack 5.1
  1. Verify the runtime is set to Nvidia
    You have set the default runtime to nvidia on the Jetson platform by adding the following line in the /etc/docker/daemon.json file. Restart the Docker service using sudo systemctl restart docker after editing the file.
    "default-runtime": "nvidia"

Please let me know if the above are set correct and still not working


Yes I am sure that I have the latest versions of Riva and JetPack and I also doublechecked the daemon.json option. However it still doesn’t work.