NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

wradmin@emboleye:~$ sudo dkms install nvidia/460.32.03

Kernel preparation unnecessary for this kernel.  Skipping...
applying patch disable_fstack-clash-protection_fcf-protection.patch...patching file Kbuild
Hunk #1 succeeded at 85 (offset 14 lines).


Building module:
cleaning build area...
unset ARCH; [ ! -h /usr/bin/cc ] && export CC=/usr/bin/gcc; env NV_VERBOSE=1 'make' -j8 NV_EXCLUDE_BUILD_MODULES='' KERNEL_UNAME=5.4.0-050400-generic IGNORE_XEN_PRESENCE=1 IGNORE_CC_MISMATCH=1 SYSSRC=/lib/modules/5.4.0-050400-generic/build LD=/usr/bin/ld.bfd modules..........
Signing module:
 - /var/lib/dkms/nvidia/460.32.03/5.4.0-050400-generic/x86_64/module/nvidia-uvm.ko
 - /var/lib/dkms/nvidia/460.32.03/5.4.0-050400-generic/x86_64/module/nvidia-modeset.ko
 - /var/lib/dkms/nvidia/460.32.03/5.4.0-050400-generic/x86_64/module/nvidia.ko
 - /var/lib/dkms/nvidia/460.32.03/5.4.0-050400-generic/x86_64/module/nvidia-drm.ko
Secure Boot not enabled on this system.
cleaning build area...

DKMS: build completed.

nvidia.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/5.4.0-050400-generic/updates/dkms/

nvidia-modeset.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/5.4.0-050400-generic/updates/dkms/

nvidia-drm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/5.4.0-050400-generic/updates/dkms/

nvidia-uvm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/5.4.0-050400-generic/updates/dkms/

depmod...

DKMS: install completed.
wradmin@emboleye:~$ sudo dkms install nvidia/460.32.03 --all
Module nvidia/460.32.03 already installed on kernel 5.4.0-050400-generic/x86_64
wradmin@emboleye:~$ dkms status
nvidia, 460.32.03, 5.4.0-050400-generic, x86_64: installed
veeamsnap, 5.0.0.4318, 4.15.0-136-generic, x86_64: installed
veeamsnap, 5.0.0.4318, 5.3.0-66-generic, x86_64: installed

rebooted… and it bloody works. THANK YOU!! 10/10, 5-stars, smashed like button. I really appreciate your assistance here, and swift attention.

Cheers!

Hi generix,
I also experienced the same problem after update today. Could you please have a look on my log file.
Thanks in advance!
Nenad

nvidia-bug-report.log.gz (108.7 KB)

Please check if you can manually load the modules:
sudo modprobe nvidia

Hi, unfortunately I also get almost the same problem. Nvidia is not working! I installed Kubuntu 20.04.2 with automated updating, my GPU is Geforce GTX 1060 6GB. Nvidia-smi is not working. After booting nothing happend, display does not show anything. I finally got managed to boot in recovery mode of GRUB and executed “nvidia-bug-report.sh”.

Thanks in advance for any suggestion!

nvidia-bug-report.log.gz (58.9 KB)

1 Like

Thank you for your fast response!
sudo modprobe nvidia
returns:
modprobe: ERROR: could not insert 'nvidia': Key was rejected by service.

I tried also with the nvidia 450 driver. It doesn’t work as well; same problem.
I have run the sudo ubuntu-drivers autoinstall without success.

@polomacnenad Please try this:
https://forums.developer.nvidia.com/t/nvidia-smi-has-failed-because-it-couldn-t-communicate-with-the-nvidia-driver-after-updating-ubuntu-20-04/170985/7?u=generix

@a.javan.gh Please get a log from the previous boot (to black screen)
sudo journalctl -b-1 >journal.txt
and attach that.

@generix thanks for your reply. Just to be sure that everything is well in my PC i just installed latest fedora (v33) with nvidia driver (460.56), everything worked fine. I just reinstalled Ubunut 20.04.2 again, but still the same result. No login splash and no desktop. So i logged in termin (fn+f2) and started journalctl and nvidia-bug-report. Please find the results attached.

Btw journalctl -b-1 gives:
data from the specified boot (-1) is not available no such boot id in journal

After removing nvidia-driver with:
sudo apt remove --purge '^nvidia-.*'
I could login, but w/o nvidia :(.

Is something wrong with the latest ubuntu version?

Thoughts?

Thanks in advance

nvidia-bug-report.log.gz (46.8 KB)
journal.log (150.3 KB)

Many users are running into this since a few days, this must be some weird Ubuntu bug introduced with an update. It’s always the same issue, as soon as the nvidia driver is installed, Gnome is not even trying to start. No error is ever logged. Please check if X starts up when changing to lightdm.
Overall, this has to be reported to Ubuntu.

@generix thanks for your answer. After all now i just feel reassured, since i am not the only one with this weired issue. Btw i think it is not realy a Gnome problem, since i am actually using kubunut (kde-version of ubuntu).

Ok, good to know, so seems to be a general issue. Maybe try setting ‘nogpumanager’ kernel parameter just to test if that’s blocking start-up of the display-manager.

@generix
Thanks! That solved the Problem. Here the code that helped:

sudo dkms remove nvidia/460.39 --all
sudo dkms install --force nvidia/460.39 -k $(uname -r)
sudo update-initramfs -u
sync
reboot

all the best!

1 Like

@generix I tried “nogpumanager” same results. i.e. no splash, no desktop. I also tried out the @polomacnenad approach, again the same, no desktop. Finally, I just switched to my fedora machine for now. See if ubuntu manages to do a new update in the next few days!
Plz share here if you know more on this topic thanks a lot!

Hi @generix, I have the same issue. I have a Lenovo Ideapad which powered with an Nvidia GeForce and an Intel graphic card. The problem is when I install the Nvidia driver, the driver can not be recognized, and the out put of nvidia-smi shows, it can not communicate with driver. Everything seems to be correct and I can not see any error. I attached the nvidia-bag-report and the output of several commands in the following.
I will appreciate any help and command to solve this issue. Thank younvidia-bug-report.log.gz (107.3 KB)

gfuse@gfuse:~$ glxinfo | grep render
direct rendering: Yes
GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
GLX_MESA_query_renderer, GLX_MESA_swap_control, GLX_OML_swap_method,
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: Mesa Intel® UHD Graphics 620 (KBL GT2)
GL_ARB_compute_variable_group_size, GL_ARB_conditional_render_inverted,
GL_IBM_multimode_draw_arrays, GL_INTEL_blackhole_render,
GL_NV_conditional_render, GL_NV_copy_image, GL_NV_depth_clamp,
GL_ARB_compute_variable_group_size, GL_ARB_conditional_render_inverted,
GL_INTEL_blackhole_render, GL_INTEL_performance_query,
GL_NV_compute_shader_derivatives, GL_NV_conditional_render,
GL_EXT_read_format_bgra, GL_EXT_render_snorm, GL_EXT_robustness,
GL_EXT_texture_view, GL_EXT_unpack_subimage, GL_INTEL_blackhole_render,
GL_NV_conditional_render, GL_NV_draw_buffers, GL_NV_fbo_color_attachments,
GL_OES_element_index_uint, GL_OES_fbo_render_mipmap,

gfuse@gfuse:~$ lspci -vnn | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 620 [8086:5917] (rev 07) (prog-if 00 [VGA controller])

gfuse@gfuse:~$ nvidia-smi
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

gfuse@gfuse:~$ dkms status
nvidia, 460.56, 5.8.0-45-generic, x86_64: installed

gfuse@gfuse:~$ sudo dkms install nvidia/460.56 --all
[sudo] password for gfuse:
Module nvidia/460.56 already installed on kernel 5.8.0-45-generic/x86_64

gfuse@gfuse:~$ cc --version
cc (Ubuntu 9.3.0-17ubuntu1~20.04) 9.3.0
Copyright © 2019 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

gfuse@gfuse:~$ inxi -G
Graphics: Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
Device-2: NVIDIA GP108M [GeForce MX150] driver: nouveau v: kernel
Display: x11 server: X.Org 1.20.9 driver: modesetting unloaded: fbdev,vesa
resolution: 1920x1080~60Hz, 1920x1080~60Hz
OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.2.6

gfuse@gfuse:~$ lshw -numeric -C display
WARNING: you should run this program as super-user.
*-display
description: VGA compatible controller
product: UHD Graphics 620 [8086:5917]
vendor: Intel Corporation [8086]
physical id: 2
bus info: pci@0000:00:02.0
version: 07
width: 64 bits
clock: 33MHz
capabilities: vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:128 memory:92000000-92ffffff memory:a0000000-afffffff ioport:5000(size=64) memory:c0000-dffff
*-display
description: 3D controller
product: GP108M [GeForce MX150] [10DE:1D10]
vendor: NVIDIA Corporation [10DE]
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list
configuration: driver=nouveau latency=0
resources: irq:129 memory:93000000-93ffffff memory:80000000-8fffffff memory:90000000-91ffffff ioport:4000(size=128)
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

gfuse@gfuse:~$ sudo apt-get install nvidia-driver-460
Reading package lists… Done
Building dependency tree
Reading state information… Done
nvidia-driver-460 is already the newest version (460.56-0ubuntu0.20.04.1).
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

gfuse@gfuse:~$ uname -r
5.8.0-45-generic

gfuse@gfuse:~ sudo apt-get install linux-headers-(uname -r)
Reading package lists… Done
Building dependency tree
Reading state information… Done
linux-headers-5.8.0-45-generic is already the newest version (5.8.0-45.51~20.04.1).
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

gfuse@gfuse:~$ sudo apt install nvidia-prime
Reading package lists… Done
Building dependency tree
Reading state information… Done
nvidia-prime is already the newest version (0.8.16~0.20.04.1).
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

gfuse@gfuse:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Neon
Description: KDE neon User Edition 5.21
Release: 20.04
Codename: focal

Hello! I have the same problem , in fact when I first installed cuda it worked perfectly but later when I installed an app that works with cuda i get this problem , i tried a lot to figured it out but couldn’t so i reinstalled the OS(Kubuntu 20.04) and reinstalled cuda but I still have the same prob .Attached you can find the bug file, I hope you can help me. nvidia-bug-report.log.gz (70.9 KB)

Please try disabling secure boot in bios.

I still have the same prob

I just find a solution.
If your nvidia-smi failed to communicate but you’ve installed the driver so many times, check prime-select .

  1. Run prime-select query to get all possible options. You should see at least nvidia | intel .
  2. Choose prime-select nvidia .
  3. If it says nvidia is already selected , select a different one, e.g. prime-select intel , then switch back to nvidia prime-select nvidia
  4. Reboot and check nvidia-smi .
    from here I get it Ubuntu – NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running – iTecTec

Still having the same issue even after disabling secure boot. A new bug report has been attached. Thank you for your help. nvidia-bug-report.log.gz (210.5 KB)

@abir.bensoltane your solution does not work for me.