NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

Hello, I have a problem with Nvidia driver.
When I run nvidia-smi I get:

NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the
latest NVIDIA driver is installed and running.

Running nvidia-settings:

ERROR: NVIDIA driver is not loaded
ERROR: Unable to load info from any available system

Currently installed driver, installed via sudo apt install nvidia-driver-430:

dkms status
nvidia, 430.50: added

Running lspci -v | grep 3D gives no output, but I don’t think that is a problem with my graphic card because I do not have any other GPU, nor integrated and my monitor is connected to my GPU and still displays my desktop.

Graphic card: nvidia gtx 1080ti

OS: Ubuntu 18.04
Kernel version: 5.4.15-050415-generic

Nvidia-bug-report:
https://drive.google.com/open?id=1shmYIahU4JcHPR44hZHf3S6ds77Icnb_

You’re running a 5.4 kernel on Ubuntu 18.04 and the repo driver is incompatible. Please use the Ubuntu graphics ppa to get the latest driver:
https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa

Hello,
I have a similar problem as well. Can you please help or should I go ahead and follow your previous instructions as well.
When I run

nvidia-smi

I get:

NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the
    latest NVIDIA driver is installed and running.

Running

nvidia-settings

gives

ERROR: NVIDIA driver is not loaded
    ERROR: Unable to load info from any available system

Currently installed driver, installed via

sudo apt install nvidia-driver-435
dkms status
nvidia, 435.21, 5.3.0-26-generic, x86_64: installed

Running

lspci -v | grep 3D

gives no output.
Graphic card: NVIDIA Corporation GP107GLM [Quadro P600 Mobile] (rev a1)

OS: Ubuntu 18.04
Kernel version: 5.3.0-26-generic

Thank you in advance.

I had a very similar problem and this worked for me:
https://devtalk.nvidia.com/default/topic/1047416/linux/nvidia-driver-is-not-loaded-ubuntu-18-10-/

Yes, I looked at that post and infact, followed #19 of that and updated the kernels. Still nothing. So, I am not sure what I am missing.

Thanks for the reply, though.

Hi, generix, I am encountering similar issue here. When you say “use the Ubuntu graphics ppa to get the latest driver”
Do you mean by sudo ubuntu-drivers autoinstall??

What I have right now:

root@NUS:~# nvidia-smi
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

root@NUS:~# nvidia-settings

ERROR: NVIDIA driver is not loaded


ERROR: Unable to load info from any available system

root@NUS:~# dkms status
nvidia, 435.21: added
root@NUS:~# lspci -v | grep 3D
root@NUS:~# uname -r
5.4.0-42-generic
root@NUS:~# sudo lshw -C display
  *-display UNCLAIMED       
       description: VGA compatible controller
       product: GM204GL [Quadro M4000]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:f7000000-f707ffff

These are what I have done to install the driver:

root@NUS:~# ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:02.0/0000:03:00.0 ==
modalias : pci:v000010DEd000013F1sv000010DEsd00001153bc03sc00i00
vendor   : NVIDIA Corporation
model    : GM204GL [Quadro M4000]
driver   : nvidia-driver-390 - distro non-free
driver   : nvidia-driver-415 - third-party free
driver   : nvidia-driver-435 - distro non-free recommended
driver   : xserver-xorg-video-nouveau - distro free builtin

root@NUS:~# sudo apt-get autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@NUS:~# sudo apt-get remove nvidia*
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'nvidia-kernel-common-418-server' for glob 'nvidia*'
Note, selecting 'nvidia-325-updates' for glob 'nvidia*'
Note, selecting 'nvidia-346-updates' for glob 'nvidia*'
Note, selecting 'nvidia-driver-binary' for glob 'nvidia*'
Note, selecting 'nvidia-331-dev' for glob 'nvidia*'
Note, selecting 'nvidia-304-updates-dev' for glob 'nvidia*'
Note, selecting 'nvidia-384-dev' for glob 'nvidia*'
Note, selecting 'nvidia-libopencl1-346-updates' for glob 'nvidia*'
Note, selecting 'nvidia-340-updates-uvm' for glob 'nvidia*'
Note, selecting 'nvidia-kernel-common' for glob 'nvidia*'
Note, selecting 'nvidia-331-updates-uvm' for glob 'nvidia*'
Note, selecting 'nvidia-cg-toolkit' for glob 'nvidia*'
Note, selecting 'nvidia-driver-libs-i386:i386' for glob 'nvidia*'
Note, selecting 'nvidia-dkms-440-server' for glob 'nvidia*'
Note, selecting 'nvidia-kernel-common-390' for glob 'nvidia*'
Note, selecting 'nvidia-kernel-common-410' for glob 'nvidia*'
Note, selecting 'nvidia-kernel-common-415' for glob 'nvidia*'
Note, selecting 'nvidia-kernel-common-418' for glob 'nvidia*'
Note, selecting 'nvidia-kernel-common-430' for glob 'nvidia*'
Note, selecting 'nvidia-kernel-common-435' for glob 'nvidia*'
Note, selecting 'nvidia-kernel-common-440' for glob 'nvidia*'
Note, selecting 'nvidia-kernel-common-450' for glob 'nvidia*'
Note, selecting 'nvidia-opencl-icd-340-updates' for glob 'nvidia*'
Note, selecting 'nvidia-384-updates' for glob 'nvidia*'
Note, selecting 'nvidia' for glob 'nvidia*'
Note, selecting 'nvidia-driver' for glob 'nvidia*'
Note, selecting 'nvidia-367-updates' for glob 'nvidia*'
Note, selecting 'nvidia-modprobe' for glob 'nvidia*'
Note, selecting 'nvidia-kernel-common-440-server' for glob 'nvidia*'
Note, selecting 'nvidia-texture-tools' for glob 'nvidia*'
Note, selecting 'nvidia-utils' for glob 'nvidia*'
Note, selecting 'nvidia-387-updates' for glob 'nvidia*'
Note, selecting 'nvidia-current-diagnostic' for glob 'nvidia*'
Note, selecting 'nvidia-legacy-340xx-vdpau-driver' for glob 'nvidia*'
Note, selecting 'nvidia-349-updates' for glob 'nvidia*'
Note, selecting 'nvidia-opencl-icd-304-updates' for glob 'nvidia*'
Note, selecting 'nvidia-310-updates' for glob 'nvidia*'
Note, selecting 'nvidia-331-updates' for glob 'nvidia*'
Note, selecting 'nvidia-352-dev' for glob 'nvidia*'
Note, selecting 'nvidia-legacy-304xx-vdpau-driver' for glob 'nvidia*'
Note, selecting 'nvidia-vdpau-driver' for glob 'nvidia*'
Note, selecting 'nvidia-346-dev' for glob 'nvidia*'
Note, selecting 'nvidia-libopencl1-331-updates' for glob 'nvidia*'
Note, selecting 'nvidia-utils-390' for glob 'nvidia*'
Note, selecting 'nvidia-smi' for glob 'nvidia*'
Note, selecting 'nvidia-opencl-icd-361-updates' for glob 'nvidia*'
Note, selecting 'nvidia-313-updates' for glob 'nvidia*'
Note, selecting 'nvidia-legacy-340xx-kernel-dkms' for glob 'nvidia*'
Note, selecting 'nvidia-334-updates' for glob 'nvidia*'
Note, selecting 'nvidia-utils-410' for glob 'nvidia*'
Note, selecting 'nvidia-utils-415' for glob 'nvidia*'
Note, selecting 'nvidia-utils-418' for glob 'nvidia*'
Note, selecting 'nvidia-utils-430' for glob 'nvidia*'
Note, selecting 'nvidia-utils-435' for glob 'nvidia*'
Note, selecting 'nvidia-utils-440' for glob 'nvidia*'
Note, selecting 'nvidia-utils-450' for glob 'nvidia*'
Note, selecting 'nvidia-331-uvm' for glob 'nvidia*'
Note, selecting 'nvidia-prime' for glob 'nvidia*'
Note, selecting 'nvidia-dkms-390' for glob 'nvidia*'
Note, selecting 'nvidia-kernel-dkms' for glob 'nvidia*'
Note, selecting 'nvidia-dkms-410' for glob 'nvidia*'
Note, selecting 'nvidia-dkms-415' for glob 'nvidia*'
Note, selecting 'nvidia-dkms-418' for glob 'nvidia*'
Note, selecting 'nvidia-dkms-430' for glob 'nvidia*'
Note, selecting 'nvidia-dkms-435' for glob 'nvidia*'
Note, selecting 'nvidia-dkms-440' for glob 'nvidia*'
Note, selecting 'nvidia-dkms-450' for glob 'nvidia*'
Note, selecting 'nvidia-current-updates' for glob 'nvidia*'
Note, selecting 'nvidia-340-dev' for glob 'nvidia*'
Note, selecting 'nvidia-nsight' for glob 'nvidia*'
Note, selecting 'nvidia-common' for glob 'nvidia*'
Note, selecting 'nvidia-opencl-icd-346-updates' for glob 'nvidia*'
Note, selecting 'nvidia-352-updates' for glob 'nvidia*'
Note, selecting 'nvidia-headless-no-dkms-390' for glob 'nvidia*'
Note, selecting 'nvidia-headless-no-dkms-410' for glob 'nvidia*'
Note, selecting 'nvidia-headless-no-dkms-415' for glob 'nvidia*'
Note, selecting 'nvidia-headless-no-dkms-418' for glob 'nvidia*'
Note, selecting 'nvidia-headless-no-dkms-430' for glob 'nvidia*'
Note, selecting 'nvidia-headless-no-dkms-435' for glob 'nvidia*'
Note, selecting 'nvidia-headless-no-dkms-440' for glob 'nvidia*'
Note, selecting 'nvidia-headless-no-dkms-450' for glob 'nvidia*'
Note, selecting 'nvidia-current-dev' for glob 'nvidia*'
Note, selecting 'nvidia-libopencl1-352-updates' for glob 'nvidia*'
Note, selecting 'nvidia-compute-utils-390' for glob 'nvidia*'
Note, selecting 'nvidia-compute-utils-410' for glob 'nvidia*'
Note, selecting 'nvidia-compute-utils-415' for glob 'nvidia*'
Note, selecting 'nvidia-compute-utils-418' for glob 'nvidia*'
Note, selecting 'nvidia-compute-utils-430' for glob 'nvidia*'
Note, selecting 'nvidia-compute-utils-435' for glob 'nvidia*'
Note, selecting 'nvidia-compute-utils-440' for glob 'nvidia*'
Note, selecting 'nvidia-compute-utils-450' for glob 'nvidia*'
Note, selecting 'nvidia-355-updates' for glob 'nvidia*'
Note, selecting 'nvidia-driver-libs-nonglvnd' for glob 'nvidia*'
Note, selecting 'nvidia-375-dev' for glob 'nvidia*'
Note, selecting 'nvidia-current' for glob 'nvidia*'
Note, selecting 'nvidia-profiler' for glob 'nvidia*'
Note, selecting 'nvidia-375-updates' for glob 'nvidia*'
Note, selecting 'nvidia-driver-390' for glob 'nvidia*'
Note, selecting 'nvidia-337-updates' for glob 'nvidia*'
Note, selecting 'nvidia-358-updates' for glob 'nvidia*'
Note, selecting 'nvidia-367-dev' for glob 'nvidia*'
Note, selecting 'nvidia-driver-410' for glob 'nvidia*'
Note, selecting 'nvidia-driver-415' for glob 'nvidia*'
Note, selecting 'nvidia-driver-418' for glob 'nvidia*'
Note, selecting 'nvidia-driver-430' for glob 'nvidia*'
Note, selecting 'nvidia-driver-435' for glob 'nvidia*'
Note, selecting 'nvidia-driver-440' for glob 'nvidia*'
Note, selecting 'nvidia-driver-450' for glob 'nvidia*'
Note, selecting 'nvidia-cuda-toolkit' for glob 'nvidia*'
Note, selecting 'nvidia-legacy-304xx-driver' for glob 'nvidia*'
Note, selecting 'nvidia-driver-libs' for glob 'nvidia*'
Note, selecting 'nvidia-kernel-source' for glob 'nvidia*'
Note, selecting 'nvidia-378-updates' for glob 'nvidia*'
Note, selecting 'nvidia-340-updates-dev' for glob 'nvidia*'
Note, selecting 'nvidia-319-updates' for glob 'nvidia*'
Note, selecting 'nvidia-304-dev' for glob 'nvidia*'
Note, selecting 'nvidia-331-updates-dev' for glob 'nvidia*'
Note, selecting 'nvidia-visual-profiler' for glob 'nvidia*'
Note, selecting 'nvidia-persistenced' for glob 'nvidia*'
Note, selecting 'nvidia-361-dev' for glob 'nvidia*'
Note, selecting 'nvidia-settings-binary' for glob 'nvidia*'
Note, selecting 'nvidia-361-updates-dev' for glob 'nvidia*'
Note, selecting 'nvidia-libopencl1-304' for glob 'nvidia*'
Note, selecting 'nvidia-libopencl1-331' for glob 'nvidia*'
Note, selecting 'nvidia-libopencl1-340' for glob 'nvidia*'
Note, selecting 'nvidia-libopencl1-346' for glob 'nvidia*'
Note, selecting 'nvidia-libopencl1-352' for glob 'nvidia*'
Note, selecting 'nvidia-libopencl1-361' for glob 'nvidia*'
Note, selecting 'nvidia-libopencl1-367' for glob 'nvidia*'
Note, selecting 'nvidia-libopencl1-375' for glob 'nvidia*'
Note, selecting 'nvidia-libopencl1-384' for glob 'nvidia*'
Note, selecting 'nvidia-352-updates-dev' for glob 'nvidia*'
Note, selecting 'nvidia-opencl-icd-331-updates' for glob 'nvidia*'
Note, selecting 'nvidia-opencl-icd-352-updates' for glob 'nvidia*'
Note, selecting 'nvidia-304-updates' for glob 'nvidia*'
Note, selecting 'nvidia-340-uvm' for glob 'nvidia*'
Note, selecting 'nvidia-headless-390' for glob 'nvidia*'
Note, selecting 'nvidia-legacy-340xx-driver' for glob 'nvidia*'
Note, selecting 'nvidia-libopencl1-304-updates' for glob 'nvidia*'
Note, selecting 'nvidia-headless-410' for glob 'nvidia*'
Note, selecting 'nvidia-headless-415' for glob 'nvidia*'
Note, selecting 'nvidia-headless-418' for glob 'nvidia*'
Note, selecting 'nvidia-headless-430' for glob 'nvidia*'
Note, selecting 'nvidia-headless-435' for glob 'nvidia*'
Note, selecting 'nvidia-headless-440' for glob 'nvidia*'
Note, selecting 'nvidia-headless-450' for glob 'nvidia*'
Note, selecting 'nvidia-cuda-dev' for glob 'nvidia*'
Note, selecting 'nvidia-cuda-doc' for glob 'nvidia*'
Note, selecting 'nvidia-340-updates' for glob 'nvidia*'
Note, selecting 'nvidia-361-updates' for glob 'nvidia*'
Note, selecting 'nvidia-libopencl1-dev' for glob 'nvidia*'
Note, selecting 'nvidia-opencl-dev' for glob 'nvidia*'
Note, selecting 'nvidia-legacy-304xx-kernel-dkms' for glob 'nvidia*'
Note, selecting 'nvidia-cg-dev' for glob 'nvidia*'
Note, selecting 'nvidia-dkms-418-server' for glob 'nvidia*'
Note, selecting 'nvidia-cg-doc' for glob 'nvidia*'
Note, selecting 'nvidia-libopencl1' for glob 'nvidia*'
Note, selecting 'nvidia-libopencl1-340-updates' for glob 'nvidia*'
Note, selecting 'nvidia-libopencl1-361-updates' for glob 'nvidia*'
Note, selecting 'nvidia-381-updates' for glob 'nvidia*'
Note, selecting 'nvidia-opencl-icd-304' for glob 'nvidia*'
Note, selecting 'nvidia-opencl-icd-331' for glob 'nvidia*'
Note, selecting 'nvidia-opencl-icd-340' for glob 'nvidia*'
Note, selecting 'nvidia-opencl-icd-346' for glob 'nvidia*'
Note, selecting 'nvidia-opencl-icd-352' for glob 'nvidia*'
Note, selecting 'nvidia-opencl-icd-361' for glob 'nvidia*'
Note, selecting 'nvidia-opencl-icd-367' for glob 'nvidia*'
Note, selecting 'nvidia-opencl-icd-375' for glob 'nvidia*'
Note, selecting 'nvidia-cuda-gdb' for glob 'nvidia*'
Note, selecting 'nvidia-experimental-304' for glob 'nvidia*'
Note, selecting 'nvidia-opencl-icd-384' for glob 'nvidia*'
Note, selecting 'nvidia-experimental-310' for glob 'nvidia*'
Note, selecting 'nvidia-experimental-313' for glob 'nvidia*'
Note, selecting 'nvidia-experimental-319' for glob 'nvidia*'
Note, selecting 'nvidia-experimental-325' for glob 'nvidia*'
Note, selecting 'nvidia-experimental-331' for glob 'nvidia*'
Note, selecting 'nvidia-experimental-334' for glob 'nvidia*'
Note, selecting 'nvidia-experimental-337' for glob 'nvidia*'
Note, selecting 'nvidia-experimental-340' for glob 'nvidia*'
Note, selecting 'nvidia-experimental-343' for glob 'nvidia*'
Note, selecting 'nvidia-experimental-346' for glob 'nvidia*'
Note, selecting 'nvidia-experimental-349' for glob 'nvidia*'
Note, selecting 'nvidia-experimental-352' for glob 'nvidia*'
Note, selecting 'nvidia-experimental-355' for glob 'nvidia*'
Note, selecting 'nvidia-experimental-358' for glob 'nvidia*'
Note, selecting 'nvidia-experimental-361' for glob 'nvidia*'
Note, selecting 'nvidia-experimental-364' for glob 'nvidia*'
Note, selecting 'nvidia-experimental-367' for glob 'nvidia*'
Note, selecting 'nvidia-experimental-375' for glob 'nvidia*'
Note, selecting 'nvidia-experimental-378' for glob 'nvidia*'
Note, selecting 'nvidia-experimental-381' for glob 'nvidia*'
Note, selecting 'nvidia-experimental-384' for glob 'nvidia*'
Note, selecting 'nvidia-experimental-387' for glob 'nvidia*'
Note, selecting 'nvidia-343-updates' for glob 'nvidia*'
Note, selecting 'nvidia-364-updates' for glob 'nvidia*'
Note, selecting 'nvidia-304' for glob 'nvidia*'
Note, selecting 'nvidia-310' for glob 'nvidia*'
Note, selecting 'nvidia-313' for glob 'nvidia*'
Note, selecting 'nvidia-319' for glob 'nvidia*'
Note, selecting 'nvidia-325' for glob 'nvidia*'
Note, selecting 'nvidia-331' for glob 'nvidia*'
Note, selecting 'nvidia-334' for glob 'nvidia*'
Note, selecting 'nvidia-337' for glob 'nvidia*'
Note, selecting 'nvidia-340' for glob 'nvidia*'
Note, selecting 'nvidia-343' for glob 'nvidia*'
Note, selecting 'nvidia-346' for glob 'nvidia*'
Note, selecting 'nvidia-349' for glob 'nvidia*'
Note, selecting 'nvidia-352' for glob 'nvidia*'
Note, selecting 'nvidia-355' for glob 'nvidia*'
Note, selecting 'nvidia-358' for glob 'nvidia*'
Note, selecting 'nvidia-kernel-source-390' for glob 'nvidia*'
Note, selecting 'nvidia-361' for glob 'nvidia*'
Note, selecting 'nvidia-364' for glob 'nvidia*'
Note, selecting 'nvidia-367' for glob 'nvidia*'
Note, selecting 'nvidia-375' for glob 'nvidia*'
Note, selecting 'nvidia-378' for glob 'nvidia*'
Note, selecting 'nvidia-381' for glob 'nvidia*'
Note, selecting 'nvidia-384' for glob 'nvidia*'
Note, selecting 'nvidia-387' for glob 'nvidia*'
Note, selecting 'nvidia-dkms-kernel' for glob 'nvidia*'
Note, selecting 'nvidia-390' for glob 'nvidia*'
Note, selecting 'nvidia-kernel-source-410' for glob 'nvidia*'
Note, selecting 'nvidia-kernel-source-415' for glob 'nvidia*'
Note, selecting 'nvidia-kernel-source-418' for glob 'nvidia*'
Note, selecting 'nvidia-346-updates-dev' for glob 'nvidia*'
Note, selecting 'nvidia-kernel-source-430' for glob 'nvidia*'
Note, selecting 'nvidia-kernel-source-435' for glob 'nvidia*'
Note, selecting 'nvidia-kernel-source-440' for glob 'nvidia*'
Note, selecting 'nvidia-kernel-source-450' for glob 'nvidia*'
Note, selecting 'nvidia-settings' for glob 'nvidia*'
Note, selecting 'nvidia-opencl-icd' for glob 'nvidia*'
Note, selecting 'nvidia-settings' instead of 'nvidia-settings-binary'
Package 'nvidia-libopencl1-dev' is not installed, so not removed
Package 'nvidia-libopencl1' is not installed, so not removed
Package 'nvidia-vdpau-driver' is not installed, so not removed
Package 'nvidia-legacy-340xx-vdpau-driver' is not installed, so not removed
Package 'nvidia-390' is not installed, so not removed
Package 'nvidia-driver' is not installed, so not removed
Package 'nvidia-legacy-340xx-driver' is not installed, so not removed
Package 'nvidia-legacy-304xx-driver' is not installed, so not removed
Package 'nvidia-kernel-dkms' is not installed, so not removed
Package 'nvidia-legacy-340xx-kernel-dkms' is not installed, so not removed
Package 'nvidia-legacy-304xx-kernel-dkms' is not installed, so not removed
Package 'nvidia' is not installed, so not removed
Package 'nvidia-current-updates' is not installed, so not removed
Package 'nvidia-experimental-304' is not installed, so not removed
Package 'nvidia-310' is not installed, so not removed
Package 'nvidia-310-updates' is not installed, so not removed
Package 'nvidia-experimental-310' is not installed, so not removed
Package 'nvidia-313' is not installed, so not removed
Package 'nvidia-313-updates' is not installed, so not removed
Package 'nvidia-experimental-313' is not installed, so not removed
Package 'nvidia-319' is not installed, so not removed
Package 'nvidia-319-updates' is not installed, so not removed
Package 'nvidia-experimental-319' is not installed, so not removed
Package 'nvidia-325' is not installed, so not removed
Package 'nvidia-325-updates' is not installed, so not removed
Package 'nvidia-experimental-325' is not installed, so not removed
Package 'nvidia-experimental-331' is not installed, so not removed
Package 'nvidia-334' is not installed, so not removed
Package 'nvidia-334-updates' is not installed, so not removed
Package 'nvidia-experimental-334' is not installed, so not removed
Package 'nvidia-337' is not installed, so not removed
Package 'nvidia-337-updates' is not installed, so not removed
Package 'nvidia-experimental-337' is not installed, so not removed
Package 'nvidia-experimental-340' is not installed, so not removed
Package 'nvidia-343' is not installed, so not removed
Package 'nvidia-343-updates' is not installed, so not removed
Package 'nvidia-experimental-343' is not installed, so not removed
Package 'nvidia-experimental-346' is not installed, so not removed
Package 'nvidia-349' is not installed, so not removed
Package 'nvidia-349-updates' is not installed, so not removed
Package 'nvidia-experimental-349' is not installed, so not removed
Package 'nvidia-experimental-352' is not installed, so not removed
Package 'nvidia-355' is not installed, so not removed
Package 'nvidia-355-updates' is not installed, so not removed
Package 'nvidia-experimental-355' is not installed, so not removed
Package 'nvidia-358' is not installed, so not removed
Package 'nvidia-358-updates' is not installed, so not removed
Package 'nvidia-experimental-358' is not installed, so not removed
Package 'nvidia-experimental-361' is not installed, so not removed
Package 'nvidia-364' is not installed, so not removed
Package 'nvidia-364-updates' is not installed, so not removed
Package 'nvidia-experimental-364' is not installed, so not removed
Package 'nvidia-367-updates' is not installed, so not removed
Package 'nvidia-experimental-367' is not installed, so not removed
Package 'nvidia-375-updates' is not installed, so not removed
Package 'nvidia-experimental-375' is not installed, so not removed
Package 'nvidia-378' is not installed, so not removed
Package 'nvidia-378-updates' is not installed, so not removed
Package 'nvidia-experimental-378' is not installed, so not removed
Package 'nvidia-381' is not installed, so not removed
Package 'nvidia-381-updates' is not installed, so not removed
Package 'nvidia-experimental-381' is not installed, so not removed
Package 'nvidia-384-updates' is not installed, so not removed
Package 'nvidia-experimental-384' is not installed, so not removed
Package 'nvidia-387' is not installed, so not removed
Package 'nvidia-387-updates' is not installed, so not removed
Package 'nvidia-experimental-387' is not installed, so not removed
Note, selecting 'libnvtt-bin' instead of 'nvidia-texture-tools'
Package 'nvidia-driver-libs' is not installed, so not removed
Package 'nvidia-driver-libs-nonglvnd' is not installed, so not removed
Package 'nvidia-driver-libs-i386:i386' is not installed, so not removed
Package 'nvidia-kernel-common-418-server' is not installed, so not removed
Package 'nvidia-kernel-common-440-server' is not installed, so not removed
Package 'nvidia-legacy-304xx-vdpau-driver' is not installed, so not removed
Package 'nvidia-340-updates-uvm' is not installed, so not removed
Package 'nvidia-346' is not installed, so not removed
Package 'nvidia-346-dev' is not installed, so not removed
Package 'nvidia-346-updates' is not installed, so not removed
Package 'nvidia-346-updates-dev' is not installed, so not removed
Package 'nvidia-352' is not installed, so not removed
Package 'nvidia-352-dev' is not installed, so not removed
Package 'nvidia-352-updates' is not installed, so not removed
Package 'nvidia-352-updates-dev' is not installed, so not removed
Package 'nvidia-361' is not installed, so not removed
Package 'nvidia-361-dev' is not installed, so not removed
Package 'nvidia-361-updates' is not installed, so not removed
Package 'nvidia-361-updates-dev' is not installed, so not removed
Package 'nvidia-367' is not installed, so not removed
Package 'nvidia-367-dev' is not installed, so not removed
Package 'nvidia-375' is not installed, so not removed
Package 'nvidia-375-dev' is not installed, so not removed
Package 'nvidia-cg-dev' is not installed, so not removed
Package 'nvidia-cg-doc' is not installed, so not removed
Package 'nvidia-cg-toolkit' is not installed, so not removed
Package 'nvidia-cuda-dev' is not installed, so not removed
Package 'nvidia-cuda-doc' is not installed, so not removed
Package 'nvidia-cuda-gdb' is not installed, so not removed
Package 'nvidia-cuda-toolkit' is not installed, so not removed
Package 'nvidia-libopencl1-346' is not installed, so not removed
Package 'nvidia-libopencl1-346-updates' is not installed, so not removed
Package 'nvidia-libopencl1-352' is not installed, so not removed
Package 'nvidia-libopencl1-352-updates' is not installed, so not removed
Package 'nvidia-libopencl1-361' is not installed, so not removed
Package 'nvidia-libopencl1-361-updates' is not installed, so not removed
Package 'nvidia-libopencl1-367' is not installed, so not removed
Package 'nvidia-libopencl1-375' is not installed, so not removed
Package 'nvidia-nsight' is not installed, so not removed
Package 'nvidia-opencl-dev' is not installed, so not removed
Package 'nvidia-opencl-icd-346' is not installed, so not removed
Package 'nvidia-opencl-icd-346-updates' is not installed, so not removed
Package 'nvidia-opencl-icd-352' is not installed, so not removed
Package 'nvidia-opencl-icd-352-updates' is not installed, so not removed
Package 'nvidia-opencl-icd-361' is not installed, so not removed
Package 'nvidia-opencl-icd-361-updates' is not installed, so not removed
Package 'nvidia-opencl-icd-367' is not installed, so not removed
Package 'nvidia-opencl-icd-375' is not installed, so not removed
Package 'nvidia-profiler' is not installed, so not removed
Package 'nvidia-visual-profiler' is not installed, so not removed
Package 'nvidia-331' is not installed, so not removed
Package 'nvidia-331-dev' is not installed, so not removed
Package 'nvidia-331-updates' is not installed, so not removed
Package 'nvidia-331-updates-dev' is not installed, so not removed
Package 'nvidia-331-updates-uvm' is not installed, so not removed
Package 'nvidia-331-uvm' is not installed, so not removed
Package 'nvidia-340' is not installed, so not removed
Package 'nvidia-340-dev' is not installed, so not removed
Package 'nvidia-340-updates' is not installed, so not removed
Package 'nvidia-340-updates-dev' is not installed, so not removed
Package 'nvidia-340-uvm' is not installed, so not removed
Package 'nvidia-compute-utils-390' is not installed, so not removed
Package 'nvidia-compute-utils-430' is not installed, so not removed
Package 'nvidia-compute-utils-440' is not installed, so not removed
Package 'nvidia-dkms-390' is not installed, so not removed
Package 'nvidia-dkms-430' is not installed, so not removed
Package 'nvidia-dkms-440' is not installed, so not removed
Package 'nvidia-driver-390' is not installed, so not removed
Package 'nvidia-driver-430' is not installed, so not removed
Package 'nvidia-driver-440' is not installed, so not removed
Package 'nvidia-headless-390' is not installed, so not removed
Package 'nvidia-headless-430' is not installed, so not removed
Package 'nvidia-headless-435' is not installed, so not removed
Package 'nvidia-headless-440' is not installed, so not removed
Package 'nvidia-headless-no-dkms-390' is not installed, so not removed
Package 'nvidia-headless-no-dkms-430' is not installed, so not removed
Package 'nvidia-headless-no-dkms-435' is not installed, so not removed
Package 'nvidia-headless-no-dkms-440' is not installed, so not removed
Package 'nvidia-kernel-common-390' is not installed, so not removed
Package 'nvidia-kernel-common-430' is not installed, so not removed
Package 'nvidia-kernel-common-440' is not installed, so not removed
Package 'nvidia-kernel-source-390' is not installed, so not removed
Package 'nvidia-kernel-source-430' is not installed, so not removed
Package 'nvidia-kernel-source-440' is not installed, so not removed
Package 'nvidia-opencl-icd-340' is not installed, so not removed
Package 'nvidia-utils-390' is not installed, so not removed
Package 'nvidia-utils-430' is not installed, so not removed
Package 'nvidia-utils-440' is not installed, so not removed
Package 'nvidia-common' is not installed, so not removed
Package 'nvidia-libopencl1-331' is not installed, so not removed
Package 'nvidia-libopencl1-331-updates' is not installed, so not removed
Package 'nvidia-libopencl1-340' is not installed, so not removed
Package 'nvidia-libopencl1-340-updates' is not installed, so not removed
Package 'nvidia-opencl-icd-331' is not installed, so not removed
Package 'nvidia-opencl-icd-331-updates' is not installed, so not removed
Package 'nvidia-opencl-icd-340-updates' is not installed, so not removed
Package 'nvidia-compute-utils-410' is not installed, so not removed
Package 'nvidia-dkms-410' is not installed, so not removed
Package 'nvidia-driver-410' is not installed, so not removed
Package 'nvidia-headless-410' is not installed, so not removed
Package 'nvidia-headless-no-dkms-410' is not installed, so not removed
Package 'nvidia-kernel-common-410' is not installed, so not removed
Package 'nvidia-kernel-source-410' is not installed, so not removed
Package 'nvidia-utils-410' is not installed, so not removed
Package 'nvidia-384' is not installed, so not removed
Package 'nvidia-384-dev' is not installed, so not removed
Package 'nvidia-libopencl1-384' is not installed, so not removed
Package 'nvidia-opencl-icd-384' is not installed, so not removed
Package 'nvidia-modprobe' is not installed, so not removed
Package 'nvidia-304' is not installed, so not removed
Package 'nvidia-304-dev' is not installed, so not removed
Package 'nvidia-304-updates' is not installed, so not removed
Package 'nvidia-304-updates-dev' is not installed, so not removed
Package 'nvidia-compute-utils-415' is not installed, so not removed
Package 'nvidia-compute-utils-418' is not installed, so not removed
Package 'nvidia-compute-utils-450' is not installed, so not removed
Package 'nvidia-current' is not installed, so not removed
Package 'nvidia-current-dev' is not installed, so not removed
Package 'nvidia-dkms-415' is not installed, so not removed
Package 'nvidia-dkms-418' is not installed, so not removed
Package 'nvidia-dkms-450' is not installed, so not removed
Package 'nvidia-driver-415' is not installed, so not removed
Package 'nvidia-driver-418' is not installed, so not removed
Package 'nvidia-driver-450' is not installed, so not removed
Package 'nvidia-headless-415' is not installed, so not removed
Package 'nvidia-headless-418' is not installed, so not removed
Package 'nvidia-headless-450' is not installed, so not removed
Package 'nvidia-headless-no-dkms-415' is not installed, so not removed
Package 'nvidia-headless-no-dkms-418' is not installed, so not removed
Package 'nvidia-headless-no-dkms-450' is not installed, so not removed
Package 'nvidia-kernel-common-415' is not installed, so not removed
Package 'nvidia-kernel-common-418' is not installed, so not removed
Package 'nvidia-kernel-common-450' is not installed, so not removed
Package 'nvidia-kernel-source-415' is not installed, so not removed
Package 'nvidia-kernel-source-418' is not installed, so not removed
Package 'nvidia-kernel-source-450' is not installed, so not removed
Package 'nvidia-libopencl1-304' is not installed, so not removed
Package 'nvidia-libopencl1-304-updates' is not installed, so not removed
Package 'nvidia-opencl-icd-304' is not installed, so not removed
Package 'nvidia-opencl-icd-304-updates' is not installed, so not removed
Package 'nvidia-utils-415' is not installed, so not removed
Package 'nvidia-utils-418' is not installed, so not removed
Package 'nvidia-utils-450' is not installed, so not removed
The following packages were automatically installed and are no longer required:
  dkms libatomic1:i386 libbsd0:i386 libdrm-amdgpu1:i386 libdrm-intel1:i386
  libdrm-nouveau2:i386 libdrm-radeon1:i386 libdrm2:i386 libedit2:i386
  libelf1:i386 libexpat1:i386 libffi6:i386 libgl1:i386 libgl1-mesa-dri:i386
  libglapi-mesa:i386 libglvnd0:i386 libglx-mesa0:i386 libglx0:i386
  libllvm10:i386 libnvidia-cfg1-435 libnvidia-common-435
  libnvidia-compute-435:i386 libnvidia-decode-435 libnvidia-decode-435:i386
  libnvidia-encode-435 libnvidia-encode-435:i386 libnvidia-fbc1-435
  libnvidia-fbc1-435:i386 libnvidia-gl-435 libnvidia-gl-435:i386
  libnvidia-ifr1-435 libnvidia-ifr1-435:i386 libpciaccess0:i386
  libsensors4:i386 libstdc++6:i386 libx11-6:i386 libx11-xcb1:i386 libxau6:i386
  libxcb-dri2-0:i386 libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386
  libxcb-sync1:i386 libxcb1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386
  libxfixes3:i386 libxnvctrl0 libxshmfence1:i386 libxxf86vm1:i386
  screen-resolution-extra xserver-xorg-video-nvidia-435
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  nvidia-compute-utils-435 nvidia-dkms-435 nvidia-driver-435
  nvidia-kernel-common-435 nvidia-kernel-source-435 nvidia-prime
  nvidia-settings nvidia-utils-435
0 upgraded, 0 newly installed, 8 to remove and 0 not upgraded.
After this operation, 39.5 MB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database ... 338229 files and directories currently installed.)
Removing nvidia-driver-435 (435.21-0ubuntu0.18.04.2) ...
Removing nvidia-compute-utils-435 (435.21-0ubuntu0.18.04.2) ...
Removing nvidia-dkms-435 (435.21-0ubuntu0.18.04.2) ...
Removing all DKMS Modules
Done.
INFO:Disable nvidia
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
update-initramfs: deferring update (trigger activated)
Removing nvidia-kernel-common-435 (435.21-0ubuntu0.18.04.2) ...
update-initramfs: deferring update (trigger activated)
Removing nvidia-kernel-source-435 (435.21-0ubuntu0.18.04.2) ...
Removing nvidia-prime (0.8.8.2) ...
Removing nvidia-settings (450.51.05-0ubuntu1) ...
Removing nvidia-utils-435 (435.21-0ubuntu0.18.04.2) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.2) ...
Processing triggers for initramfs-tools (0.130ubuntu3.9) ...
update-initramfs: Generating /boot/initrd.img-5.4.0-42-generic
I: The initramfs will attempt to resume from /dev/sda6
I: (UUID=ac47a98c-8560-4626-8c8e-ebae77b4278d)
I: Set the RESUME variable to override this.
Processing triggers for libc-bin (2.27-3ubuntu1.2) ...
/sbin/ldconfig.real: /usr/local/cuda-10.1/targets/x86_64-linux/lib/libcudnn.so.7 is not a symbolic link

Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Processing triggers for mime-support (3.60ubuntu1) ...
root@NUS:~# sudo apt-get purge cuda*
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'cuda-cusparse-cross-qnx-10-0' for glob 'cuda*'
Note, selecting 'cuda-nsight-compute-11-0' for glob 'cuda*'
Note, selecting 'cuda-nvprof-11-0' for glob 'cuda*'
Note, selecting 'cuda-npp-cross-qnx-10-0' for glob 'cuda*'
Note, selecting 'cuda-nvprune-10-0' for glob 'cuda*'
Note, selecting 'cuda-nvprune-10-1' for glob 'cuda*'
Note, selecting 'cuda-nvprune-10-2' for glob 'cuda*'
Note, selecting 'cuda-nvprune-11-0' for glob 'cuda*'
Note, selecting 'cuda-nvgraph-10-0' for glob 'cuda*'
Note, selecting 'cuda-nvgraph-10-1' for glob 'cuda*'
Note, selecting 'cuda-nvgraph-10-2' for glob 'cuda*'
Note, selecting 'cuda-cublas-dev-10-0' for glob 'cuda*'
Note, selecting 'cuda-drivers-418' for glob 'cuda*'
Note, selecting 'cuda-drivers-440' for glob 'cuda*'
Note, selecting 'cuda-drivers-450' for glob 'cuda*'
Note, selecting 'cuda-gdb-10-0' for glob 'cuda*'
Note, selecting 'cuda-gdb-10-1' for glob 'cuda*'
Note, selecting 'cuda-gdb-10-2' for glob 'cuda*'
Note, selecting 'cuda-nsight-compute--10-0' for glob 'cuda*'
Note, selecting 'cuda-gdb-11-0' for glob 'cuda*'
Note, selecting 'cuda-visual-tools-10-0' for glob 'cuda*'
Note, selecting 'cuda-visual-tools-10-1' for glob 'cuda*'
Note, selecting 'cuda-visual-tools-10-2' for glob 'cuda*'
Note, selecting 'cuda-curand-dev-10-0' for glob 'cuda*'
Note, selecting 'cuda-curand-dev-10-1' for glob 'cuda*'
Note, selecting 'cuda-curand-dev-10-2' for glob 'cuda*'
Note, selecting 'cuda-cupti-10-0' for glob 'cuda*'
Note, selecting 'cuda-cupti-10-1' for glob 'cuda*'
Note, selecting 'cuda-cupti-10-2' for glob 'cuda*'
Note, selecting 'cuda-curand-cross-qnx-10-0' for glob 'cuda*'
Note, selecting 'cuda-visual-tools-11-0' for glob 'cuda*'
Note, selecting 'cuda-libraries-dev-10-0' for glob 'cuda*'
Note, selecting 'cuda-libraries-dev-10-1' for glob 'cuda*'
Note, selecting 'cuda-libraries-dev-10-2' for glob 'cuda*'
Note, selecting 'cuda-cublas-cross-qnx-10-0' for glob 'cuda*'
Note, selecting 'cuda-cupti-11-0' for glob 'cuda*'
Note, selecting 'cuda-drivers-branch' for glob 'cuda*'
Note, selecting 'cuda-repo-ubuntu1204' for glob 'cuda*'
Note, selecting 'cuda-nvjpeg-10-0' for glob 'cuda*'
Note, selecting 'cuda-nvjpeg-10-1' for glob 'cuda*'
Note, selecting 'cuda-nvjpeg-10-2' for glob 'cuda*'
Note, selecting 'cuda-nvrtc-dev-10-0' for glob 'cuda*'
Note, selecting 'cuda-nvrtc-dev-10-1' for glob 'cuda*'
Note, selecting 'cuda-nvrtc-dev-10-2' for glob 'cuda*'
Note, selecting 'cuda-libraries-dev-11-0' for glob 'cuda*'
Note, selecting 'cuda-nvrtc-dev-11-0' for glob 'cuda*'
Note, selecting 'cuda-minimal-build-10-0' for glob 'cuda*'
Note, selecting 'cuda-minimal-build-10-1' for glob 'cuda*'
Note, selecting 'cuda-minimal-build-10-2' for glob 'cuda*'
Note, selecting 'cuda-drivers' for glob 'cuda*'
Note, selecting 'cuda-repo-ubuntu1404' for glob 'cuda*'
Note, selecting 'cuda-repo-ubuntu1410' for glob 'cuda*'
Note, selecting 'cuda-minimal-build-11-0' for glob 'cuda*'
Note, selecting 'cuda-cufft-cross-qnx-10-0' for glob 'cuda*'
Note, selecting 'cuda-repo-ubuntu1504' for glob 'cuda*'
Note, selecting 'cuda-license-7-5' for glob 'cuda*'
Note, selecting 'cuda-cupti-dev-10-2' for glob 'cuda*'
Note, selecting 'cuda-libraries-10-0' for glob 'cuda*'
Note, selecting 'cuda-libraries-10-1' for glob 'cuda*'
Note, selecting 'cuda-libraries-10-2' for glob 'cuda*'
Note, selecting 'cuda-runtime-10-0' for glob 'cuda*'
Note, selecting 'cuda-runtime-10-1' for glob 'cuda*'
Note, selecting 'cuda-runtime-10-2' for glob 'cuda*'
Note, selecting 'cuda-cusolver-10-0' for glob 'cuda*'
Note, selecting 'cuda-cusolver-10-1' for glob 'cuda*'
Note, selecting 'cuda-cusolver-10-2' for glob 'cuda*'
Note, selecting 'cuda-cupti-dev-11-0' for glob 'cuda*'
Note, selecting 'cuda-libraries-11-0' for glob 'cuda*'
Note, selecting 'cuda-repo-ubuntu1804' for glob 'cuda*'
Note, selecting 'cuda-runtime-11-0' for glob 'cuda*'
Note, selecting 'cuda-drivers-diagnostic' for glob 'cuda*'
Note, selecting 'cuda-cusparse-dev-10-0' for glob 'cuda*'
Note, selecting 'cuda-cusparse-dev-10-1' for glob 'cuda*'
Note, selecting 'cuda-cusparse-dev-10-2' for glob 'cuda*'
Note, selecting 'cuda-sanitizer-11-0' for glob 'cuda*'
Note, selecting 'cuda-nvrtc-10-0' for glob 'cuda*'
Note, selecting 'cuda-nvrtc-10-1' for glob 'cuda*'
Note, selecting 'cuda-nvrtc-10-2' for glob 'cuda*'
Note, selecting 'cuda-nvjpeg-dev-10-0' for glob 'cuda*'
Note, selecting 'cuda-nvjpeg-dev-10-1' for glob 'cuda*'
Note, selecting 'cuda-nvjpeg-dev-10-2' for glob 'cuda*'
Note, selecting 'cuda-cufft-10-0' for glob 'cuda*'
Note, selecting 'cuda-cufft-10-1' for glob 'cuda*'
Note, selecting 'cuda-cufft-10-2' for glob 'cuda*'
Note, selecting 'cuda-nsight-systems-10-1' for glob 'cuda*'
Note, selecting 'cuda-nsight-systems-10-2' for glob 'cuda*'
Note, selecting 'cuda-nvrtc-11-0' for glob 'cuda*'
Note, selecting 'cuda-cusparse-10-0' for glob 'cuda*'
Note, selecting 'cuda-cusparse-10-1' for glob 'cuda*'
Note, selecting 'cuda-cusparse-10-2' for glob 'cuda*'
Note, selecting 'cuda-nsight-systems-11-0' for glob 'cuda*'
Note, selecting 'cuda-npp-10-0' for glob 'cuda*'
Note, selecting 'cuda-npp-10-1' for glob 'cuda*'
Note, selecting 'cuda-npp-10-2' for glob 'cuda*'
Note, selecting 'cuda-tools-10-0' for glob 'cuda*'
Note, selecting 'cuda-tools-10-1' for glob 'cuda*'
Note, selecting 'cuda-tools-10-2' for glob 'cuda*'
Note, selecting 'cuda-nvtx-10-0' for glob 'cuda*'
Note, selecting 'cuda-nvtx-10-1' for glob 'cuda*'
Note, selecting 'cuda-nvtx-10-2' for glob 'cuda*'
Note, selecting 'cuda-tools-11-0' for glob 'cuda*'
Note, selecting 'cuda-nvtx-11-0' for glob 'cuda*'
Note, selecting 'cuda-cudart-10-0' for glob 'cuda*'
Note, selecting 'cuda-cudart-10-1' for glob 'cuda*'
Note, selecting 'cuda-cudart-10-2' for glob 'cuda*'
Note, selecting 'cuda-license-10-0' for glob 'cuda*'
Note, selecting 'cuda-license-10-1' for glob 'cuda*'
Note, selecting 'cuda-license-10-2' for glob 'cuda*'
Note, selecting 'cuda-nvdisasm-10-0' for glob 'cuda*'
Note, selecting 'cuda-nvdisasm-10-1' for glob 'cuda*'
Note, selecting 'cuda-nvdisasm-10-2' for glob 'cuda*'
Note, selecting 'cuda-samples-10-0' for glob 'cuda*'
Note, selecting 'cuda-samples-10-1' for glob 'cuda*'
Note, selecting 'cuda-samples-10-2' for glob 'cuda*'
Note, selecting 'cuda-documentation-10-0' for glob 'cuda*'
Note, selecting 'cuda-documentation-10-1' for glob 'cuda*'
Note, selecting 'cuda-documentation-10-2' for glob 'cuda*'
Note, selecting 'cuda-cusolver-cross-qnx-10-0' for glob 'cuda*'
Note, selecting 'cuda-cudart-11-0' for glob 'cuda*'
Note, selecting 'cuda-nvdisasm-11-0' for glob 'cuda*'
Note, selecting 'cuda-samples-11-0' for glob 'cuda*'
Note, selecting 'cuda-cross-qnx' for glob 'cuda*'
Note, selecting 'cuda-documentation-11-0' for glob 'cuda*'
Note, selecting 'cuda-compat-10-0' for glob 'cuda*'
Note, selecting 'cuda-compat-10-1' for glob 'cuda*'
Note, selecting 'cuda-compat-10-2' for glob 'cuda*'
Note, selecting 'cuda-compat-11-0' for glob 'cuda*'
Note, selecting 'cuda-nvcc-10-0' for glob 'cuda*'
Note, selecting 'cuda-nvcc-10-1' for glob 'cuda*'
Note, selecting 'cuda-nvcc-10-2' for glob 'cuda*'
Note, selecting 'cuda-repo-ubuntu1404-7-5-local' for glob 'cuda*'
Note, selecting 'cuda-nvvp-10-0' for glob 'cuda*'
Note, selecting 'cuda-nvvp-10-1' for glob 'cuda*'
Note, selecting 'cuda-nvvp-10-2' for glob 'cuda*'
Note, selecting 'cuda-cross-qnx-10-0' for glob 'cuda*'
Note, selecting 'cuda-repo-ubuntu1804-10-1-local-10.1.243-418.87.00' for glob 'cuda*'
Note, selecting 'cuda-nvcc-11-0' for glob 'cuda*'
Note, selecting 'cuda-nvvp-11-0' for glob 'cuda*'
Note, selecting 'cuda-toolkit-10-0' for glob 'cuda*'
Note, selecting 'cuda-toolkit-10-1' for glob 'cuda*'
Note, selecting 'cuda-toolkit-10-2' for glob 'cuda*'
Note, selecting 'cuda-nvgraph-dev-10-0' for glob 'cuda*'
Note, selecting 'cuda-nvgraph-dev-10-1' for glob 'cuda*'
Note, selecting 'cuda-nvgraph-dev-10-2' for glob 'cuda*'
Note, selecting 'cuda-toolkit-11-0' for glob 'cuda*'
Note, selecting 'cuda-cudart-dev-10-0' for glob 'cuda*'
Note, selecting 'cuda-cudart-dev-10-1' for glob 'cuda*'
Note, selecting 'cuda-cudart-dev-10-2' for glob 'cuda*'
Note, selecting 'cuda-nvml-dev-10-0' for glob 'cuda*'
Note, selecting 'cuda-nvml-dev-10-1' for glob 'cuda*'
Note, selecting 'cuda-nvml-dev-10-2' for glob 'cuda*'
Note, selecting 'cuda-cudart-dev-11-0' for glob 'cuda*'
Note, selecting 'cuda-nvml-dev-11-0' for glob 'cuda*'
Note, selecting 'cuda-gpu-library-advisor-10-0' for glob 'cuda*'
Note, selecting 'cuda-gpu-library-advisor-10-1' for glob 'cuda*'
Note, selecting 'cuda-cublas-10-0' for glob 'cuda*'
Note, selecting 'cuda-core-10-0' for glob 'cuda*'
Note, selecting 'cuda-core-10-1' for glob 'cuda*'
Note, selecting 'cuda-core-10-2' for glob 'cuda*'
Note, selecting 'cuda-cusolver-dev-10-0' for glob 'cuda*'
Note, selecting 'cuda-cusolver-dev-10-1' for glob 'cuda*'
Note, selecting 'cuda-cusolver-dev-10-2' for glob 'cuda*'
Note, selecting 'cuda-driver-cross-qnx-10-0' for glob 'cuda*'
Note, selecting 'cuda-sanitizer-api-10-1' for glob 'cuda*'
Note, selecting 'cuda-sanitizer-api-10-2' for glob 'cuda*'
Note, selecting 'cuda-compiler-10-0' for glob 'cuda*'
Note, selecting 'cuda-compiler-10-1' for glob 'cuda*'
Note, selecting 'cuda-compiler-10-2' for glob 'cuda*'
Note, selecting 'cuda-demo-suite-10-0' for glob 'cuda*'
Note, selecting 'cuda-demo-suite-10-1' for glob 'cuda*'
Note, selecting 'cuda-demo-suite-10-2' for glob 'cuda*'
Note, selecting 'cuda-npp-dev-10-0' for glob 'cuda*'
Note, selecting 'cuda-npp-dev-10-1' for glob 'cuda*'
Note, selecting 'cuda-npp-dev-10-2' for glob 'cuda*'
Note, selecting 'cuda-compiler-11-0' for glob 'cuda*'
Note, selecting 'cuda-demo-suite-11-0' for glob 'cuda*'
Note, selecting 'cuda-nsight-10-0' for glob 'cuda*'
Note, selecting 'cuda-nsight-10-1' for glob 'cuda*'
Note, selecting 'cuda-nsight-10-2' for glob 'cuda*'
Note, selecting 'cuda-curand-10-0' for glob 'cuda*'
Note, selecting 'cuda-curand-10-1' for glob 'cuda*'
Note, selecting 'cuda-curand-10-2' for glob 'cuda*'
Note, selecting 'cuda-command-line-tools-10-0' for glob 'cuda*'
Note, selecting 'cuda-command-line-tools-10-1' for glob 'cuda*'
Note, selecting 'cuda-command-line-tools-10-2' for glob 'cuda*'
Note, selecting 'cuda-cufft-dev-10-0' for glob 'cuda*'
Note, selecting 'cuda-cufft-dev-10-1' for glob 'cuda*'
Note, selecting 'cuda-cufft-dev-10-2' for glob 'cuda*'
Note, selecting 'cuda-nsight-11-0' for glob 'cuda*'
Note, selecting 'cuda-driver-dev-10-0' for glob 'cuda*'
Note, selecting 'cuda-driver-dev-10-1' for glob 'cuda*'
Note, selecting 'cuda-driver-dev-10-2' for glob 'cuda*'
Note, selecting 'cuda-repo-ubuntu1504-7-5-local' for glob 'cuda*'
Note, selecting 'cuda-10-0' for glob 'cuda*'
Note, selecting 'cuda-10-1' for glob 'cuda*'
Note, selecting 'cuda-10-2' for glob 'cuda*'
Note, selecting 'cuda-command-line-tools-11-0' for glob 'cuda*'
Note, selecting 'cuda-driver-dev-11-0' for glob 'cuda*'
Note, selecting 'cuda-misc-headers-cross-qnx-10-0' for glob 'cuda*'
Note, selecting 'cuda-11-0' for glob 'cuda*'
Note, selecting 'cuda-memcheck-10-0' for glob 'cuda*'
Note, selecting 'cuda-memcheck-10-1' for glob 'cuda*'
Note, selecting 'cuda-memcheck-10-2' for glob 'cuda*'
Note, selecting 'cuda' for glob 'cuda*'
Note, selecting 'cuda-memcheck-11-0' for glob 'cuda*'
Note, selecting 'cuda-cudart-cross-qnx-10-0' for glob 'cuda*'
Note, selecting 'cuda-gdb-src-10-0' for glob 'cuda*'
Note, selecting 'cuda-gdb-src-10-1' for glob 'cuda*'
Note, selecting 'cuda-gdb-src-10-2' for glob 'cuda*'
Note, selecting 'cuda-misc-headers-10-0' for glob 'cuda*'
Note, selecting 'cuda-misc-headers-10-1' for glob 'cuda*'
Note, selecting 'cuda-misc-headers-10-2' for glob 'cuda*'
Note, selecting 'cuda-gdb-src-11-0' for glob 'cuda*'
Note, selecting 'cuda-cuobjdump-10-0' for glob 'cuda*'
Note, selecting 'cuda-cuobjdump-10-1' for glob 'cuda*'
Note, selecting 'cuda-cuobjdump-10-2' for glob 'cuda*'
Note, selecting 'cuda-cuobjdump-11-0' for glob 'cuda*'
Note, selecting 'cuda-nsight-compute-10-0' for glob 'cuda*'
Note, selecting 'cuda-nsight-compute-10-1' for glob 'cuda*'
Note, selecting 'cuda-nsight-compute-10-2' for glob 'cuda*'
Note, selecting 'cuda-nvprof-10-0' for glob 'cuda*'
Note, selecting 'cuda-nvprof-10-1' for glob 'cuda*'
Note, selecting 'cuda-nvprof-10-2' for glob 'cuda*'
Package 'cuda-license-7-5' is not installed, so not removed
Package 'cuda-repo-ubuntu1204' is not installed, so not removed
Package 'cuda-repo-ubuntu1404' is not installed, so not removed
Package 'cuda-repo-ubuntu1404-7-5-local' is not installed, so not removed
Package 'cuda-repo-ubuntu1410' is not installed, so not removed
Package 'cuda-repo-ubuntu1504' is not installed, so not removed
Package 'cuda-repo-ubuntu1504-7-5-local' is not installed, so not removed
Package 'cuda-cudart-cross-qnx-10-0' is not installed, so not removed
Package 'cuda-driver-cross-qnx-10-0' is not installed, so not removed
Package 'cuda-misc-headers-cross-qnx-10-0' is not installed, so not removed
Package 'cuda-cusolver-cross-qnx-10-0' is not installed, so not removed
Package 'cuda-cublas-cross-qnx-10-0' is not installed, so not removed
Package 'cuda-cufft-cross-qnx-10-0' is not installed, so not removed
Package 'cuda-curand-cross-qnx-10-0' is not installed, so not removed
Package 'cuda-cusparse-cross-qnx-10-0' is not installed, so not removed
Package 'cuda-npp-cross-qnx-10-0' is not installed, so not removed
Package 'cuda-10-0' is not installed, so not removed
Package 'cuda-10-1' is not installed, so not removed
Package 'cuda-10-2' is not installed, so not removed
Package 'cuda-command-line-tools-10-0' is not installed, so not removed
Package 'cuda-command-line-tools-10-2' is not installed, so not removed
Package 'cuda-compat-10-0' is not installed, so not removed
Package 'cuda-compiler-10-0' is not installed, so not removed
Package 'cuda-compiler-10-2' is not installed, so not removed
Package 'cuda-core-10-0' is not installed, so not removed
Package 'cuda-core-10-1' is not installed, so not removed
Package 'cuda-core-10-2' is not installed, so not removed
Package 'cuda-cross-qnx-10-0' is not installed, so not removed
Package 'cuda-cross-qnx' is not installed, so not removed
Package 'cuda-cublas-10-0' is not installed, so not removed
Package 'cuda-cublas-dev-10-0' is not installed, so not removed
Package 'cuda-cudart-10-0' is not installed, so not removed
Package 'cuda-cudart-10-2' is not installed, so not removed
Package 'cuda-cudart-dev-10-0' is not installed, so not removed
Package 'cuda-cudart-dev-10-2' is not installed, so not removed
Package 'cuda-cufft-10-0' is not installed, so not removed
Package 'cuda-cufft-10-2' is not installed, so not removed
Package 'cuda-cufft-dev-10-0' is not installed, so not removed
Package 'cuda-cufft-dev-10-2' is not installed, so not removed
Package 'cuda-cuobjdump-10-0' is not installed, so not removed
Package 'cuda-cuobjdump-10-2' is not installed, so not removed
Package 'cuda-cupti-10-0' is not installed, so not removed
Package 'cuda-cupti-10-2' is not installed, so not removed
Package 'cuda-cupti-dev-10-2' is not installed, so not removed
Package 'cuda-curand-10-0' is not installed, so not removed
Package 'cuda-curand-10-2' is not installed, so not removed
Package 'cuda-curand-dev-10-0' is not installed, so not removed
Package 'cuda-curand-dev-10-2' is not installed, so not removed
Package 'cuda-cusolver-10-0' is not installed, so not removed
Package 'cuda-cusolver-10-2' is not installed, so not removed
Package 'cuda-cusolver-dev-10-0' is not installed, so not removed
Package 'cuda-cusolver-dev-10-2' is not installed, so not removed
Package 'cuda-cusparse-10-0' is not installed, so not removed
Package 'cuda-cusparse-10-2' is not installed, so not removed
Package 'cuda-cusparse-dev-10-0' is not installed, so not removed
Package 'cuda-cusparse-dev-10-2' is not installed, so not removed
Package 'cuda-demo-suite-10-0' is not installed, so not removed
Package 'cuda-demo-suite-10-1' is not installed, so not removed
Package 'cuda-demo-suite-10-2' is not installed, so not removed
Package 'cuda-demo-suite-11-0' is not installed, so not removed
Package 'cuda-documentation-10-0' is not installed, so not removed
Package 'cuda-documentation-10-2' is not installed, so not removed
Package 'cuda-driver-dev-10-0' is not installed, so not removed
Package 'cuda-driver-dev-10-2' is not installed, so not removed
Package 'cuda-drivers-diagnostic' is not installed, so not removed
Package 'cuda-gdb-10-0' is not installed, so not removed
Package 'cuda-gdb-10-2' is not installed, so not removed
Package 'cuda-gdb-src-10-0' is not installed, so not removed
Package 'cuda-gdb-src-10-1' is not installed, so not removed
Package 'cuda-gdb-src-10-2' is not installed, so not removed
Package 'cuda-gpu-library-advisor-10-0' is not installed, so not removed
Package 'cuda-libraries-10-0' is not installed, so not removed
Package 'cuda-libraries-10-1' is not installed, so not removed
Package 'cuda-libraries-10-2' is not installed, so not removed
Package 'cuda-libraries-dev-10-0' is not installed, so not removed
Package 'cuda-libraries-dev-10-2' is not installed, so not removed
Package 'cuda-license-10-0' is not installed, so not removed
Package 'cuda-memcheck-10-0' is not installed, so not removed
Package 'cuda-memcheck-10-2' is not installed, so not removed
Package 'cuda-minimal-build-10-0' is not installed, so not removed
Package 'cuda-minimal-build-10-1' is not installed, so not removed
Package 'cuda-minimal-build-10-2' is not installed, so not removed
Package 'cuda-misc-headers-10-0' is not installed, so not removed
Package 'cuda-misc-headers-10-2' is not installed, so not removed
Package 'cuda-npp-10-0' is not installed, so not removed
Package 'cuda-npp-10-2' is not installed, so not removed
Package 'cuda-npp-dev-10-0' is not installed, so not removed
Package 'cuda-npp-dev-10-2' is not installed, so not removed
Package 'cuda-nsight-10-0' is not installed, so not removed
Package 'cuda-nsight-10-2' is not installed, so not removed
Package 'cuda-nsight-compute--10-0' is not installed, so not removed
Package 'cuda-nsight-compute-10-0' is not installed, so not removed
Package 'cuda-nsight-compute-10-2' is not installed, so not removed
Package 'cuda-nsight-systems-10-2' is not installed, so not removed
Package 'cuda-nvcc-10-0' is not installed, so not removed
Package 'cuda-nvcc-10-2' is not installed, so not removed
Package 'cuda-nvdisasm-10-0' is not installed, so not removed
Package 'cuda-nvdisasm-10-2' is not installed, so not removed
Package 'cuda-nvgraph-10-0' is not installed, so not removed
Package 'cuda-nvgraph-10-2' is not installed, so not removed
Package 'cuda-nvgraph-dev-10-0' is not installed, so not removed
Package 'cuda-nvgraph-dev-10-2' is not installed, so not removed
Package 'cuda-nvjpeg-10-0' is not installed, so not removed
Package 'cuda-nvjpeg-10-2' is not installed, so not removed
Package 'cuda-nvjpeg-dev-10-0' is not installed, so not removed
Package 'cuda-nvjpeg-dev-10-2' is not installed, so not removed
Package 'cuda-nvml-dev-10-0' is not installed, so not removed
Package 'cuda-nvml-dev-10-2' is not installed, so not removed
Package 'cuda-nvml-dev-11-0' is not installed, so not removed
Package 'cuda-nvprof-10-0' is not installed, so not removed
Package 'cuda-nvprof-10-2' is not installed, so not removed
Package 'cuda-nvprune-10-0' is not installed, so not removed
Package 'cuda-nvprune-10-2' is not installed, so not removed
Package 'cuda-nvprune-11-0' is not installed, so not removed
Package 'cuda-nvrtc-10-0' is not installed, so not removed
Package 'cuda-nvrtc-10-2' is not installed, so not removed
Package 'cuda-nvrtc-dev-10-0' is not installed, so not removed
Package 'cuda-nvrtc-dev-10-2' is not installed, so not removed
Package 'cuda-nvtx-10-0' is not installed, so not removed
Package 'cuda-nvtx-10-2' is not installed, so not removed
Package 'cuda-nvtx-11-0' is not installed, so not removed
Package 'cuda-nvvp-10-0' is not installed, so not removed
Package 'cuda-nvvp-10-2' is not installed, so not removed
Package 'cuda-repo-ubuntu1804' is not installed, so not removed
Package 'cuda-runtime-10-0' is not installed, so not removed
Package 'cuda-runtime-10-1' is not installed, so not removed
Package 'cuda-runtime-10-2' is not installed, so not removed
Package 'cuda-samples-10-0' is not installed, so not removed
Package 'cuda-samples-10-2' is not installed, so not removed
Package 'cuda-sanitizer-api-10-2' is not installed, so not removed
Package 'cuda-toolkit-10-0' is not installed, so not removed
Package 'cuda-toolkit-10-2' is not installed, so not removed
Package 'cuda-tools-10-0' is not installed, so not removed
Package 'cuda-tools-10-2' is not installed, so not removed
Package 'cuda-visual-tools-10-0' is not installed, so not removed
Package 'cuda-visual-tools-10-2' is not installed, so not removed
Package 'cuda-compat-10-1' is not installed, so not removed
Package 'cuda-drivers-418' is not installed, so not removed
Package 'cuda-compat-10-2' is not installed, so not removed
Package 'cuda-drivers-440' is not installed, so not removed
Package 'cuda-compat-11-0' is not installed, so not removed
Package 'cuda-drivers-450' is not installed, so not removed
Package 'cuda-drivers' is not installed, so not removed
Package 'cuda-11-0' is not installed, so not removed
Package 'cuda' is not installed, so not removed
Package 'cuda-command-line-tools-11-0' is not installed, so not removed
Package 'cuda-compiler-11-0' is not installed, so not removed
Package 'cuda-cudart-11-0' is not installed, so not removed
Package 'cuda-cudart-dev-11-0' is not installed, so not removed
Package 'cuda-cuobjdump-11-0' is not installed, so not removed
Package 'cuda-cupti-11-0' is not installed, so not removed
Package 'cuda-cupti-dev-11-0' is not installed, so not removed
Package 'cuda-documentation-11-0' is not installed, so not removed
Package 'cuda-driver-dev-11-0' is not installed, so not removed
Package 'cuda-gdb-11-0' is not installed, so not removed
Package 'cuda-gdb-src-11-0' is not installed, so not removed
Package 'cuda-libraries-11-0' is not installed, so not removed
Package 'cuda-libraries-dev-11-0' is not installed, so not removed
Package 'cuda-memcheck-11-0' is not installed, so not removed
Package 'cuda-minimal-build-11-0' is not installed, so not removed
Package 'cuda-nsight-11-0' is not installed, so not removed
Package 'cuda-nsight-compute-11-0' is not installed, so not removed
Package 'cuda-nsight-systems-11-0' is not installed, so not removed
Package 'cuda-nvcc-11-0' is not installed, so not removed
Package 'cuda-nvdisasm-11-0' is not installed, so not removed
Package 'cuda-nvprof-11-0' is not installed, so not removed
Package 'cuda-nvrtc-11-0' is not installed, so not removed
Package 'cuda-nvrtc-dev-11-0' is not installed, so not removed
Package 'cuda-nvvp-11-0' is not installed, so not removed
Package 'cuda-runtime-11-0' is not installed, so not removed
Package 'cuda-samples-11-0' is not installed, so not removed
Package 'cuda-sanitizer-11-0' is not installed, so not removed
Package 'cuda-toolkit-11-0' is not installed, so not removed
Package 'cuda-tools-11-0' is not installed, so not removed
Package 'cuda-visual-tools-11-0' is not installed, so not removed
The following packages were automatically installed and are no longer required:
  dkms libatomic1:i386 libbsd0:i386 libdrm-amdgpu1:i386 libdrm-intel1:i386
  libdrm-nouveau2:i386 libdrm-radeon1:i386 libdrm2:i386 libedit2:i386
  libelf1:i386 libexpat1:i386 libffi6:i386 libgl1:i386 libgl1-mesa-dri:i386
  libglapi-mesa:i386 libglvnd0:i386 libglx-mesa0:i386 libglx0:i386
  libllvm10:i386 libnvidia-cfg1-435 libnvidia-common-435
  libnvidia-compute-435:i386 libnvidia-decode-435 libnvidia-decode-435:i386
  libnvidia-encode-435 libnvidia-encode-435:i386 libnvidia-fbc1-435
  libnvidia-fbc1-435:i386 libnvidia-gl-435 libnvidia-gl-435:i386
  libnvidia-ifr1-435 libnvidia-ifr1-435:i386 libpciaccess0:i386
  libsensors4:i386 libstdc++6:i386 libx11-6:i386 libx11-xcb1:i386 libxau6:i386
  libxcb-dri2-0:i386 libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386
  libxcb-sync1:i386 libxcb1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386
  libxfixes3:i386 libxnvctrl0 libxshmfence1:i386 libxxf86vm1:i386
  nsight-compute-2019.5.0 nsight-systems-2019.5.2 screen-resolution-extra
  xserver-xorg-video-nvidia-435
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  cuda-command-line-tools-10-1* cuda-compiler-10-1* cuda-cudart-10-1*
  cuda-cudart-dev-10-1* cuda-cufft-10-1* cuda-cufft-dev-10-1*
  cuda-cuobjdump-10-1* cuda-cupti-10-1* cuda-curand-10-1*
  cuda-curand-dev-10-1* cuda-cusolver-10-1* cuda-cusolver-dev-10-1*
  cuda-cusparse-10-1* cuda-cusparse-dev-10-1* cuda-documentation-10-1*
  cuda-driver-dev-10-1* cuda-gdb-10-1* cuda-gpu-library-advisor-10-1*
  cuda-libraries-dev-10-1* cuda-license-10-1* cuda-license-10-2*
  cuda-memcheck-10-1* cuda-misc-headers-10-1* cuda-npp-10-1*
  cuda-npp-dev-10-1* cuda-nsight-10-1* cuda-nsight-compute-10-1*
  cuda-nsight-systems-10-1* cuda-nvcc-10-1* cuda-nvdisasm-10-1*
  cuda-nvgraph-10-1* cuda-nvgraph-dev-10-1* cuda-nvjpeg-10-1*
  cuda-nvjpeg-dev-10-1* cuda-nvml-dev-10-1* cuda-nvprof-10-1*
  cuda-nvprune-10-1* cuda-nvrtc-10-1* cuda-nvrtc-dev-10-1* cuda-nvtx-10-1*
  cuda-nvvp-10-1* cuda-repo-ubuntu1804-10-1-local-10.1.243-418.87.00*
  cuda-samples-10-1* cuda-sanitizer-api-10-1* cuda-toolkit-10-1*
  cuda-tools-10-1* cuda-visual-tools-10-1* libcublas-dev* libcublas10*
0 upgraded, 0 newly installed, 49 to remove and 0 not upgraded.
After this operation, 5,191 MB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database ... 337730 files and directories currently installed.)
Removing cuda-toolkit-10-1 (10.1.243-1) ...
Removing cuda-tools-10-1 (10.1.243-1) ...
Removing cuda-command-line-tools-10-1 (10.1.243-1) ...
Removing cuda-compiler-10-1 (10.1.243-1) ...
Removing cuda-cupti-10-1 (10.1.243-1) ...
Removing cuda-visual-tools-10-1 (10.1.243-1) ...
Removing cuda-libraries-dev-10-1 (10.1.243-1) ...
Removing cuda-documentation-10-1 (10.1.243-1) ...
Removing cuda-samples-10-1 (10.1.243-1) ...
Removing cuda-cufft-dev-10-1 (10.1.243-1) ...
Removing cuda-cufft-10-1 (10.1.243-1) ...
Removing cuda-gdb-10-1 (10.1.243-1) ...
Removing cuda-cuobjdump-10-1 (10.1.243-1) ...
Removing cuda-curand-dev-10-1 (10.1.243-1) ...
Removing cuda-curand-10-1 (10.1.243-1) ...
Removing cuda-cusolver-dev-10-1 (10.1.243-1) ...
Removing cuda-cusolver-10-1 (10.1.243-1) ...
Removing cuda-cusparse-dev-10-1 (10.1.243-1) ...
Removing cuda-cusparse-10-1 (10.1.243-1) ...
Removing cuda-gpu-library-advisor-10-1 (10.1.243-1) ...
Removing libcublas-dev (10.2.2.89-1) ...
Removing libcublas10 (10.2.2.89-1) ...
Removing cuda-license-10-2 (10.2.89-1) ...
Removing cuda-memcheck-10-1 (10.1.243-1) ...
Removing cuda-nvcc-10-1 (10.1.243-1) ...
Removing cuda-misc-headers-10-1 (10.1.243-1) ...
Removing cuda-npp-dev-10-1 (10.1.243-1) ...
Removing cuda-npp-10-1 (10.1.243-1) ...
Removing cuda-nsight-10-1 (10.1.243-1) ...
Removing cuda-nsight-compute-10-1 (10.1.243-1) ...
Removing cuda-nsight-systems-10-1 (10.1.243-1) ...
Removing cuda-nvdisasm-10-1 (10.1.243-1) ...
Removing cuda-nvgraph-dev-10-1 (10.1.243-1) ...
Removing cuda-nvgraph-10-1 (10.1.243-1) ...
Removing cuda-nvjpeg-dev-10-1 (10.1.243-1) ...
Removing cuda-nvjpeg-10-1 (10.1.243-1) ...
Removing cuda-nvml-dev-10-1 (10.1.243-1) ...
Removing cuda-nvprof-10-1 (10.1.243-1) ...
Removing cuda-nvprune-10-1 (10.1.243-1) ...
dpkg: warning: while removing cuda-nvprune-10-1, directory '/usr/local/cuda-10.1/bin' not empty so not removed
Removing cuda-nvrtc-dev-10-1 (10.1.243-1) ...
Removing cuda-nvrtc-10-1 (10.1.243-1) ...
Removing cuda-nvtx-10-1 (10.1.243-1) ...
Removing cuda-nvvp-10-1 (10.1.243-1) ...
Removing cuda-repo-ubuntu1804-10-1-local-10.1.243-418.87.00 (1.0-1) ...
Removing cuda-sanitizer-api-10-1 (10.1.243-1) ...
Removing cuda-cudart-dev-10-1 (10.1.243-1) ...
Removing cuda-cudart-10-1 (10.1.243-1) ...
Removing cuda-driver-dev-10-1 (10.1.243-1) ...
dpkg: warning: while removing cuda-driver-dev-10-1, directory '/usr/local/cuda-10.1/targets/x86_64-linux/lib' not empty so not removed
Removing cuda-license-10-1 (10.1.243-1) ...
Processing triggers for libc-bin (2.27-3ubuntu1.2) ...
/sbin/ldconfig.real: /usr/local/cuda-10.1/targets/x86_64-linux/lib/libcudnn.so.7 is not a symbolic link

(Reading database ... 325627 files and directories currently installed.)
Purging configuration files for cuda-cupti-10-1 (10.1.243-1) ...
Purging configuration files for cuda-cudart-10-1 (10.1.243-1) ...
Purging configuration files for cuda-nvcc-10-1 (10.1.243-1) ...
Purging configuration files for cuda-cusolver-10-1 (10.1.243-1) ...
Purging configuration files for cuda-repo-ubuntu1804-10-1-local-10.1.243-418.87.00 (1.0-1) ...
Purging configuration files for cuda-nvtx-10-1 (10.1.243-1) ...
Purging configuration files for cuda-curand-10-1 (10.1.243-1) ...
Purging configuration files for cuda-nvgraph-10-1 (10.1.243-1) ...
Purging configuration files for cuda-cudart-dev-10-1 (10.1.243-1) ...
dpkg: warning: while removing cuda-cudart-dev-10-1, directory '/usr/local/cuda-10.1/targets/x86_64-linux/include' not empty so not removed
Purging configuration files for cuda-cusparse-10-1 (10.1.243-1) ...
Purging configuration files for cuda-nvjpeg-10-1 (10.1.243-1) ...
Purging configuration files for cuda-sanitizer-api-10-1 (10.1.243-1) ...
dpkg: warning: while removing cuda-sanitizer-api-10-1, directory '/usr/local/cuda-10.1/extras' not empty so not removed
Purging configuration files for cuda-cufft-10-1 (10.1.243-1) ...
Purging configuration files for cuda-nvprof-10-1 (10.1.243-1) ...
Purging configuration files for cuda-nvrtc-10-1 (10.1.243-1) ...
Purging configuration files for libcublas10 (10.2.2.89-1) ...
Purging configuration files for cuda-npp-10-1 (10.1.243-1) ...
Purging configuration files for cuda-visual-tools-10-1 (10.1.243-1) ...
Purging configuration files for cuda-toolkit-10-1 (10.1.243-1) ...
root@NUS:~# sudo add-apt-repository ppa:graphics-drivers/ppa
 Fresh drivers from upstream, currently shipping Nvidia.

## Current Status

Current long-lived branch release: `nvidia-430` (430.40)
Dropped support for Fermi series (https://nvidia.custhelp.com/app/answers/detail/a_id/4656)

Old long-lived branch release: `nvidia-390` (390.129)

For GF1xx GPUs use `nvidia-390` (390.129)
For G8x, G9x and GT2xx GPUs use `nvidia-340` (340.107)
For NV4x and G7x GPUs use `nvidia-304` (304.137) End-Of-Life!

Support timeframes for Unix legacy GPU releases:
https://nvidia.custhelp.com/app/answers/detail/a_id/3142

## What we're working on right now:

- Normal driver updates
- Help Wanted: Mesa Updates for Intel/AMD users, ping us if you want to help do this work, we're shorthanded.

## WARNINGS:

This PPA is currently in testing, you should be experienced with packaging before you dive in here:

Volunteers welcome!

### How you can help:

## Install PTS and benchmark your gear:

    sudo apt-get install phoronix-test-suite

Run the benchmark:

    phoronix-test-suite default-benchmark openarena xonotic tesseract gputest unigine-valley

and then say yes when it asks you to submit your results to openbechmarking.org. Then grab a cup of coffee, it takes a bit for the benchmarks to run. Depending on the version of Ubuntu you're using it might preferable for you to grabs PTS from upstream directly: http://www.phoronix-test-suite.com/?k=downloads

## Share your results with the community:

Post a link to your results (or any other feedback to): https://launchpad.net/~graphics-drivers-testers

Remember to rerun and resubmit the benchmarks after driver upgrades, this will allow us to gather a bunch of data on performance that we can share with everybody.

If you run into old documentation referring to other PPAs, you can help us by consolidating references to this PPA.

If someone wants to go ahead and start prototyping on `software-properties-gtk` on what the GUI should look like, please start hacking!

## Help us Help You!

We use the donation funds to get the developers hardware to test and upload these drivers, please consider donating to the "community" slider on the donation page if you're loving this PPA:

http://www.ubuntu.com/download/desktop/contribute
 More info: https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa
Press [ENTER] to continue or Ctrl-c to cancel adding it.

Hit:1 https://cloud.r-project.org/bin/linux/ubuntu bionic-cran35/ InRelease
Hit:2 http://sg.archive.ubuntu.com/ubuntu bionic InRelease                     
Hit:3 http://security.ubuntu.com/ubuntu bionic-security InRelease              
Ign:4 http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64  InRelease
Hit:5 http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64  Release
Hit:6 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic InRelease    
Hit:7 http://sg.archive.ubuntu.com/ubuntu bionic-updates InRelease             
Hit:8 http://security.ubuntu.com/ubuntu xenial-security InRelease              
Hit:9 http://sg.archive.ubuntu.com/ubuntu bionic-backports InRelease           
Hit:11 https://packagecloud.io/github/git-lfs/ubuntu bionic InRelease          
Reading package lists... Done 
root@NUS:~# sudo apt install nvidia-driver-435
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  nsight-compute-2019.5.0 nsight-systems-2019.5.2
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  nvidia-compute-utils-435 nvidia-dkms-435 nvidia-kernel-common-435
  nvidia-kernel-source-435 nvidia-prime nvidia-settings nvidia-utils-435
The following NEW packages will be installed:
  nvidia-compute-utils-435 nvidia-dkms-435 nvidia-driver-435
  nvidia-kernel-common-435 nvidia-kernel-source-435 nvidia-prime
  nvidia-settings nvidia-utils-435
0 upgraded, 8 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/14.2 MB of archives.
After this operation, 39.5 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Selecting previously unselected package nvidia-compute-utils-435.
(Reading database ... 325621 files and directories currently installed.)
Preparing to unpack .../0-nvidia-compute-utils-435_435.21-0ubuntu0.18.04.2_amd64.deb ...
Unpacking nvidia-compute-utils-435 (435.21-0ubuntu0.18.04.2) ...
Selecting previously unselected package nvidia-kernel-source-435.
Preparing to unpack .../1-nvidia-kernel-source-435_435.21-0ubuntu0.18.04.2_amd64.deb ...
Unpacking nvidia-kernel-source-435 (435.21-0ubuntu0.18.04.2) ...
Selecting previously unselected package nvidia-kernel-common-435.
Preparing to unpack .../2-nvidia-kernel-common-435_435.21-0ubuntu0.18.04.2_amd64.deb ...
Unpacking nvidia-kernel-common-435 (435.21-0ubuntu0.18.04.2) ...
Selecting previously unselected package nvidia-dkms-435.
Preparing to unpack .../3-nvidia-dkms-435_435.21-0ubuntu0.18.04.2_amd64.deb ...
Unpacking nvidia-dkms-435 (435.21-0ubuntu0.18.04.2) ...
Selecting previously unselected package nvidia-utils-435.
Preparing to unpack .../4-nvidia-utils-435_435.21-0ubuntu0.18.04.2_amd64.deb ...
Unpacking nvidia-utils-435 (435.21-0ubuntu0.18.04.2) ...
Selecting previously unselected package nvidia-driver-435.
Preparing to unpack .../5-nvidia-driver-435_435.21-0ubuntu0.18.04.2_amd64.deb ...
Unpacking nvidia-driver-435 (435.21-0ubuntu0.18.04.2) ...
Selecting previously unselected package nvidia-prime.
Preparing to unpack .../6-nvidia-prime_0.8.8.2_all.deb ...
Unpacking nvidia-prime (0.8.8.2) ...
Selecting previously unselected package nvidia-settings.
Preparing to unpack .../7-nvidia-settings_450.51.05-0ubuntu1_amd64.deb ...
Unpacking nvidia-settings (450.51.05-0ubuntu1) ...
Setting up nvidia-compute-utils-435 (435.21-0ubuntu0.18.04.2) ...
Warning: The home dir /nonexistent you specified can't be accessed: No such file or directory
Adding system user `nvidia-persistenced' (UID 122) ...
Adding new group `nvidia-persistenced' (GID 127) ...
Adding new user `nvidia-persistenced' (UID 122) with group `nvidia-persistenced' ...
Not creating home directory `/nonexistent'.
Setting up nvidia-prime (0.8.8.2) ...
Setting up nvidia-settings (450.51.05-0ubuntu1) ...
Setting up nvidia-utils-435 (435.21-0ubuntu0.18.04.2) ...
Setting up nvidia-kernel-common-435 (435.21-0ubuntu0.18.04.2) ...
update-initramfs: deferring update (trigger activated)
Setting up nvidia-kernel-source-435 (435.21-0ubuntu0.18.04.2) ...
Setting up nvidia-dkms-435 (435.21-0ubuntu0.18.04.2) ...
update-initramfs: deferring update (trigger activated)
INFO:Enable nvidia
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
Loading new nvidia-435.21 DKMS files...
Building for 5.4.0-42-generic
Building for architecture x86_64
Building initial module for 5.4.0-42-generic
ERROR: Cannot create report: [Errno 17] File exists: '/var/crash/nvidia-dkms-435.0.crash'
Error! Bad return status for module build on kernel: 5.4.0-42-generic (x86_64)
Consult /var/lib/dkms/nvidia/435.21/build/make.log for more information.
Setting up nvidia-driver-435 (435.21-0ubuntu0.18.04.2) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.2) ...
Processing triggers for libc-bin (2.27-3ubuntu1.2) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for initramfs-tools (0.130ubuntu3.9) ...
update-initramfs: Generating /boot/initrd.img-5.4.0-42-generic
I: The initramfs will attempt to resume from /dev/sda6
I: (UUID=ac47a98c-8560-4626-8c8e-ebae77b4278d)
I: Set the RESUME variable to override this.
root@NUS:~# sudo apt install --reinstall nvidia-driver-435
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  nsight-compute-2019.5.0 nsight-systems-2019.5.2
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/413 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 326120 files and directories currently installed.)
Preparing to unpack .../nvidia-driver-435_435.21-0ubuntu0.18.04.2_amd64.deb ...
Unpacking nvidia-driver-435 (435.21-0ubuntu0.18.04.2) over (435.21-0ubuntu0.18.04.2) ...
Setting up nvidia-driver-435 (435.21-0ubuntu0.18.04.2) ...
root@NUS:~# sudo dkms install nvidia/435.21 --all
root@NUS:~# dkms status
nvidia, 435.21: added

I have rebooted my computer after the reinstallation for several times already. Makes no difference.

And attached my nvidia-bug-report.log
nvidia-bug-report.log.gz (103.3 KB)

Any help would be highly appreciated!

Janinejl: You had this error about the kernel module, so you may need to try installing this separately.

Check your /lib/modules/5.4.0-42-generic folder to see if there’s a build softlink in there to /usr/src/linux-headers…
If not, you can install with:
sudo apt install linux-headers-5.4.0-42-generic

If you now have a newer /lib/modules/5.X.X-XX-generic, you probably need to install that version.
This worked for me, but it doesn’t seem to be a very permanent fix, because subsequent OS upgrades have necessitated another manual install of the kernel modules.

Not sure if this is still an active thread for assistance, but I am having the issue:
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

Also looking for help. This is on a headless server. I am trying to use the GPU in Docker containers. I have uploaded a bug report.

Thank you.
nvidia-bug-report.log (998.1 KB)

You have a legacy fermi gpu so you’ll have to use the v390 driver.

Thank you. I will try that and report back.

Hi, I have a new Asus Zephyrus G14 laptop with ryzen 4800 HS and gtx 1650. I have been able to install the amd gpu drivers and the nvidia drivers, but I log using the amdgpu driver only. I would like to use the nvidia driver on-demand, like in this post: https://www.reddit.com/r/ZephyrusG14/comments/id4e2d/asus_g14_ubuntu_2004_setup/, but I have not been able. In fact, I have not been able to use the nvidia gpu in any capacity, even though I seem to have installed the drivers. I am running ubuntu 18.04 that I need for ROS development.

$ nvidia-smi
Fri Feb 19 01:09:54 2021
±----------------------------------------------------------------------------+
| NVIDIA-SMI 460.39 Driver Version: 460.39 CUDA Version: 11.2 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
|===============================+======================+======================|
| 0 GeForce GTX 1650 Off | 00000000:01:00.0 Off | N/A |
| N/A 46C P8 1W / N/A | 6MiB / 3911MiB | 0% Default |
| | | N/A |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: |
| GPU GI CI PID Type Process name GPU Memory |
| ID ID Usage |
|=============================================================================|
| 0 N/A N/A 1724 G /usr/lib/xorg/Xorg 4MiB |
±----------------------------------------------------------------------------+

nvidia bug report (actually a compressed file) nvidia-bug-report.txt (284.4 KB)

Please see this:
https://forums.developer.nvidia.com/t/nvidia-xconfig-doesnt-do-what-i-want-it-to-nor-does-nvidia-settings/107883/7?u=generix

This did resolve the issue. However I am onto the next issue. That is Docker wants Cuda 10 or greater. Can I used Cuda-10 with the v390 drivers?

Thank you.

No, Fermi gpus are only supported up until cuda 8.

Thank you.

Hello, I have a similar problem -
“NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.”

Here is the log nvidia-bug-report.log.gz (82.2 KB)
I’ve been trying to make it work for a long time. If possible, would really appreciate some help with this.

There’s no nvidia gpu present in your system. Please make sure it’s properly seated in the pcie slot and all power cords are connected.

Thank you, generix, for your help and your fast reply.

Having similar issue in kernel version 5.4.0-65-generic.
I also have newer kernel versions but after installation they get STUCK at ubuntu and asus BOOT logo.
And nvidia-smi command works fine in recovery mode.
I have turned off my secure boot and have dual boot with windows 10 installed.
Please help, I have been struggling with this for a few days now. I have tried purging nvidia-drivers.
Without nvidia-driver my laptop is consuming a lot of power. If there is no fix, at least tell me a way to manage my power.
Other kernel versions I have:
‘’’
rc linux-image-5.3.0-18-generic 5.3.0-18.19+1 amd64 Signed kernel image generic
rc linux-image-5.3.0-64-generic 5.3.0-64.58 amd64 Signed kernel image generic
ii linux-image-5.4.0-65-generic 5.4.0-65.73 amd64 Signed kernel image generic
ii linux-image-5.4.0-66-generic 5.4.0-66.74 amd64 Signed kernel image generic
ii linux-image-generic 5.4.0.66.69 amd64 Generic Linux kernel image
ii linux-image-unsigned-5.10.0-051000-generic 5.10.0-051000.202012132330 amd64 Linux kernel image for version 5.10.0 on 64 bit x86 SMP
ii linux-image-unsigned-5.11.0-051100-generic 5.11.0-051100.202102142330 amd64 Linux kernel image for version 5.11.0 on 64 bit x86 SMP

‘’’

Also nvidia-settings return
‘’’
ERROR: NVIDIA driver is not loaded

ERROR: Unable to load info from any available system

(nvidia-settings:6092): GLib-GObject-CRITICAL **: 19:29:04.143: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed
** Message: 19:29:04.148: PRIME: No offloading required. Abort
** Message: 19:29:04.148: PRIME: is it supported? no
‘’’
nvidia-bug-report.log.gz (117.0 KB)

Please do a fresh install of Ubuntu 20.04, update,update update, this should bring you to kernel 5.8, then install the nvidia driver using Software&Updates.
Don’t create an xorg.conf.