NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running

I believe that most people have encountered this problem, but I have found a lot of information and finally can not solve my mistake, can you help me? Really anxious death!

Hi there @user155999 and welcome to the NVIDIA developer forums.

I would like to point you to this post: “If you have a problem, PLEASE read this first” in the Linux forums.

Please share your nvidia-bug-report.log.gz with us and we will see what might be the issue.

Good starting points to fixing this are:

  • Purge all NVIDIA drivers and reinstall from scratch, using the Software Manager of Ubuntu. This is the recommended way
  • Check if you have a mismatch in secure boot. If you have secure boot enabled, you need to install and authenticate a certified driver through the Ubuntu installer. Otherwise you need to disable secure boot
  • Check if you have nouveau drivers installed. If yes, black-list them.