NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running

Hi everybody,
After a simple reboot, the NVIDIA-SMI is showing the error listed in the topic.

What I tried was the following ( Nvlinked Titan RTX Chips: NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver - Graphics / Linux / Linux - NVIDIA Developer Forums:

user@alien grep nvidia /etc/modprobe.d/* /lib/modprobe.d/*

which give me an entry in the file blacklist-framebuffer.conf
I removed the following line in that file:

blacklist nvidiafb

then run :

user@alien sudo update-initramfs -u
user@alien sudo reboot

But the problem is still there.
Attached is the ** nvidia-bug-report output**
nvidia-bug-report.log (476.9 KB)

The machine is an Alienware aurore with Ubuntu 21.04 installed (GNU/Linux 5.11.0-34-generic x86_64)
The GPU is an RTX 3090

user@alien sudo lshw -C display

*-display UNCLAIMED
       description: VGA compatible controller
       product: GA102 [GeForce RTX 3090]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:0b:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller cap_list
       configuration: latency=0
       resources: memory:fb000000-fbffffff memory:d0000000-dfffffff memory:e0000000-e1ffffff ioport:e000(size=128) memory:fc000000-fc07ffff
user@alien dkms status nvidia
user@alien mokutil --sb-state
SecureBoot enabled

If anyone knows what happened after that simple system restart (before it all worked perfectly), I would really appreciate the help! :)

Thank you!