NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver


I recently installed Ubuntu 18.04.02 LTS on my HP Zbook with a Nvidia Quadro M1200 inside.
When I tried to connect my external monitor it was discovered but stayed black so I tried to find a solution online but now it is no more discovered.

When I run ‘nvidia-smi’ I get this error message:
‘NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.’

Running ‘sudo ubuntu-drivers devices’ gives this:
‘== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd000013B6sv0000103Csd0000826Dbc03sc00i00
vendor : NVIDIA Corporation
model : GM107GLM [Quadro M1200 Mobile]
driver : nvidia-driver-390 - distro non-free recommended
driver : xserver-xorg-video-nouveau - distro free builtin’

So I installed nvidia-driver-390 and it is used as shown in this picture:

Using nvidia-settings gives:
So it looks like nothing is detected…

I disabled Secure Boot as it was recommanded in several threads but it didn’t change anything.

If you have any idea on how I could solve this issue, I would be very thankful.

nvidia-bug-report.log.gz (71 KB)

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.

The log is now attached to the first post. Sorry I forgot to include it the first time.

Please check if the file
exists, delete it and run
sudo update-initramfs -u
then reboot.

None of them exists on my system even with ‘sudo find -name blacklist-nvidia.conf’.

Though you said you disabled secure boot, it is still enabled:

secureboot: Secure boot enabled

please disable it in bios and if it still doesn’t work create a new nvidia-bug-report.log.

You’re right, don’t know why but secure boot was re-enabled…
Now that it is really disabled it works. Thanks for your time.