Nvidia-smi shows no devices were found although driver is installed

I recently installed my nvidia driver using sudo apt install nvidia-driver-535(this was the recommended option), but when I run nvidia-smi, no devices are found. It is important to mention that I uninstalled all nvidia drivers before installing the current one. These are my specifications and different outputs that may be useful:

|Description:|Ubuntu 22.04.4 LTS|

  • ~$ sudo lspci | grep ‘VGA’
    00:02.0 VGA compatible controller: Intel Corporation CometLake-H GT2 [UHD Graphics] (rev 05)
    01:00.0 VGA compatible controller: NVIDIA Corporation TU104M [GeForce RTX 2070 SUPER Mobile / Max-Q] (rev a1)

  • ~$ dkms status
    nvidia/535.171.04, 6.5.0-26-generic, x86_64: installed
    nvidia/535.171.04, 6.5.0-28-generic, x86_64: installed

  • $ cat /proc/driver/nvidia/version
    NVRM version: NVIDIA UNIX x86_64 Kernel Module 535.171.04 Tue Mar 19 20:30:00 UTC 2024
    GCC version: gcc version 12.3.0 (Ubuntu 12.3.0-1ubuntu1~22.04)

  • $ cat /sys/module/nvidia/version

I’ll attach my bug report here. Thank you in advance.

nvidia-bug-report.log.gz (229.5 KB)

NVRM: GPU 0000:01:00.0: RmInitAdapter failed! (0x24:0x72:1435)
The gpu fails to initialize. Please try an ealier driver, e.g. 470. If that doesn’t work, it might be broken.

Thank you for the suggestion. As requested I tried with the earlier driver, but no success. I attached the new bug report if that helps find any other root causes. Do you still think my hardware is the issue?

nvidia-bug-report.log.gz (232.7 KB)

Yes, I guess the gpu is broken, please check warranty status.

That’s a shame; I’ll have to look into that. And thanks again for all your help.

You might want to install Windows to double-check.

So I tried with windows, but sadly no luck. Thanks again.